Announcement

Collapse
No announcement yet.

9/2/2020: ARK Dev Kit v313.1 is now available on the Epic Launcher

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    The Winter Wonderland has been removed now. Any ETA on the new Binaries?

    Also, had a question about dino colors. If I just want to add new colors and remove a few old colors from the DinoColor_BP For the Mod Extensions, do I still have to create a new dino class? Or can I just copy the BP into the mod folder and it will over ride the original? It defeats the purpose of color mods if you have to recreate all dino's just to change the colors. Also, doing it this way will remove any dino's tamed while the mod was installed if the mod is uninstalled.

    Comment


      Is the new build coming to the Epic Games Launcher?

      I have a lot of work to do so I can fix the nerfing introduced to the game and I need to spawn my dino variants but the current Dev Kit doesn't let me spawn in the wild.

      Comment


        Originally posted by Archie Vision View Post
        The Winter Wonderland has been removed now. Any ETA on the new Binaries?

        Also, had a question about dino colors. If I just want to add new colors and remove a few old colors from the DinoColor_BP For the Mod Extensions, do I still have to create a new dino class? Or can I just copy the BP into the mod folder and it will over ride the original? It defeats the purpose of color mods if you have to recreate all dino's just to change the colors. Also, doing it this way will remove any dino's tamed while the mod was installed if the mod is uninstalled.
        The binaries are up to date, what we need is the content update, which will probably be available within a couple of days, hopefully a week at most.
        Workshop: My Workshop
        ARK Modding Discord Admin: Join here!

        Comment


          I'm trying to load the landscape sublevel map, its no longer showing up in the content browser and instead its a material instance.... I checked in the explorer window and landscapesublevel.umap is there.




          When I try to open it, I get a dev kit crash..


          Assertion failed: CollisionHeightData.GetElementCount() == FMath::Square(CollisionSizeVerts) [File:F:\UE4\UnrealEngine\Engine\Source\Runtime\Engine\Private\Landscape\LandscapeCollision.cpp] [Line: 328]



          KERNELBASE.dll!UnknownFunction (0x000007fefd929e5d) + 0 bytes [UnknownFile:0]
          UE4Editor-Core.dll!UnknownFunction (0x000007fee5921174) + 0 bytes [UnknownFile:0]
          UE4Editor-Core.dll!UnknownFunction (0x000007fee5839168) + 0 bytes [UnknownFile:0]
          UE4Editor-Core.dll!UnknownFunction (0x000007fee5804d02) + 0 bytes [UnknownFile:0]
          UE4Editor-Engine.dll!UnknownFunction (0x000007fee35a66fe) + 0 bytes [UnknownFile:0]
          UE4Editor-Engine.dll!UnknownFunction (0x000007fee35a8843) + 0 bytes [UnknownFile:0]
          UE4Editor-Engine.dll!UnknownFunction (0x000007fee35dd80c) + 0 bytes [UnknownFile:0]
          UE4Editor-CoreUObject.dll!UnknownFunction (0x000007fee542555e) + 0 bytes [UnknownFile:0]
          UE4Editor-CoreUObject.dll!UnknownFunction (0x000007fee548dad6) + 0 bytes [UnknownFile:0]
          UE4Editor-CoreUObject.dll!UnknownFunction (0x000007fee5498c5d) + 0 bytes [UnknownFile:0]
          UE4Editor-CoreUObject.dll!UnknownFunction (0x000007fee54a0a1b) + 0 bytes [UnknownFile:0]
          UE4Editor-CoreUObject.dll!UnknownFunction (0x000007fee54a5ce4) + 0 bytes [UnknownFile:0]
          UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed7c740b7) + 0 bytes [UnknownFile:0]
          UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed7ccb702) + 0 bytes [UnknownFile:0]
          UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed7c57633) + 0 bytes [UnknownFile:0]
          UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed7c612a8) + 0 bytes [UnknownFile:0]
          UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed7cd7994) + 0 bytes [UnknownFile:0]
          UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed7c50706) + 0 bytes [UnknownFile:0]
          UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed7c5f30b) + 0 bytes [UnknownFile:0]
          UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed7c5c9f6) + 0 bytes [UnknownFile:0]
          UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed7cec84f) + 0 bytes [UnknownFile:0]
          UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed7cd7bdf) + 0 bytes [UnknownFile:0]
          UE4Editor-Slate.dll!UnknownFunction (0x000007fee22ec595) + 0 bytes [UnknownFile:0]
          UE4Editor-Slate.dll!UnknownFunction (0x000007fee22d8500) + 0 bytes [UnknownFile:0]
          UE4Editor-Core.dll!UnknownFunction (0x000007fee58a4278) + 0 bytes [UnknownFile:0]
          UE4Editor-Core.dll!UnknownFunction (0x000007fee58894db) + 0 bytes [UnknownFile:0]
          UE4Editor-Core.dll!UnknownFunction (0x000007fee58a5599) + 0 bytes [UnknownFile:0]
          UE4Editor-Core.dll!UnknownFunction (0x000007fee5884972) + 0 bytes [UnknownFile:0]
          USER32.dll!UnknownFunction (0x00000000778b9bd1) + 0 bytes [UnknownFile:0]
          USER32.dll!UnknownFunction (0x00000000778b98da) + 0 bytes [UnknownFile:0]
          UE4Editor-Core.dll!UnknownFunction (0x000007fee58a5a56) + 0 bytes [UnknownFile:0]
          UE4Editor.exe!UnknownFunction (0x000000013f9993c2) + 0 bytes [UnknownFile:0]
          UE4Editor.exe!UnknownFunction (0x000000013f98ed0f) + 0 bytes [UnknownFile:0]
          UE4Editor.exe!UnknownFunction (0x000000013f98ed7a) + 0 bytes [UnknownFile:0]
          UE4Editor.exe!UnknownFunction (0x000000013f99abe0) + 0 bytes [UnknownFile:0]
          UE4Editor.exe!UnknownFunction (0x000000013f99bb19) + 0 bytes [UnknownFile:0]
          kernel32.dll!UnknownFunction (0x000000007779652d) + 0 bytes [UnknownFile:0]
          ntdll.dll!UnknownFunction (0x00000000779cc541) + 0 bytes [UnknownFile:0]
          ntdll.dll!UnknownFunction (0x00000000779cc541) + 0 bytes [UnknownFile:0]
          Last edited by SakuraSammi; 01-07-2016, 01:01 AM.
          My Mods - Cute Hair | Fun Vaults | xTcR Island | Invisible Turret Blocker
          My Servers - I have many servers running. Main server below.


          Find the rest of my servers at
          xTcR.Net Servers
          The Ark Life PVP Server

          Comment


            Argh, 3.2GB's. D@mn < Why is that filtered :|. I knew it was going to be large with like 7 major version changes since the last one but, ugh, well time to stop uTorrent for a little bit. :c lol.

            -WM
            Workshop: My Workshop
            ARK Modding Discord Admin: Join here!

            Comment


              Yeah this new update to the dev kit broke a lot of things

              here is what happens when trying to open theisland

              Click image for larger version

Name:	646757e257.jpg
Views:	1
Size:	563.8 KB
ID:	1098129
              My Mods - Cute Hair | Fun Vaults | xTcR Island | Invisible Turret Blocker
              My Servers - I have many servers running. Main server below.


              Find the rest of my servers at
              xTcR.Net Servers
              The Ark Life PVP Server

              Comment


                Originally posted by SakuraSammi View Post
                Yeah this new update to the dev kit broke a lot of things

                here is what happens when trying to open theisland
                Since when is that the file used to load TheIsland map?

                File > Open Level > IslandSubMaps > Scroll Down to TheIsland(Level)... ?

                -WM
                Workshop: My Workshop
                ARK Modding Discord Admin: Join here!

                Comment


                  Originally posted by WoefulMacabre View Post
                  Since when is that the file used to load TheIsland map?

                  File > Open Level > IslandSubMaps > Scroll Down to TheIsland(Level)... ?

                  -WM
                  Thats what he is saying, its no longer a level file. Its showing up as a generated blueprint class file. (Look at the screenshot again)

                  Comment


                    Originally posted by jslay View Post
                    Thats what he is saying, its no longer a level file. Its showing up as a generated blueprint class file. (Look at the screenshot again)
                    That's not what he said but no point to arguing semantics, I've never opened the levels from the browser so to me those files have always been there.

                    I'm in the process of downloading the content update now, wondering if it's a content or binary issue... most likely a content issue as I doubt the devkit could alter that many files like that on load without noticing it.
                    -
                    WM
                    Workshop: My Workshop
                    ARK Modding Discord Admin: Join here!

                    Comment


                      Originally posted by WoefulMacabre View Post
                      That's not what he said but no point to arguing semantics, I've never opened the levels from the browser so to me those files have always been there.
                      but... you are arguing semantics just there.

                      Not sure why everything between you and everyone else that tries to help has to be an argument or a competition. really doesn't help much for anyone. other people do have good information too.

                      My bad, thats what his image implies

                      I'll just refrain from trying to help in any post where you are to avoid this conflict from now on. gl sakura.
                      Last edited by jslay; 01-07-2016, 04:23 AM.

                      Comment


                        Got the same problem as Sakura. Map files look corrupted. The LandscapeSublevel does not shop up in the content browser at all despite the file being there. I also noticed the LandscapeSublevel.umap is now almost 2GB in size? It was at about 350mb before. Is that intended?
                        Last edited by Mezzow; 01-07-2016, 03:22 AM.
                        ARKModding.net Wiki --- ARKModding.net: Resource Collection, BP Snippets --- ADK Tutorial/Example Blueprint Collection on github --- Tutorial: Adding custom MultiUse(Radial) menu entry/action --- My Steam Workshop

                        Comment


                          Originally posted by Mezzow View Post
                          Got the same problem as Sakura. Map files look corrupted. The LandscapeSublevel does not shop up in the content browser at all despite the file being there. I also noticed the LandscapeSublevel.umap is now almost 2GB in size? It was at about 350mb before. Is that intended?
                          Looks like it was the new content thing they put out. without the new content and just the binaries, it looks fine. Thanks to jslay for helping me out with that.
                          My Mods - Cute Hair | Fun Vaults | xTcR Island | Invisible Turret Blocker
                          My Servers - I have many servers running. Main server below.


                          Find the rest of my servers at
                          xTcR.Net Servers
                          The Ark Life PVP Server

                          Comment


                            Yup, the Map files were corrupted. Sorry about that, the fixed Content is now uploaded as well.

                            Will get it posted on the Epic Launcher later today too.

                            Cheers,
                            Drake

                            Comment


                              new update of the devkit from epic launcher just keeps freezing everytime i try to open a Primalgamedata BP or hit play it freeze and i have to end task
                              Last edited by spezz; 01-07-2016, 03:00 PM.
                              My MODS: Ark Advance | Ark Steampunk Mod

                              Comment


                                The new Dev Kit keeps freezing every time I try to copy the generic mod PrimalGameData_BP_GenericMod, impossible to make any mod now.

                                Also in game my dino variants are not spawning in the wild, I used the summon command and it didn't work then I used the spawndino command and it worked, after using the spawndino command the summon command started working wtf?

                                In short:
                                The last Dev Kit from Epic Games Launcher is NOT working, freezes before you can edit anything.

                                Comment

                                Working...
                                X