Announcement

Collapse
No announcement yet.

9/2/2020: ARK Dev Kit v313.1 is now available on the Epic Launcher

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Cant make a copy of the Simple_TerrainGenerator_BP, get errors on saving. Click image for larger version

Name:	3kmBXdu.png
Views:	1
Size:	29.2 KB
ID:	1117544
    Cant compile changes to an function (Generate Terrain) implemented in a child of Simple_TerrainGenerator_BP because variables are marked as private. Click image for larger version

Name:	iVDNXUs.png
Views:	1
Size:	225.1 KB
ID:	1117543
    Temporary solution is to create new variables to use instead of the private ones, but it also means re-implementing any function that uses the variables to use the new ones. Also, I can't be sure that the underlying c++ code will break because they use the original variables.
    Last edited by Artanys; 10-26-2016, 05:06 PM.

    Leave a comment:


  • replied
    Originally posted by Mezzow View Post
    @Finedragon: You need BOTH content diff from google drive AND the files from github! One or the other won't work, they belong together. Also if you manually update DON'T do verifying or really anything through the launcher.

    For more detailed instructions please take the time and read this thread. It feels like i wrote this 100 times already This same question comes up at least one or two times after every update and if people would just check back one or two pages the whole thread could be half as long and twice as clear.
    Or... you know... just actually read the entirety of the first part of the post, which is only a couple of lines:

    Originally posted by StudioWildcard
    The ARK Dev Kit v248.4 has been posted to the GitHub ( https://github.com/StudioWildcard1/Ark-Dev-Kit ) to download on top of the Epic Launcher build, and you can download the v248 Content Diff to extract on top of the Epic Launcher build here: https://drive.google.com/file/d/0Bwk...ew?usp=sharing (this link has the previously-missing PGARK map necessary to test custom Procedural Generators)
    But that seems to be too much for some people most days...

    -WM

    Leave a comment:


  • replied
    [MENTION=464842]Finedragon[/MENTION]: You need BOTH content diff from google drive AND the files from github! One or the other won't work, they belong together. Also if you manually update DON'T do verifying or really anything through the launcher.

    For more detailed instructions please take the time and read this thread. It feels like i wrote this 100 times already This same question comes up at least one or two times after every update and if people would just check back one or two pages the whole thread could be half as long and twice as clear.

    Leave a comment:


  • replied
    Could I get a little assistance with this. This is the first time I have updated my Dev Kit in this fashion and seemed to have missed something. I downloaded the file through Google Drive and copied it to my DevKit folder. When I go in I'm still showing Version247.8 and got the white models of the Dodowyvern. I tried to verify to see if that did anything but I am still showing my old version and no luck with the Dodowyvern. I looked through the Gitbub option but I'm not 100% sure how to go with that route. Normally I just wait for the Devkit to update through the launcher but I really want to mess around with the Dodowyvern.

    Leave a comment:


  • replied
    Originally posted by MagixTS View Post
    Any ETA on when this will be available to download from the Epic Games launcher? I have downloaded the content diff three times now after each update and still have a bunch of issues in the devkit.



    Opening a terrain generator blueprint give an error along the lines of "the parent class of this subclass does not exist".
    What about the actual devkit update binaries? You getting those? Make sure you are also adding the "PackageInfo.bin" There is nothign wrong with the files so it must be something with how you are doing it

    Leave a comment:


  • replied
    Something with tracing is broken on servers again since one of the latest patches. Not 100% sure which one but one of the last 2.
    I've been using box components as origins for the spawn transform for projectiles and as of now, the projectiles are only spawning at ground level and always go to the right. Only on a server. They work normally in singleplayer.
    Also, the drop crates and lasers I have as a matinee in a map extension which has been working fine for almost a year now is also having issues. Again server only. The crates and lasers always spawn at 50/50
    Last edited by P0k3r; 10-25-2016, 03:20 PM.

    Leave a comment:


  • replied
    Originally posted by MagixTS View Post
    Any ETA on when this will be available to download from the Epic Games launcher? I have downloaded the content diff three times now after each update and still have a bunch of issues in the devkit.



    Opening a terrain generator blueprint give an error along the lines of "the parent class of this subclass does not exist".
    Ok now have the right version 248.4 but still the same problem/error me too...

    Leave a comment:


  • replied
    Confused

    Originally posted by StudioWildcard View Post
    Does your DevKit indicate v248.4? (i.e. do you have the updated binaries? It took them a bit for us to put on GitHub )

    Cheers,
    Jeremy
    I can't find anything by your link to GitHub .. Give me the error 404 page no found of GitHub... Anyway I downloaded the one by google drive ( v248.4 - 1.8 GB ) but no sure were do I have to install it properly... When I start DEV KIT and I try to open the PGark i have this message






    followed by this one





    If You look on the top right of the second Image You' ll see that the version of the DEV KIT Still 247.8... So where I have to install properly all the files? Which directory I mind ?

    Leave a comment:


  • replied
    Originally posted by StudioWildcard View Post
    Does your DevKit indicate v248.4? (i.e. do you have the updated binaries? It took them a bit for us to put on GitHub )

    Cheers,
    Jeremy
    yea, all good now. must have been lucky enough to just miss binaries i guess

    Leave a comment:


  • replied
    Any ETA on when this will be available to download from the Epic Games launcher? I have downloaded the content diff three times now after each update and still have a bunch of issues in the devkit.

    The following member variables in blueprint 'Blueprint /Game/PrimalEarth/CoreBlueprints/TerrainGenerators/Simple_TerrainGenerator_BP.Simple_TerrainGenerator_BP' have invalid type. Would you like to remove them?

    Deep Water Objects
    Grass
    Ocean Biomes
    NPCManager Jungle
    Player Starts
    NPCManager Water
    Snow Materials
    Trees
    Inland Water Objects
    Jungle Grass
    Jungle Trees
    Mountain Grass
    Mountain Trees
    Red Wood Grass
    Red Wood Trees
    Snow Grass
    Snow Trees
    NPCManager Snow
    NPCManager Ocean
    Jungle Biomes
    Snow Biomes
    Generic Water Biomes
    NPCManager Red Wood
    Red Wood Biomes
    NPCManager Grass Lands
    Grass Lands Biomes
    Supply Drop Settings
    Supply Drop Points
    Snow Mountain Grass
    Snow Mountain Trees
    NPCManager Mountains
    Mountains Biomes
    NPCManager Deep Water
    Shoreline Objects
    Snow Shoreline
    Underwater Objects
    Deep Water Biomes
    NPCManager Shoreline
    NPCManager Snow Shoreline
    NPCManager Snow Mountains
    Snow Mountains Biomes
    Opening a terrain generator blueprint give an error along the lines of "the parent class of this subclass does not exist".

    Leave a comment:


  • replied
    Dev kit is still taking hours and hours to cook simple map extensions. Currently trying to cook a PGARK extension, containing the empty TerrainGeneratorOverride map and 4 blueprints. Shader compilers have been running full blast for the past 4 hours, with no indication of progress.

    Leave a comment:


  • replied
    Originally posted by Nimrod_Z View Post
    i'm getting compiler errors in BP's for diplocaulus and kaprosachus.
    Does your DevKit indicate v248.4? (i.e. do you have the updated binaries? It took them a bit for us to put on GitHub )

    Cheers,
    Jeremy

    Leave a comment:


  • replied
    Originally posted by Artanys View Post
    The PGARK level was not included in the 248.4 patch, can't create any PGARK mods.
    Ahh, sorry about that! The Content link is now fixed to include the PGARK level, which is here:
    https://drive.google.com/file/d/0Bwk...ew?usp=sharing

    -Jeremy

    Leave a comment:


  • replied
    The PGARK level was not included in the 248.4 patch, can't create any PGARK mods.

    Leave a comment:


  • replied
    i'm getting compiler errors in BP's for diplocaulus and kaprosachus.

    Leave a comment:

Working...
X