Announcement

Collapse
No announcement yet.

7/20: ARK Dev Kit v297.2 is now available on the Epic Games Launcher

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Speaking of, is there a proper order in which to copy over first? Binaries then differing content? or the other way around?

    Comment


      #47
      Originally posted by jslay View Post
      Speaking of, is there a proper order in which to copy over first? Binaries then differing content? or the other way around?
      Doesn't matter which, as they affect different files (GitHub and the Google Drive ZIP).

      Thank you so much jslay. The GitHub + Google Drive content seems good to us here (i.e. no crashes or animation problems and correct latest content), but once confirmed by someone from the community, we'll get the Epic Launcher updated.

      Cheers,
      Drake

      Comment


        #48
        Getting a crash when compiling, but the cooker keeps going. So Im gunna let it finish, kick it off again, and get a screenshot for you.

        Code:
        Ensure condition failed: bValidRootIndex [File:F:\UE4\UnrealEngine\Engine\Source\Runtime\Engine\Private\Animation\AnimBlueprintGeneratedClass.cpp] [Line: 219] 
        
        
        
        Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff
        
        UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f4eb92a) + 0 bytes [UnknownFile:0]
        UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f4eca57) + 0 bytes [UnknownFile:0]
        UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f4f0b2b) + 0 bytes [UnknownFile:0]
        UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f4d2601) + 0 bytes [UnknownFile:0]
        UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f4de4b1) + 0 bytes [UnknownFile:0]
        UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1a6354) + 0 bytes [UnknownFile:0]
        UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1ed7cd) + 0 bytes [UnknownFile:0]
        UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1023fa) + 0 bytes [UnknownFile:0]
        UE4Editor.exe!UnknownFunction (0x00007ff7563fa821) + 0 bytes [UnknownFile:0]
        UE4Editor.exe!UnknownFunction (0x00007ff7563fa715) + 0 bytes [UnknownFile:0]
        UE4Editor.exe!UnknownFunction (0x00007ff7563fce42) + 0 bytes [UnknownFile:0]
        UE4Editor.exe!UnknownFunction (0x00007ff7563fed44) + 0 bytes [UnknownFile:0]
        UE4Editor.exe!UnknownFunction (0x00007ff7563fed7a) + 0 bytes [UnknownFile:0]
        UE4Editor.exe!UnknownFunction (0x00007ff75640ab40) + 0 bytes [UnknownFile:0]
        UE4Editor.exe!UnknownFunction (0x00007ff75640ba79) + 0 bytes [UnknownFile:0]
        KERNEL32.DLL!UnknownFunction (0x00007ff86b378102) + 0 bytes [UnknownFile:0]
        ntdll.dll!UnknownFunction (0x00007ff86d42c264) + 0 bytes [UnknownFile:0]
        ntdll.dll!UnknownFunction (0x00007ff86d42c264) + 0 bytes [UnknownFile:0]
        Doing a verify with the launcher to see where that gets me. This will take some time.
        Last edited by jslay; 11-29-2015, 06:44 PM.

        Comment


          #49
          Also, it would be really nice if there would be a way to get tribe ownership information off what an admin is looking at so that they can set the ownership of stuff properly without making it personal owner when they do give all structure/ give to me.

          Structure ownership can be a real pain when transferring tribes or something like that and if it gets messed up, not much anyone can do but destroy, replace mats, and rebuild. Unless I am missing something.

          Comment


            #50
            Compiled fine after verifying, Replacing with new files and trying again. And yes, cont walking ani was fixed.

            New files in place. Cooking mod now...



            This also crashes PIE

            First Crash
            Code:
            Ensure condition failed: bValidRootIndex [File:F:\UE4\UnrealEngine\Engine\Source\Runtime\Engine\Private\Animation\AnimBlueprintGeneratedClass.cpp] [Line: 219] 
            
            
            
            Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff
            
            UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f53b92a) + 0 bytes [UnknownFile:0]
            UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f53ca57) + 0 bytes [UnknownFile:0]
            UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f540b2b) + 0 bytes [UnknownFile:0]
            UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f522601) + 0 bytes [UnknownFile:0]
            UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f52e4b1) + 0 bytes [UnknownFile:0]
            UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1a6354) + 0 bytes [UnknownFile:0]
            UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1ed7cd) + 0 bytes [UnknownFile:0]
            UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1023fa) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c6a821) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c6a715) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c6ce42) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c6ed44) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c6ed7a) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c7ab40) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c7ba79) + 0 bytes [UnknownFile:0]
            KERNEL32.DLL!UnknownFunction (0x00007ff86b378102) + 0 bytes [UnknownFile:0]
            ntdll.dll!UnknownFunction (0x00007ff86d42c264) + 0 bytes [UnknownFile:0]
            ntdll.dll!UnknownFunction (0x00007ff86d42c264) + 0 bytes [UnknownFile:0]

            Second Crash (appears to be the same as first):
            Code:
            Ensure condition failed: bValidRootIndex [File:F:\UE4\UnrealEngine\Engine\Source\Runtime\Engine\Private\Animation\AnimBlueprintGeneratedClass.cpp] [Line: 219] 
            
            
            
            Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff
            
            UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f53b92a) + 0 bytes [UnknownFile:0]
            UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f53ca57) + 0 bytes [UnknownFile:0]
            UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f540b2b) + 0 bytes [UnknownFile:0]
            UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f522601) + 0 bytes [UnknownFile:0]
            UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f52e4b1) + 0 bytes [UnknownFile:0]
            UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1a6354) + 0 bytes [UnknownFile:0]
            UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1ed7cd) + 0 bytes [UnknownFile:0]
            UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1023fa) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c6a821) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c6a715) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c6ce42) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c6ed44) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c6ed7a) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c7ab40) + 0 bytes [UnknownFile:0]
            UE4Editor.exe!UnknownFunction (0x00007ff791c7ba79) + 0 bytes [UnknownFile:0]
            KERNEL32.DLL!UnknownFunction (0x00007ff86b378102) + 0 bytes [UnknownFile:0]
            ntdll.dll!UnknownFunction (0x00007ff86d42c264) + 0 bytes [UnknownFile:0]
            ntdll.dll!UnknownFunction (0x00007ff86d42c264) + 0 bytes [UnknownFile:0]
            Verifying again to get back to a good build.
            Last edited by jslay; 11-29-2015, 07:50 PM.

            Comment


              #51
              Try getting the latest binaries from GitHub (still referred to as v224.5). One of the 'uplugin' files was out of date, which was messing it up to cause that crash. Please let us know how it goes, thanks!

              -Drake

              Comment


                #52
                Will do once it finishes verifying. :P

                Want to have a fresh good build to upgrade from.

                Comment


                  #53
                  Originally posted by jslay View Post
                  Will do once it finishes verifying. :P

                  Want to have a fresh good build to upgrade from.
                  Thank you

                  Comment


                    #54
                    Originally posted by StudioWildcard View Post
                    Try getting the latest binaries from GitHub (still referred to as v224.5). One of the 'uplugin' files was out of date, which was messing it up to cause that crash. Please let us know how it goes, thanks!

                    -Drake
                    Drake, please look into the penguin, angler, and deepwater spawner that the (Plesio is mapped to); when they are remapped with a copied version of those spawners they never stop spawning dinos, i had 80k angler fish and 20k penguins on the map, i had to remove the mapping of those spawners and just remap the NPCs.

                    As for the current build i will be testing here in 10min
                    DinoOverhaul X CLICK HERE

                    Comment


                      #55
                      Crashes appear to be fixed, but getting the cont walking ani again. (Which I can deal with)

                      Comment


                        #56
                        Originally posted by M1k3_C View Post
                        Drake, please look into the penguin, angler, and deepwater spawner that the (Plesio is mapped to); when they are remapped with a copied version of those spawners they never stop spawning dinos, i had 80k angler fish and 20k penguins on the map, i had to remove the mapping of those spawners and just remap the NPCs.
                        Yeah for now, those spawners (and the mosasaurus spawners) are set to specifically limit those classes of dinosaurs, so the Spawner Remapping would cause problems unless you are explicitly also remapping those NPC's. We'll look into handling it a bit differently for those spawners to allow them to be more broadly remapped. But we have an even better system coming up next week: the capability for Mods specifically, to override OR add new sublevels of 'TheIsland' -- which will allow Mod authors to directly revise or enhance whatever aspects of TheIsland they choose without limitation! (currently only a TC or entirely new map can effectively do this)

                        -Drake

                        Comment


                          #57
                          Originally posted by jslay View Post
                          Crashes appear to be fixed, but getting the cont walking ani again.
                          I think that's because Verifying with the Epic Launcher would have clobbered your Content files (if you extract them once again from the zip they should be fine). Seems like we're good, we'll go ahead and get the Epic Launcher updated asap

                          Comment


                            #58
                            Drake,
                            The animations seem to be fine, but as you can see by this screen shot http://postimg.org/image/7e3ndbpmd/full/ the meshes are still not showing correct and those dinos do not work correctly in PIE.
                            DinoOverhaul X CLICK HERE

                            Comment


                              #59
                              current github files and content are doing this while compiling. Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	91.2 KB
ID:	1094222

                              Current as of a couple hours ago. Also just tried compiling other projects and they failed with the same error as well. Redownloading github files right now to ensure I have the newer ones.
                              Last edited by hogscraper; 11-29-2015, 08:58 PM.

                              Comment


                                #60
                                Originally posted by hogscraper View Post
                                current github files and content are doing this while compiling. [ATTACH=CONFIG]68101[/ATTACH]

                                Current as of a couple hours ago.
                                Hogscraper, we just updated the GitHub files < 1 hour ago with the fix for that, as far as I can tell.

                                M1k3_C, that is due to the content in the Epic Launcher being oudated. If you extract this content over it, it should work:
                                https://drive.google.com/file/d/0B0d...ew?usp=sharing


                                I think we need to get the DevKit on the Epic Launcher updated to ensure everyone is in sync

                                -Drake

                                Comment

                                Working...
                                X