Announcement

Collapse
No announcement yet.

4/8/2020: ARK Dev Kit v310.1 is now available on the Epic Launcher

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Could I get a little assistance with this. This is the first time I have updated my Dev Kit in this fashion and seemed to have missed something. I downloaded the file through Google Drive and copied it to my DevKit folder. When I go in I'm still showing Version247.8 and got the white models of the Dodowyvern. I tried to verify to see if that did anything but I am still showing my old version and no luck with the Dodowyvern. I looked through the Gitbub option but I'm not 100% sure how to go with that route. Normally I just wait for the Devkit to update through the launcher but I really want to mess around with the Dodowyvern.

    Leave a comment:


  • replied
    Originally posted by MagixTS View Post
    Any ETA on when this will be available to download from the Epic Games launcher? I have downloaded the content diff three times now after each update and still have a bunch of issues in the devkit.



    Opening a terrain generator blueprint give an error along the lines of "the parent class of this subclass does not exist".
    What about the actual devkit update binaries? You getting those? Make sure you are also adding the "PackageInfo.bin" There is nothign wrong with the files so it must be something with how you are doing it

    Leave a comment:


  • replied
    Something with tracing is broken on servers again since one of the latest patches. Not 100% sure which one but one of the last 2.
    I've been using box components as origins for the spawn transform for projectiles and as of now, the projectiles are only spawning at ground level and always go to the right. Only on a server. They work normally in singleplayer.
    Also, the drop crates and lasers I have as a matinee in a map extension which has been working fine for almost a year now is also having issues. Again server only. The crates and lasers always spawn at 50/50
    Last edited by P0k3r; 10-25-2016, 03:20 PM.

    Leave a comment:


  • replied
    Originally posted by MagixTS View Post
    Any ETA on when this will be available to download from the Epic Games launcher? I have downloaded the content diff three times now after each update and still have a bunch of issues in the devkit.



    Opening a terrain generator blueprint give an error along the lines of "the parent class of this subclass does not exist".
    Ok now have the right version 248.4 but still the same problem/error me too...

    Leave a comment:


  • replied
    Confused

    Originally posted by StudioWildcard View Post
    Does your DevKit indicate v248.4? (i.e. do you have the updated binaries? It took them a bit for us to put on GitHub )

    Cheers,
    Jeremy
    I can't find anything by your link to GitHub .. Give me the error 404 page no found of GitHub... Anyway I downloaded the one by google drive ( v248.4 - 1.8 GB ) but no sure were do I have to install it properly... When I start DEV KIT and I try to open the PGark i have this message






    followed by this one





    If You look on the top right of the second Image You' ll see that the version of the DEV KIT Still 247.8... So where I have to install properly all the files? Which directory I mind ?

    Leave a comment:


  • replied
    Originally posted by StudioWildcard View Post
    Does your DevKit indicate v248.4? (i.e. do you have the updated binaries? It took them a bit for us to put on GitHub )

    Cheers,
    Jeremy
    yea, all good now. must have been lucky enough to just miss binaries i guess

    Leave a comment:


  • replied
    Any ETA on when this will be available to download from the Epic Games launcher? I have downloaded the content diff three times now after each update and still have a bunch of issues in the devkit.

    The following member variables in blueprint 'Blueprint /Game/PrimalEarth/CoreBlueprints/TerrainGenerators/Simple_TerrainGenerator_BP.Simple_TerrainGenerator_BP' have invalid type. Would you like to remove them?

    Deep Water Objects
    Grass
    Ocean Biomes
    NPCManager Jungle
    Player Starts
    NPCManager Water
    Snow Materials
    Trees
    Inland Water Objects
    Jungle Grass
    Jungle Trees
    Mountain Grass
    Mountain Trees
    Red Wood Grass
    Red Wood Trees
    Snow Grass
    Snow Trees
    NPCManager Snow
    NPCManager Ocean
    Jungle Biomes
    Snow Biomes
    Generic Water Biomes
    NPCManager Red Wood
    Red Wood Biomes
    NPCManager Grass Lands
    Grass Lands Biomes
    Supply Drop Settings
    Supply Drop Points
    Snow Mountain Grass
    Snow Mountain Trees
    NPCManager Mountains
    Mountains Biomes
    NPCManager Deep Water
    Shoreline Objects
    Snow Shoreline
    Underwater Objects
    Deep Water Biomes
    NPCManager Shoreline
    NPCManager Snow Shoreline
    NPCManager Snow Mountains
    Snow Mountains Biomes
    Opening a terrain generator blueprint give an error along the lines of "the parent class of this subclass does not exist".

    Leave a comment:


  • replied
    Dev kit is still taking hours and hours to cook simple map extensions. Currently trying to cook a PGARK extension, containing the empty TerrainGeneratorOverride map and 4 blueprints. Shader compilers have been running full blast for the past 4 hours, with no indication of progress.

    Leave a comment:


  • replied
    Originally posted by Nimrod_Z View Post
    i'm getting compiler errors in BP's for diplocaulus and kaprosachus.
    Does your DevKit indicate v248.4? (i.e. do you have the updated binaries? It took them a bit for us to put on GitHub )

    Cheers,
    Jeremy

    Leave a comment:


  • replied
    Originally posted by Artanys View Post
    The PGARK level was not included in the 248.4 patch, can't create any PGARK mods.
    Ahh, sorry about that! The Content link is now fixed to include the PGARK level, which is here:
    https://drive.google.com/file/d/0Bwk...ew?usp=sharing

    -Jeremy

    Leave a comment:


  • replied
    The PGARK level was not included in the 248.4 patch, can't create any PGARK mods.

    Leave a comment:


  • replied
    i'm getting compiler errors in BP's for diplocaulus and kaprosachus.

    Leave a comment:


  • replied
    there are still a lot of missing files and I still do't know why the editor has to cook everyhting for even a small mod but it does seem to cook quicker.

    Leave a comment:


  • replied
    Today Epic Launcer needed to do another ARK Dev Kit Update, while I first did this manually with github and later came the epic launcer update. So it was all done, but now another update, but I don't read anywhere what this last small update was all about, or I must overread something somewhere.

    Leave a comment:


  • replied
    I'm getting this Error, when cooking a Mod.

    Code:
    Assertion failed: NumRemoved == 1 [File:C:\SVN_Ark\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectHash.cpp] [Line: 481] 
    
    VERSION: 0.0 
    KERNELBASE.dll!UnknownFunction (0x00007ffc4ca87788) + 0 bytes [UnknownFile:0]
    UE4Editor-Core.dll!UnknownFunction (0x00007ffc1f5c7204) + 0 bytes [UnknownFile:0]
    UE4Editor-Core.dll!UnknownFunction (0x00007ffc1f4df2b8) + 0 bytes [UnknownFile:0]
    UE4Editor-Core.dll!UnknownFunction (0x00007ffc1f4ab0b2) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ffc43c1fcea) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ffc43c0f208) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ffc43b92916) + 0 bytes [UnknownFile:0]
    UE4Editor-Engine.dll!UnknownFunction (0x00007ffc162876ee) + 0 bytes [UnknownFile:0]
    UE4Editor-Engine.dll!UnknownFunction (0x00007ffc164e8c9e) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ffc43b98e04) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ffc43adf69d) + 0 bytes [UnknownFile:0]
    UE4Editor-UnrealEd.dll!UnknownFunction (0x00007ffc14efacc8) + 0 bytes [UnknownFile:0]
    UE4Editor-UnrealEd.dll!UnknownFunction (0x00007ffc14f361d2) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff7d2aa650f) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff7d2a9f57c) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff7d2a9f6da) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff7d2aabb40) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff7d2aaca89) + 0 bytes [UnknownFile:0]
    KERNEL32.DLL!UnknownFunction (0x00007ffc4dff8364) + 0 bytes [UnknownFile:0]
    ntdll.dll!UnknownFunction (0x00007ffc4f835e91) + 0 bytes [UnknownFile:0]
    ntdll.dll!UnknownFunction (0x00007ffc4f835e91) + 0 bytes [UnknownFile:0]
    I tried this 3 times now and already verified files between try 2 and 3, but still this error. I also downloaded and replaces this "ActorMacros.uasset" file.
    It always happens at the same position:
    Code:
    LogCookCommandlet-Display: Cooking /Game/Mods/MyMod/PrimalEarth/General/M_Snow -> ../.../.../ModTools/Output/MyMod/LinuxNoEditor_STAGING/MyMod/PrimalEarth/General/M_Snow.uasset
    LogSavePackageDisplay: No exports found (or all exports are editor-only) for M_SNow. Package will not be saved.
    After clicking ok, the cooking keeps going on. No crash. And in the end it is saying successful. But I have doubts it was really successfull with an Error like this.


    Someone an idea?


    PS:
    It's just a simple Stack-Mod. Only things I changed since last successful cooking:
    - Updated DevKit to newest Version (247.8)
    - Added Wyvern Milk to the Stack-Mod

    EDIT:
    Looks like the issue is gone after pc restart.
    Maybe it was also a overclocking issue. I changed something a few days ago....
    Last edited by McBane87; 09-30-2016, 04:41 PM.

    Leave a comment:

Working...
X