Announcement

Collapse
No announcement yet.

Re-Enable Underground Building

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Re-Enable Underground Building

    I have been working on a map that has an entire cave system. And I am trying to figure out how to re-enable the underground aka cave building. I am guessing it determines whether you are under a landscape layer and blocks it?

    Any help would be greatly appreciated.

    #2
    I'd suggest you take a look at how caves are done on the Island, assuming you have enabled cave building in your .ini file.

    There will be some kind of bounding box/physics volume... the absence of which is probably causing actors to get nuked by the code.

    Comment


      #3
      Ive gone over as much as I can in regards to how Prevent Structure is done, to a degree, it allows the building under the landscape, but once you hit a certain distance in, the floor just no longer allows building.

      I am trying to figure out what is causing it, its almost as if there is a Z axis under landscape prevention.

      I loaded up all of my levels and checked them one by one for any accidental copies, really my entire cave system is a set of static meshes, I am trying to find settings on the mesh themselves to make them function as the terrain level, I have changed collisions and messed with tons of Z axis settings and Build Prevention settings. Even went into the foundations themselves and found other options that look like they might work, but no luck.

      I was hoping I could get a response from one of the Studio Wildcard guys at least letting me know if I am wasting my time or not. I am assuming that since the server command line to enable cave building in PVE exists that the actual variable I want to use may not be available from within the dev kit.

      Any other ideas would be great. I added you on steam earlier as well, and would love to bounce ideas back and forth if you have some time later as well.

      Comment


        #4
        Structure prevention zone, then hit disable in details. That did it for me.
        Last edited by mandave98; 10-17-2015, 12:42 PM.
        Valhalla Map

        Comment

        Working...
        X