Announcement

Collapse
No announcement yet.

Importing models causing crashes...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Importing models causing crashes...

    here's the thing, sometimes the model file will import just fine without a issue, other times it just crashes, but, it can be the exact same model file...

    i.e. Import model: crash, import same model, no changes to file: it worked, next time, crash.... there doesn't seem to be any rhyme or reason to why its crashing on the model import.

    Here is the dump from the latest crash:

    Assertion failed: ChartB.Join[ Side ^ 1 ] == i [File:\UE4\UnrealEngine\Engine\Source\Developer\MeshUtilities\Private\LayoutUV.cpp] [Line: 374]

    KERNELBASE.dll!UnknownFunction (0x00007ff982a08b9c) + 0 bytes [UnknownFile:0]
    UE4Editor-Core.dll!UnknownFunction (0x00007ff95d9709a4) + 0 bytes [UnknownFile:0]
    UE4Editor-Core.dll!UnknownFunction (0x00007ff95d8889a8) + 0 bytes [UnknownFile:0]
    UE4Editor-Core.dll!UnknownFunction (0x00007ff95d854942) + 0 bytes [UnknownFile:0]
    UE4Editor-MeshUtilities.dll!UnknownFunction (0x00007ff94f9e78c4) + 0 bytes [UnknownFile:0]
    UE4Editor-MeshUtilities.dll!UnknownFunction (0x00007ff94f9d3fb7) + 0 bytes [UnknownFile:0]
    UE4Editor-Engine.dll!UnknownFunction (0x00007ff9545e73f7) + 0 bytes [UnknownFile:0]
    UE4Editor-Engine.dll!UnknownFunction (0x00007ff9545e7b4b) + 0 bytes [UnknownFile:0]
    UE4Editor-Engine.dll!UnknownFunction (0x00007ff95466f95a) + 0 bytes [UnknownFile:0]
    UE4Editor-UnrealEd.dll!UnknownFunction (0x00007ff95780408f) + 0 bytes [UnknownFile:0]
    UE4Editor-UnrealEd.dll!UnknownFunction (0x00007ff9577e069e) + 0 bytes [UnknownFile:0]
    UE4Editor-UnrealEd.dll!UnknownFunction (0x00007ff95778c737) + 0 bytes [UnknownFile:0]
    UE4Editor-AssetTools.dll!UnknownFunction (0x00007ff94ea5569c) + 0 bytes [UnknownFile:0]
    UE4Editor-AssetTools.dll!UnknownFunction (0x00007ff94ea54283) + 0 bytes [UnknownFile:0]
    UE4Editor-ContentBrowser.dll!UnknownFunction (0x00007ff94ac959e1) + 0 bytes [UnknownFile:0]
    UE4Editor-ContentBrowser.dll!UnknownFunction (0x00007ff94ac51f2f) + 0 bytes [UnknownFile:0]
    UE4Editor-Slate.dll!UnknownFunction (0x00007ff9584442fa) + 0 bytes [UnknownFile:0]
    UE4Editor-Slate.dll!UnknownFunction (0x00007ff9584771f2) + 0 bytes [UnknownFile:0]
    UE4Editor-Slate.dll!UnknownFunction (0x00007ff95839d46c) + 0 bytes [UnknownFile:0]
    UE4Editor-Slate.dll!UnknownFunction (0x00007ff958389376) + 0 bytes [UnknownFile:0]
    UE4Editor-Core.dll!UnknownFunction (0x00007ff95d8f3c49) + 0 bytes [UnknownFile:0]
    UE4Editor-Core.dll!UnknownFunction (0x00007ff95d8d8d1b) + 0 bytes [UnknownFile:0]
    UE4Editor-Core.dll!UnknownFunction (0x00007ff95d8f4dc9) + 0 bytes [UnknownFile:0]
    UE4Editor-Core.dll!UnknownFunction (0x00007ff95d8d41b2) + 0 bytes [UnknownFile:0]
    USER32.dll!UnknownFunction (0x00007ff98522250d) + 0 bytes [UnknownFile:0]
    USER32.dll!UnknownFunction (0x00007ff985222367) + 0 bytes [UnknownFile:0]
    UE4Editor-Core.dll!UnknownFunction (0x00007ff95d8f5286) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff677899242) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff67788ed0f) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff67788ed7a) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff67789aa60) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff67789b999) + 0 bytes [UnknownFile:0]
    KERNEL32.DLL!UnknownFunction (0x00007ff984f313d2) + 0 bytes [UnknownFile:0]
    ntdll.dll!UnknownFunction (0x00007ff9868f5454) + 0 bytes [UnknownFile:0]
    ntdll.dll!UnknownFunction (0x00007ff9868f5454) + 0 bytes [UnknownFile:0]

    based on the starting line of the dump, I thought it was because of the UV map layout, so I redid the UV map, exported it to a new file, same thing happens, thus far I have 3 models I've created that 'sometimes' will import, other times crashing with a similar message. Like I said, no consistancy to why its happening.

    #2
    maybe using the sticky topic regarding this issue.. ? https://forums.unrealengine.com/show...-fixed-in-v207!
    Creator of Mods and The ArkModding Server, Check out our Community

    Comment


      #3
      Being im not getting a 'bad name call stack' error, I doubt its the same issue.

      Comment


        #4
        maybe but it could have something to do with the current issues, idk sorry its been along day..
        Creator of Mods and The ArkModding Server, Check out our Community

        Comment


          #5
          could possibly, just figured sense it didn't sound like the same thing best to make a new thread about it

          Comment


            #6
            found a way to keep it from happening, which honestly doesn't make any sense to me... but... If importing a model and your getting a crash screen when doing it, go back into your model editor, rotate the model 90 degrees toward the ground plane (i.e. if it were a standing person, so their face is flat on the ground plane) then export your model as a fbx again.... oddly, doing this stops the engine from crashing when importing.... again, doesn't really make sense, and imports it just the way you see it in your editor so... yeah...

            Be nice to see this fixed, like exporting things in the right orientation from the start.

            Comment

            Working...
            X