Announcement

Collapse
No announcement yet.

To The Devs / Moderators

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    To The Devs / Moderators

    I guess I may have been expecting some announcement to the modders about the new system, converting their old project to the new format, etc. At the very least, how it would impact current mods that are out there.

    For those that don't know, if you had a server running this mod using 'ActiveMods' in the .ini, it wont run this mod after the new update. If you had custom items in which people stored things, they are lost. While this may seem inconsequential to some, the impact is felt heavily with a mod that has a ton of custom items. I guess advanced notice would have been nice so server owners running mods could have prepared and had their players store things in containers that weren't custom. I know this is alpha so I expect these things to happen. I just happen to think the blow could have been lessened a bit with a simple "Mods will not load as an 'ActiveMod' when going to 200. Please prepare!" My apologies if I missed something but I can't find any info on the points above.

    How do you load TC mods that aren't SOTF? Do you load it the same way you would SOTF ( 'TotalConversionMod' ) but with a different ID? Can that same setting be used in the 'ini? Are older mods backwards compatible with the 'TotalConversionMod' parameter?

    Don't take this as a rant or someone who is ungrateful. Just feedback for the next major release. Thanks for everything you are doing and continue to do!
    Wildcard Mod Liaison | Creator of Primitive+ Survival

    #2
    Wow... just wow.
    100% agree.

    I am really not looking forward to launching my server
    I had custom containers that people used...

    .ETA.
    I've loaded my server up... My mod still works, my containers and their contents are still there.
    Perhaps it was the way the mod was made that made it incompatible?
    Last edited by Sovaka; 08-14-2015, 07:21 PM.

    Comment


      #3
      https://forums.unrealengine.com/show...oming-tomorrow!

      The info and release coming tomorrow should help explain all this to us

      As for that issue with the containers, I have a feeling as Sovaka mentioned it is probably exclusive to your situation with your mod setup potentially.
      Last edited by TTVWobby_Funkel; 08-14-2015, 07:51 PM.

      Comment


        #4
        The mod doesn't even load using the 'ActiveMods' line in the .ini. I'm not sure how he was loading his mod. As for the way the mod was setup, I am sure it was using the correct structure (didnt use the master items list, used additional resources to add custom items, etc). I think the issue is that I can't even get the mod to load with the modification in the .ini.

        It is a custom game mode that restricts engrams to only those in the mod. I used the override named engrams list to specify which engrams/items were in the game. Perhaps this didn't affect people who had custom game modes or restricted engrams?
        Wildcard Mod Liaison | Creator of Primitive+ Survival

        Comment


          #5
          maybe they just delete the command for the ini (or a bug in it), use the good old command line to try

          Comment


            #6
            Originally posted by wazalop View Post
            maybe they just delete the command for the ini (or a bug in it), use the good old command line to try
            so your mod works when using commandline? Maybe the issue is that the 'ActiveMods' .ini doesn't work like it used to and not anything to do with the mod. I could see that as a possibility.
            Wildcard Mod Liaison | Creator of Primitive+ Survival

            Comment


              #7
              i don't have a mod myself but it seem sovaka one work. that's why i did guess that maybe with the new system for loading total conversion mod they maybe have change the ini config

              Comment


                #8
                You are correct. Looks like its an issue that's catching attention in the Steam forums.
                Wildcard Mod Liaison | Creator of Primitive+ Survival

                Comment


                  #9
                  Originally posted by wazalop View Post
                  i don't have a mod myself but it seem sovaka one work. that's why i did guess that maybe with the new system for loading total conversion mod they maybe have change the ini config
                  I don't know for sure, but I have a feeling Waza is on the right train of thought with this. Probably prep for TC release tomorrow :P

                  Comment


                    #10
                    With my mod, it is still launched on the dedicated server with the ActiveMods line in the INI.
                    I'm not doing anything special to launch my mod.

                    Comment


                      #11
                      Why are you not taking a full backup before doing any sort of change to the server? I would think that would be the very first step you take before you apply updates!

                      Comment


                        #12
                        Probably a dead horse, but I just thought I would mention that my mod is working fine on 200.2 as well. I ran it all day yesterday using the old manual launch script (.bat file), and this morning I installed the new Super Launch Tool thing whatever the eff it's called, and it's launching the server + mod with no issues as well. Everything is working as expected. v200.2

                        If you're having issues, it's not everyone, it's something specific to your Mod most likely.

                        Comment

                        Working...
                        X