Announcement

Collapse
No announcement yet.

[TUTORIAL] Import FBX Blenderfiles into ARK Dev Kit (for Static Meshes)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [TUTORIAL] Import FBX Blenderfiles into ARK Dev Kit (for Static Meshes)

    Who like to know, how to export FBX Blenderfiles right, read my tutorial "How to export Blender FBX Files into the ARK Dev Kit" (under Beginner Section): https://forums.unrealengine.com/show...-skill-levels!

    After opening the ARK Dev Kit, we'll see the default screen:


    First we prepare ourself for import the Blender FBX file. Go to the Content Browser (watch above). Open the Mods folder there and create a new folder. Click on the "New" button on the left top corner of the content browser. And choose "new folder" there. Name it, like you want.
    Attention! : It is not allowed to have free space in your folder name, like "My Mod". It should be written: "MyMod", My-Mod" or "My_Mod".


    Now click on "import" at the content browser, navigate to your blendermade FBX file and open it.




    As soon as you opened it, the "FBX Import Options" window will pop up.


    Under "Mesh" you should uncheck the "Import as Skeletal". Because the mentioned FBX file is a Static Mesh. The "Auto Generate Collision" is not working for Static Meshes. You can uncheck it. But you can also leave it, as it is. It has no impact. I say more about Static Mesh Collision to a later point of this tutorial.
    The other checkboxes you can leave as it is, too. At last click on "Import" or "Import all". I percieved no difference.



    After the Engine imported the Assets, you will see, there are no textures imported. The Materials are empty. No problem. We manage that manually.




    So, navigate to your textures for your Static Mesh Actor. Do it via Drag & Drop, where your Static Mesh Actor and your Materials are.
    Click image for larger version

Name:	importcomplet.jpg
Views:	1
Size:	306.2 KB
ID:	1159291


    Now, double click your Static Mesh Actor. The Static Mesh Editor will open.
    Click image for larger version

Name:	materialeditor2.jpg
Views:	1
Size:	231.5 KB
ID:	1159292


    As you can see on "Details" on the right side, there are the materials. In this case 3. To assign the textures for these materials, double click on them. The Material Editor will open.
    Click image for larger version

Name:	materialnodes.jpg
Views:	1
Size:	281.6 KB
ID:	1159296



    In the center of the Material Editor, we have a node system, we will work with. First, delete the "Constant3Vector"-Node, called "none". Now press the T-Key and clicking on a free place, while holding the T-Key. Do it twice. Now we will have two "Texture Sample" Nodes. One for the texture itself and one for the Bump-Map or Normal-Map.
    Click image for larger version

Name:	materialnodes_3.jpg
Views:	1
Size:	300.6 KB
ID:	1159297



    To assign the right textures with that nodes, go to the left side under "Details" to the "Material Expression Texture Base". There you click on the rolldown menu for "Texture" and search for your appropriate textures. After that step, connect the Texture Sample Nodes with your "Material Main Node". The Texture into the "Base Color", and your Normal/Bump-Map into the "Normal" connector.
    Click image for larger version

Name:	material_node5.jpg
Views:	1
Size:	379.3 KB
ID:	1159298



    Don't forget to save at last! After that, you can close the Material Editor. And you can repeat with your other materials for your Static mesh Actor, if it has more.

    Click image for larger version

Name:	tut_fertig.jpg
Views:	1
Size:	358.8 KB
ID:	1159299



    Now, you can use your Static Mesh. But beware, it won't have any Collision-algorythm. Nevermind, you did Auto-Collision check or not. You can change this, manually for every single Static Mesh, when you choose "Block All" intead of "No Collsion" on your Collision Parameters.
    Click image for larger version

Name:	blockall.jpg
Views:	1
Size:	409.7 KB
ID:	1159300

    I am not aware, how to enable this for instanced foliages ... but as soon as I know a way, i will say, how it works.

    Have fun
    Last edited by Vertebrat; 08-12-2015, 12:46 PM.

    #2
    Awesome tutorial!!! This will go a long way for many people!

    Comment


      #3
      Do you know how to export skeleton meshes with Blender (my problem: nobinded Arms from the Rifle skeleton)

      Comment


        #4
        For now, I don't know that. But As soon as I know, I will make a tutorial about

        Comment


          #5
          I am trying to import a 3d model I made in blender into the dev kit. Everytime I click import it gets to 96% and Unreal Engine stops responding. What am I doing wrong?

          Comment


            #6
            Sorry for being absent for months. I had to organize a stronger machine to keep on modding.

            This crash can be caused by more than one single issue. First: Try to use Blender 2.74 or v.2.75a, instead of the newest blender build.

            Than have a look, on my tutorial how to export .fbx files
            from blender (before importing them into the Ark Dev Kit). https://forums.unrealengine.com/show...C-MESH-only%29

            As soon as you (or everyone else) have tried out and/or checked everything I mentioned above, it should be working.

            Regards
            Vert

            Comment

            Working...
            X