Announcement

Collapse
No announcement yet.

Getting TestGameMode settings to be used in PIE

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Getting TestGameMode settings to be used in PIE

    Hi all,

    You know all those settings in TestGameMode... DifficultyValue, DinoDamageMultiplier?

    Anyone know how to make those settings activate in PIE... or at least set them in PIE for testing purposes?

    #2
    Originally posted by JasonFJ View Post
    Hi all,

    You know all those settings in TestGameMode... DifficultyValue, DinoDamageMultiplier?

    Anyone know how to make those settings activate in PIE... or at least set them in PIE for testing purposes?
    Example: you are testing on TheIsland, then you would need to remap the GameModeClass array to your custom GameModeClass under World Settings on TheIsland's umap.

    Hope this helps

    - Sinari

    Comment


      #3
      Hmm gave that a try, but after further testing it seems that PIE is using *selective* settings from GameMode.

      What I do after I load my mod umap, is change the Force Load Map Name to "TestMap" as it's a fast map/sandbox to test stuff out in.
      It seemed that my custom GameMode settings (which are linked out of PrimalGameData) didn't stick (according to showmyadminmanager command, and also based on what I can spawn).

      I then disabled dynamic music in GameMode... and that *does* work correctly.

      So it appears GameMode file is being read by PIE... but not using the settings like DinoDamageMultiplier etc.

      Thought there might be some trick to it... I did try setting the GameMode to my custom one in the TestMap... but same result. Also, in the Scene Outliner (top right corner) the custom GameMode is active.

      Anyone else have any ideas? Otherwise I guess it's a "feature" for now

      Comment

      Working...
      X