Announcement

Collapse
No announcement yet.

HOWTO: Add new structure variants

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I found out that you need to make your own structure for crafting your items and use it instead of the vanilla structure in the examples above.OR avoid it all together and have them craftable on the character.

    Leave a comment:


  • replied
    Originally posted by LuapYllier View Post
    Post number 18 above https://forums.unrealengine.com/show...l=1#post393957

    I have done this for my set of new items going into the smithy and another set into the fabricator. It all works perfectly in the editor but when I get into single player the folder I added with my items only exists on a brand new smithy or fabricator that is placed. if you leave the game and come back then the folder no longer shows. I assume that this translates to the folders disappearing on server restart in an online server. Has anyone else come across this?
    I just came across the same problem. My new item is only craftable in a newly created smithy, not existing ones and if the server is rebooted the new item disappears from that smithy too.

    Regards,

    Les

    Leave a comment:


  • replied
    Post number 18 above https://forums.unrealengine.com/show...l=1#post393957

    I have done this for my set of new items going into the smithy and another set into the fabricator. It all works perfectly in the editor but when I get into single player the folder I added with my items only exists on a brand new smithy or fabricator that is placed. if you leave the game and come back then the folder no longer shows. I assume that this translates to the folders disappearing on server restart in an online server. Has anyone else come across this?

    Leave a comment:


  • replied
    I remade the whole thing out of a different object copy...works fine now. Thanks.

    Leave a comment:


  • replied
    Originally posted by LuapYllier View Post
    I see...well Every item I have made I selected copy. They still seem to have parents.
    Everything still has a parent, they always will. The problem comes from making a child of something instead of copying it as it inherits everything from its parent, however, the tap seems to be an exception in this case. Odd.

    -WM

    Leave a comment:


  • replied
    I see...well Every item I have made I selected copy. They still seem to have parents.

    Leave a comment:


  • replied
    Originally posted by LuapYllier View Post
    6.1.2. Right-click delete PrimalInventoryBP_StandingTorch

    I am attempting to do this on a copy of the water tap object and I am not able to. The hover tip that pops up on mine says "Inherited PrimalInventory..." and the details tab when click on the asset shows no information at all. When I right-click the inventory component delete is grayed out. I am thinking this has something to do with the parenting but hoping you can make it more clear. The result is that I have no option to delete the inventory. I don't even want to replace it. I just want no inventory on this item. Please help.
    You can't delete components from Childs, only copies.

    -WM

    Leave a comment:


  • replied
    6.1.2. Right-click delete PrimalInventoryBP_StandingTorch

    I am attempting to do this on a copy of the water tap object and I am not able to. The hover tip that pops up on mine says "Inherited PrimalInventory..." and the details tab when click on the asset shows no information at all. When I right-click the inventory component delete is grayed out. I am thinking this has something to do with the parenting but hoping you can make it more clear. The result is that I have no option to delete the inventory. I don't even want to replace it. I just want no inventory on this item. Please help.

    Leave a comment:


  • replied
    Thank you Ionic_ovrdose for that info.

    Also a huge thank you to DerfK2 post #18 for that incredibly useful info...That needs to be coppied into the OP for sure.

    I think I am making some headway here, Thanks again.

    Leave a comment:


  • replied
    When you open any blueprint (file inside editor) the window that pops up will have the compile and save buttons in the top left

    Leave a comment:


  • replied
    Hi, yes I am a complete nub. Dumbest question ever but how do you compile and save? You have it after practically everything you do and I am literally trying this tutorial as the first thing I am doing in the editor. I am just attempting to make a copy of a simple metal pipe. I see save options all over the place but I have yet to find the compile or understand what it does.
    Thanks.

    Leave a comment:


  • replied
    Ok, I'm new to this whole modding thing, but I'm having an...interesting phenomenon. I followed the steps in this post to a T and now when I try to place my modded item, instead of placing it, it is consumed like food or ammo. Any ideas on why this happen?

    Leave a comment:


  • replied
    Originally posted by duke54 View Post
    I would not be able to mod without instructions like there so thanks a lot.

    In step 5.3 it says to change the field to MyStandingTorch_Placement_Emitter, but there's no preceeding step where we actually make that emitter, so can I just leave the field with the default "GenericStructurePlacementEmitter"? I'm wondering if the generic emitter is best to use when creating new structures.
    These instructions are kind of old, I think a few things may have changed since this was written. I did not edit the placement spawn emitter on my fabricator and it works 100%.

    Edit:
    After looking at the placement spawn emitter, it appears it mainly just determines the sound and generates the little puff of dust that is generated when you place the item. Only reason I can see you would need to edit that one is if you wanted to change or disable the sound & the puff.

    Also, from what I have experienced so far with my limited experience is that you really only need to copy/link the files you will be editing. If you are not editing that particular reference, it seems to be fine if you leave it default.
    Last edited by P0k3r; 12-09-2015, 09:15 PM.

    Leave a comment:


  • replied
    I would not be able to mod without instructions like these so thanks a lot, Also thanks to DerfK2 for additional info above on making items craftable inside a crafting station.

    In step 5.3 it says to change the field to MyStandingTorch_Placement_Emitter, but there's no preceding step where we actually make that emitter, so I just kept the default "GenericStructurePlacementEmitter", and the mod works fine.

    Also, step 6.2.2., I think it "MUST match items in 5.2.1" only at the beginning of the list, with new items at the end of the list since you also want additional items allowed in the inventory that are not fuel, right?

    To Exilog's point, an early tutorial (here) from the ARK dev's had us add items directly to the "Master Item List" and add blueprints to "Engram Blueprint Classes." According to the video, engrams appear in the game in the same order in which they appear in "Engram Blueprint Classes", so that's how you can organize them. Maybe new items are added to the master list, and only new structures need to be placed in "Additional Structures to Place"?
    Last edited by duke54; 12-10-2015, 10:38 PM.

    Leave a comment:


  • replied
    Originally posted by xPreeMode View Post
    for me it wont work :/ i tried it with Torch and Storage box but somehow im not able to place the items.. anyone have a idea what im doing wrong?
    Make sure you did the step: "2.2 Expand Additional Structures to Place, click +, and add your MyStandingTorch" in your PrimalGameData_BP_Yourmod.

    And also" "5.4. Locate Structure->Consumes Primal Item, and change it to PrimalItemStructure_MyStandingTorch"

    The two things above will prevent the crafted item from being placed.

    I built a mini fabricator using this guide for a mod I'm working on and it works 100% perfect. Make sure you have done every step and it should work without issues.
    Last edited by P0k3r; 12-08-2015, 09:38 AM.

    Leave a comment:

Working...
X