Announcement

Collapse
No announcement yet.

trying to mod player - what step(s) did I miss?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    FIXED: thanks BlueFreakQ you were correct I just needed to use the ARK path instead of the ArkDevKit path - correct path below, don't know if this is just an issue for PlayerPawn or other things also.

    ARK/Projects/ShooterGame/Saved/SavedArksLocal and renaming 'TheIsland.ark' to 'TheIsland.ark.old1'

    Leave a comment:


  • replied
    Originally posted by 3ndoflin3 View Post
    Thanks for the suggestion BlueFreakQ, I tried just now as you suggested clearing out the files under
    ArkDevKit/Projects/ShooterGame/Saved/SavedArksLocal and renaming 'TheIsland.ark' to 'TheIsland.ark.old1' and starting the game but same issue. Let me know if its the wrong saved file path,etc.
    This honestly sounds like another case of missing references. This is a very common issue actually if you forgot to change even a single reference. I have a feeling something was missed along the way, cause god only knows I've missed a few myself here & there lol.

    Leave a comment:


  • replied
    Thanks for the suggestion BlueFreakQ, I tried just now as you suggested clearing out the files under
    ArkDevKit/Projects/ShooterGame/Saved/SavedArksLocal and renaming 'TheIsland.ark' to 'TheIsland.ark.old1' and starting the game but same issue. Let me know if its the wrong saved file path,etc.

    Leave a comment:


  • replied
    Hi,

    Not sure if this is the issue here or not, but when I was making playpawns, the same kept happening to me, it just seemed like non of the changes worked. The issue was saved data in my local ark saves folder, once i cleared my save files the player pawns worked. It might be worth a check, just make sure you make a backup copy in case you want those saves back.

    ~Q~

    Leave a comment:


  • replied
    do yours also not loading the modded primal game data and only loading the original?
    It displays the mod name in the main menu, but the player pawn changes I was trying to effect(increasing the player speed) through the files have no effect.

    Leave a comment:


  • replied
    mine does the same and i have done the exact same thing as you have done except i maded my gamedata and gamemode as child do yours also not loading the modded primal game data and only loading the original?
    Last edited by Dirty_Nightmare; 07-25-2015, 03:25 PM.

    Leave a comment:


  • started a topic trying to mod player - what step(s) did I miss?

    trying to mod player - what step(s) did I miss?

    I can mod the player pawn in-editor(say setting movement speed to x10) and it works fine but not after cooking/upload - that never happens to anyone else I bet The game says that the mod(RM3) is loaded when checking the main menu, but I do not see any of the player changes taking effect. What step(s) did I miss or get wrong?

    Here are the steps as pulled from other threads and videos

    1) Copy and uniquely rename contents of 'GenericMod' - so say my mod uses suffix 'RM3' so these get copied to mod 'RM3' folder as

    GenericMod_RM3
    PrimalGameData_BP_GenericMod_RM3
    TestGameMode_GenericMod_RM3

    2) Copy and uniquely rename from the game files to my mod 'RM3' the PlayerPawn files

    PlayerPawnTest_RM3
    PlayerPawnTest_Male_RM3
    PlayerPawnTest_Female_RM3

    3) Reparent PlayerPawnTest_Male_RM3, PlayerPawnTest_Female_RM3 to PlayerPawnTest_RM3

    4) Modify say movement speed to 10 in all 3 pawn files(not sure if only needed in PlayerPawnTest, but setting all 3 just in case)
    Character Movement->Max Speed Multiplier = 10

    5) In my GenericMod_RM3 level:
    a)change 'Primal Game Data Override' to PrimalGameData_BP_GenericMod_RM3
    b)check 'Force Load Map Name' is set to 'TheIsland'

    6)In my PrimalGameData_BP_GenericMod_RM3
    a)change 'Mod Name', 'Mod Description' to my mod name(RM3) and description(my RM3 mod)
    a)change 'Player Character Gender Definitions'->0(male) and 1(female)->Character Blueprint to my mod male(PlayerPawnTest_Male_RM3) and female(PlayerPawnTest_Female_RM3) pawn files
    b)change 'Default Game Mode' to my TestGameMode_GenericMod_RM3

    7)In my TestGameMode_GenericMod_RM3:
    a)change 'Default Pawn Class' to my PlayerPawnTest_RM3
Working...
X