Announcement

Collapse
No announcement yet.

Can't Upload

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't Upload

    I just got done making a mod for the first time. I have done the Steam Guard code a few days ago for something else, so I am assuming I don't need to do that step as no window is popping up asking me to do so. However this is what I get:

    It cooks the mod, then I hit upload and...
    It gives the upload job command line ect, and says Loading Steam API...Ok. I get a spinning wheel at the bottom, and nothing happens from there out.

    Anyone know what I am doing wrong here?

    #2
    open your ark devkit>modtools>steamcmd>steamcmd.exe and login from there
    STEAM: [MAD]Dirty_Nightmare
    MOD: Dirty Weapons

    Comment


      #3
      Hi TheKillingLitz,

      To expand a bit on what Dirty_Nightmare is saying, the issue here is very likely that you need to authorize the dev kit with steam guard. I did see that you have done this previously, but it may need to be done again. (I have had to do it a few times myself, so it may be worth a try.) Unfortunately, the errors shown don't reference that at all, and that makes it hard to diagnose on your own. Luckily, pretty much all of us have hit this at one time or another, and there is an easy fix. I believe you know the steps, but I'll list them for anyway in case it helps, or another user with the same issue finds this post.

      Go to the path mentioned above, devkit>modtools>steamcmd>steamcmd.exe and run steamcmd.exe. This will give you a console window with a prompt. Type 'login <username> <password>' - it will then prompt you for a steam guard code, check your email for the latest one, enter it, and you are good to go. Close steamcmd, and try your upload again, it should work this time. If not, come back and tell us what you see.

      There have been reports of people still hitting this issue, or a similar one, when using the uploader in the dev kit. If re-setting steam guard doesn't help, people have reported success by running the upload manually through the steamcmd.exe interface, and then point it to your "VDF" file

      1. C:\Steam\steamapps\common\ARKDevKit\ModTools\SteamCMD\Steamcmd.exe
      2. Login "username" "password"
      3. workshop_build_item C:\Steam\steamapps\common\ARKDevKit\ModTools\ModConfigs\ "MODNAME.vdf"

      Hopefully one of these will get you up and running, good luck!


      ~Q~
      --- Remote View CCTV - Here --- Arkhammer 40k (warhammer 40k total conversion in progress) - Here --- Gizmodian blade pack, modder's resource - Here
      Join me in the Ark Modding IRC: Server: irc.quakenet.org Channel: #arkmodding Or Here for easy web chat

      Comment

      Working...
      X