Announcement

Collapse
No announcement yet.

Server Crashs after using my Mod!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Server Crashs after using my Mod!

    Error wont launch on linux server
    $ ./ShooterGameServer /Game/Mods/479320986/Storage?listen?ModId=479320986

    Using binned.
    4.5.1-0+UE4 7038 3077 402 3
    [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
    Setting breakpad minidump AppID = 346110
    LowLevelFatalError [File:\UE4\UnrealEngine\Engine\Source\Runtime\CoreUObject\Private\UObject\LinkerLoad.cpp] [Line: 3774]
    Bad name index -1896828711/37
    Signal 11 caught.
    EngineCrashHandler: Signal=11
    Segmentatiefout

    Any Idea?
    ARK: Storage+ - Raiding becomes more Difficult

    #2
    Originally posted by Tarantel View Post
    Error wont launch on linux server
    $ ./ShooterGameServer /Game/Mods/479320986/Storage?listen?ModId=479320986

    Using binned.
    4.5.1-0+UE4 7038 3077 402 3
    [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
    Setting breakpad minidump AppID = 346110
    LowLevelFatalError [File:\UE4\UnrealEngine\Engine\Source\Runtime\CoreUObject\Private\UObject\LinkerLoad.cpp] [Line: 3774]
    Bad name index -1896828711/37
    Signal 11 caught.
    EngineCrashHandler: Signal=11
    Segmentatiefout

    Any Idea?
    From the error message it looks like the problem starts with Steam not running. My guess to a potential resolution with this would be to make sure you have -nosteam added to your command line. Could be off base though seeing as I've never seen this error and have zero knowledge of Linux. Just speculating here, and going by the callstack's info. Past that, I don't think I have any suggestions :/

    If that doesn't fix it, I think you will need to contact the Dev's about this one or wait for them to respond here.

    - Sinari

    Comment


      #3
      This error is quite usual on linux using steamcmd hosted servers, it doesent do anything. The Server runs fine...

      Comment


        #4
        Hi m1ndgames,

        With any luck, the update that was just released should address the issue linux servers have been having. One of the patch notes is:
        "* Linux Dedi Server should now be able to load Mods without crashing " I know this is affecting many people, good luck, and please let us know if it's working or not, either way.

        ~Q~
        --- Remote View CCTV - Here --- Arkhammer 40k (warhammer 40k total conversion in progress) - Here --- Gizmodian blade pack, modder's resource - Here
        Join me in the Ark Modding IRC: Server: irc.quakenet.org Channel: #arkmodding Or Here for easy web chat

        Comment

        Working...
        X