Announcement

Collapse
No announcement yet.

Quick Note: How to manually override the Steam PublishedFileID for your Map/Mod

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Quick Note: How to manually override the Steam PublishedFileID for your Map/Mod

    A quick note:

    In case the ARK Dev Kit loses track (through a reinstallation or error) of the Steam FileID that you want to upload your Map/Mod to (you can see the ID on SteamWorkshop URL, ala http://steamcommunity.com/sharedfile.../?id=478227612 ), then all you need to do is open this file in Notepad (when the ARK Dev Kit is closed):

    \SteamLibrary\steamapps\common\ARKDevKit\Projects\ShooterGame\Saved\Mods.db

    Find the section for your Map/Mod after you've attempted an upload:

    {
    "ModDir": "GenericMod",
    "Maps": "GenericMod",
    "Title": "The Lost World (Updated v188 fixed!)",
    "Description": "Install and run this mod to play on the ARK Island with only primitive-tier technology! ",
    "PreviewImage": "C:/Users/Administrator/Desktop/TheLostWorld.png",
    "Visibility": "Public",
    "ChangeNotes": "",
    "ItemSeamId": "478227612"
    },

    And then change ItemSeamId (haha typo) to whatever Steam Workshop File ID that you want. Then launch the ARK Dev Kit, Upload, and it should upload to whatever SteamID you wish, as long as your logged-in user has permission to publish to that ID

    Cheers,
    Drake
    Last edited by Drathek; 08-26-2015, 01:39 AM.

  • replied
    I figured it out, the cook deletes the image files which prevents the upload so I changed the path of my images
    Last edited by Lanthanum; 05-09-2017, 07:51 PM.

    Leave a comment:


  • replied
    Originally posted by JasonFJ View Post
    Guys, don't use the DevKit steam uploader.

    1) Go to your \Epic Games\ARKDevKit\ModTools\SteamCMD folder.
    2) Create a new batch file called "UpdateMyMod.bat"
    3) Add a single line in your batch file: "steamcmd +login [yourSteamusername] [yourSteampass] +workshop_build_item "[yourpath]\Epic Games\ARKDevKit\ModTools\ModConfigs\[yourmodname].vdf""

    ....
    I love you!

    Leave a comment:


  • replied
    Originally posted by JasonFJ View Post
    Guys, don't use the DevKit steam uploader.

    1) Go to your \Epic Games\ARKDevKit\ModTools\SteamCMD folder.
    2) Create a new batch file called "UpdateMyMod.bat"
    3) Add a single line in your batch file: "steamcmd +login [yourSteamusername] [yourSteampass] +workshop_build_item "[yourpath]\Epic Games\ARKDevKit\ModTools\ModConfigs\[yourmodname].vdf""

    You can edit [yourmodname].vdf to any values you want.
    Thanks, that's amazing not having to type it out every time!

    I can't get a 'Test' version to upload using this method though, i get a file not found error if I'm not using my proper mod ID - any ideas?

    Leave a comment:


  • replied
    would be cool if the devs actually added the above into the ADK, a secondary steam upload for the same mod (Live and dev-test)

    Leave a comment:


  • replied
    Guys, don't use the DevKit steam uploader.

    1) Go to your \Epic Games\ARKDevKit\ModTools\SteamCMD folder.
    2) Create a new batch file called "UpdateMyMod.bat"
    3) Add a single line in your batch file: "steamcmd +login [yourSteamusername] [yourSteampass] +workshop_build_item "[yourpath]\Epic Games\ARKDevKit\ModTools\ModConfigs\[yourmodname].vdf""

    You can edit [yourmodname].vdf to any values you want.

    For example, my .vdf file has this.

    "workshopitem"
    {
    "appid" "346110"
    "contentfolder" "[yourpath]\Epic Games\\ARKDevKit\\ModTools\\Output\\Ultra-Realism"
    "previewfile" "[yourpath]\\Epic Games\\ARKDevKit\\ModTools\\Output\\Ultra-Realism\\preview.jpg"
    "visibility" "0"
    "title" "Ultra-Realism: Total Conversion"
    "changenote" "Beta release 201.6(4)"
    "publishedfileid" "505962979"
    }

    When I'm testing my mod, I create a second batch file that has a different publisherid... this way I can test new versions with a different mod id... without overwriting my last published mod that people use.

    "workshopitem"
    {
    "appid" "346110"
    "contentfolder" "[yourpath]\Epic Games\\ARKDevKit\\ModTools\\Output\\Ultra-Realism"
    "previewfile" "[yourpath]\\Epic Games\\ARKDevKit\\ModTools\\Output\\Ultra-Realism\\preview.jpg"
    "visibility" "2"
    "title" "Test-Dev Ultra-Realism: Total Conversion"
    "changenote" "Test release 201.6(5)"
    "publishedfileid" "xxxxxxxxx"
    }

    Notice that I use the same cooked folder output... I'm just uploading the changes to a different, hidden steam mod... so i can test without messing up my last good published version to the main steam mod I use.

    Hope this helps.
    Last edited by JasonFJ; 08-31-2015, 11:53 AM.

    Leave a comment:


  • replied
    what is GUID?
    do I need to clear this?

    Leave a comment:


  • replied
    Every time I update my project I have to use the dev kit and upload with a new file Id as a hidden file. Then I edit the .vdf file with the correct file id and use steamcmd to upload again. Then delete the duplicate with the wrong ID. It works for me every time, but really this needs to be looked into as it seems to be a hack way of making an update.

    Leave a comment:


  • replied
    Yeah sorry this does not work. The devkit overwrites any changes made to the db file. So if you lose the settings somehow like I did. You are going to have to not use the devkit uploader.

    Leave a comment:


  • replied
    I've got it working now but only if I place the .vdf file and referenced picture in the same folder as steamcmd.exe. Seems like I'm stuck using that now instead of the dev kit upload.

    Leave a comment:


  • replied
    Originally posted by Azunai View Post
    even manual upload with steamcmd doesnt work for "some" reason
    https://goo.gl/fgoUU5
    this is what happens

    Leave a comment:


  • replied
    Have you tried to do it manually with steamCMD, it just seems to work a lot better then the inbuilt uploader.

    If you are using windows, don't load it by double clicking, use command prompt and navigate to it, that way you can copy your path to the .vdf files with windows explorer, then right click paste (or just right click with win10 or newer versions of command prompt)

    login [username] [password]
    workshop_build_item [path to file]\Modname.vdf
    exit
    exit

    done.

    Leave a comment:


  • replied
    changed with notepad++ file stays alive, but upload fails "file not found"
    and yes i double tripple infinite checked the fileId

    Leave a comment:


  • replied
    Originally posted by Azunai View Post
    what editor do you use for Mods.db?`as all i tried seem ti invalidate its encoding thus letting the dev kit reset the file
    I use Notepad++
    I never get problems editing those files with that editor. I can upload with the build in cooker in ark dev kit.

    Leave a comment:


  • replied
    The only way I have been able to get this to work is to do a full cook, then upload my mod as "hidden". Once it is uploaded, I go into the files and edit the vdf (located in ARKDevKit\ModTools\ModConfigs). Then I can use SteamCMD to upload my mod to the correct place. Doing it in any other order has always given me some errors. (I then delete the hidden mod on steam since I don't want multiple copies flying around)

    Leave a comment:

Working...
X