Announcement

Collapse
No announcement yet.

Dedicated Server is not loading map

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Dedicated Server is not loading map

    I am trying to load a custom workshop map onto my server and am having trouble. i have the workshopmod# folder in my servers mod directory as well as the workshopmod renamed into the map name for folder in my maps folder, I also have my command line looking like this for server startup:
    D:\bluefang\servers\server6878\ShooterGame\Binaries\Win64\ShooterGameServer.exe /Game/Mods/481811048/Terra-nova?MaxPlayers=100?ModId=481811048?RCONEnabled=True?RCONPort=16557?Listen -multihome=209.170.149.42 -port=16547 -queryport=16557

    Can someone please help me the workshop mod is Terra-nova.
    I followed a tutorial for adding custom maps did what it said but it still wont allow my server to show when launched. - Thanks

    #2
    Does it load up in the single player HOST? If not then you have bigger problems.
    DinoOverhaul X CLICK HERE

    Comment


      #3
      Is it a dedicated server? If yes, then you need to copy the mod folder to the \Mods folder on the server as well.

      Comment


        #4
        M1k3_C - Yes it plays local fine

        MustangDood - I have it in my server mod folder as well copy pasted from desktop steam folder C:\Program Files (x86)\Steam\steamapps\common\ARK\ShooterGame\Content\Mods\481811048 .
        I have it also in server maps folder but like i said i renamed the map folder to the supposed map name.
        Last edited by Drunken Master; 07-19-2015, 05:06 PM.

        Comment


          #5
          I dont have a server, nor have I troubleshot this problem, but i'm pretty sure the map actually needs to be cooked with the mod, and in the mod folder.

          Comment


            #6
            Originally posted by TheRealAzrael View Post
            I dont have a server, nor have I troubleshot this problem, but i'm pretty sure the map actually needs to be cooked with the mod, and in the mod folder.
            My dedicated server uses a mod and loads a 3rd party map. All you need is both of the mods in the mods folder on the server, and to make sure you are force loading the name of the map. That's it. Nothing needs to be cooked.

            Comment


              #7
              Originally posted by MustangDood View Post
              My dedicated server uses a mod and loads a 3rd party map. All you need is both of the mods in the mods folder on the server, and to make sure you are force loading the name of the map. That's it. Nothing needs to be cooked.
              Really now? That is nifty. I assumed cooking would be required to get this to work, but I guess not. Thanks for sharing the useful info

              Comment


                #8
                Still will not load. Supposed corrected command line: D:\bluefang\servers\server6878\ShooterGame\Binaries\Win64\ShooterGameServer.exe /Game/Mods/481811048/Terra-nova?MaxPlayers=100?ModId=481811048?RCONEnabled=True?RCONPort=16567?Listen?ModId=481811048 -multihome=209.170.149.42 -port=16547 -queryport=16557

                Original: D:\bluefang\servers\server6878\ShooterGame\Binaries\Win64\ShooterGameServer.exe TheIsland?MaxPlayers=100?RCONEnabled=True?RCONPort=16567?Listen -multihome=209.170.149.42 -port=16547 -queryport=16557

                Map is installed in mods directory of server. Any lasting ideas?

                Comment


                  #9
                  "ShooterGameServer.exe" /Game/Mods/xxxxx/GenericMod_Canna?listen?ModId=xxxxx

                  Try it without the full directory listed and formatted like the provided example. I've never had to reference the exact file location ever in mine. Could be the problem. Just speculating though really. It's something to try at the least.

                  Comment


                    #10
                    Where are you calling that command from? A batch file? Where is the batch file? Is it the same folder as the ShooterGameServer.exe ? Did you change the folder structure from the default installation?

                    These things matter.

                    As troubleshooting, try simplifying the command line to just what Sinarisinestro suggests, and run it in the same folder as the .exe . Also, are you positive in your Mod, you are force loading "Terra-Nova"?

                    Comment


                      #11
                      Originally posted by MustangDood View Post
                      Where are you calling that command from? A batch file? Where is the batch file? Is it the same folder as the ShooterGameServer.exe ? Did you change the folder structure from the default installation?

                      These things matter.

                      As troubleshooting, try simplifying the command line to just what Sinarisinestro suggests, and run it in the same folder as the .exe . Also, are you positive in your Mod, you are force loading "Terra-Nova"?
                      OP's OP states the file directory setup they are using from what I can see. So OP does have a custom file directory setup.

                      "D:\bluefang\servers\server6878" I think that is the issue most likely. Either that, or OP has the wrong map name.

                      @DrunkenMaster Make sure that you double check the .umap file name inside of the mod folder, and ensure that it is in fact Terra-Nova.umap as well (just in case), as Mustang hinted at.

                      Comment


                        #12
                        So a update to clear up some things to troubleshoot further..
                        These are server side uploads locations for the mod...
                        /ShooterGame/Content/Maps/Terra-Nova
                        /ShooterGame/Content/Mods/481811048
                        and
                        /ShooterGame/Content/Mods/481811048.mod which is just a .mod file that goes into the mods folder not the mod/mod ID folder

                        Also i kept command line the same because that is scripted off the original server startup when server was using default theisland map. It has been changed via DaemonForge who posted the original post in workshop on how to get the apako map running on a dedicated server it is still as follows:
                        D:\bluefang\servers\server6878\ShooterGame\Binaries\Win64\ShooterGameServer.exe /Game/Mods/481811048/Terra-nova?MaxPlayers=100?ModId=481811048?RCONEnabled=True?RCONPort=16567?Listen?ModId=481811048 -multihome=209.170.149.42 -port=16547 -queryport=16557

                        ALSO.... because this is not a mod according to another tutorial for custom map installation it states because you are running a map and not a mod to place folder and rename it the map name in as above stated the /ShooterGame/Content/Maps/Terra-Nova
                        SO... i took the mod id folder and copy pasted all contents inside it into that terra-nova folder as described.. Reference:https://www.survivalservers.com/foru...client-server/

                        LASTLY:
                        to forceload the map i do not follow how or what you are implying to if its not above i do not know.




                        New command line i am playing around with:
                        D:\bluefang\servers\server6878\ShooterGame\Binaries\Win64\ShooterGameServer.exe /Game/Maps/Terra-Nova/Terra-Nova?ModId=481811048?MaxPlayers=100?RCONEnabled=True?RCONPort=16567?Listen?ModId=481811048 -multihome=209.170.149.42 -port=16547 -queryport=16557 <--- using maps director not mods with same modid= at end

                        old one:
                        D:\bluefang\servers\server6878\ShooterGame\Binaries\Win64\ShooterGameServer.exe /Game/Mods/481811048/Terra-nova?ModId=481811048?MaxPlayers=100?RCONEnabled=True?RCONPort=16567?Listen?ModId=481811048 -multihome=209.170.149.42 -port=16547 -queryport=16557 <--- AND i tryed old one to run it again and server status is: "Looks like it is not loading again, as it is stuck at 240MB of RAM."


                        New command line i hope lets it load correctly.
                        Last edited by Drunken Master; 07-20-2015, 04:55 PM.

                        Comment

                        Working...
                        X