Announcement

Collapse
No announcement yet.

Loading Steam API...OK - stuck

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Loading Steam API...OK - stuck

    When trying to upload mod, game sits spinning at the step 'Loading Steam API...OK' and never progresses. Read through some of the other threads and tried shortening my description, etc but no luck. Other ideas/fixes?

    #2
    Originally posted by 3ndoflin3 View Post
    When trying to upload mod, game sits spinning at the step 'Loading Steam API...OK' and never progresses. Read through some of the other threads and tried shortening my description, etc but no luck. Other ideas/fixes?
    been doing the same thing for an hour...insanity

    Comment


      #3
      think I fixed this i went to

      D:\Program Files (x86)\Steam\SteamApps\common\ARKDevKit\ModTools\SteamCMD

      ran steamcmd.exe manually with +login <user> <pass> it asked me for the steam guard code that in my email..I put it in then tried uploading again and all seems good.

      Comment


        #4
        This is an indication of Steam Guard not having been authenticated.

        Comment


          #5
          Thanks also for the responses, bruceswork suggestion running the steamcmd.exe from command prompt using the supplied email guard code worked to get me past that point.

          Also ran into a 'limit exceeded' error and hang on 'verify installation' which turned out to be (looking at workshop_log.txt log file) that you have to use a png preview file less than 1 MB. After providing < 1 MB preview image, successful upload.

          Comment


            #6
            Originally posted by 3ndoflin3 View Post
            Thanks also for the responses, bruceswork suggestion running the steamcmd.exe from command prompt using the supplied email guard code worked to get me past that point.

            Also ran into a 'limit exceeded' error and hang on 'verify installation' which turned out to be (looking at workshop_log.txt log file) that you have to use a png preview file less than 1 MB. After providing < 1 MB preview image, successful upload.
            Awesome! Hope things are working for you!

            Comment


              #7
              Im trying the steamCMD.exe, and nothing. I type: "+login <username> <password>" then press enter
              nothing. I have a .png file under 1 Mb (35kb)?? I have even tried deleting the description. It won't upload without a description??

              Any help would be great.

              Comment


                #8
                You wouldn't add the "+" to the start if you are entering the commands manually, that is for running it from the command line.

                Comment


                  #9
                  Im running it from the steamCMD.exe.

                  Comment


                    #10
                    to rephrase the earlier thread, when running steamCMD.exe from a command line, at the 'Steam>' prompt try "login <username> <password>" , removing the '+' symbol and using your steam account username/password, you should then get a prompt for a 5-digit code which you'll receive shortly via your email associated with your steam account. After you validate once, you shouldn't have to again and can then upload normally via the editor.

                    Comment


                      #11
                      Originally posted by 3ndoflin3 View Post
                      to rephrase the earlier thread, when running steamCMD.exe from a command line, at the 'Steam>' prompt try "login <username> <password>" , removing the '+' symbol and using your steam account username/password, you should then get a prompt for a 5-digit code which you'll receive shortly via your email associated with your steam account. After you validate once, you shouldn't have to again and can then upload normally via the editor.
                      You are the man!! Thanks. (And for others, if your in the process of an upload while signing into steam via command line, you will need to restart the upload via the Ark Dev kit after you enter your unique steam-guard code.)
                      Last edited by Ohio_Rockstar; 07-28-2015, 01:50 PM. Reason: spelling

                      Comment

                      Working...
                      X