Announcement

Collapse
No announcement yet.

Starter needs Help!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Starter needs Help!

    Hey Mates!

    I started using the devkit, i watched some tutorials and now i've encountered some problems...

    First off, the ADK crashes kinda often. If i use the "mi_newisland-hole" material.
    Also i can't seem to load my previously saved maps, without the ADK crashing.

    Oh, and i've seen that there is a modding discord for ARK, i would gladly join!
    But the auto verification didn't work out somehow...

    #2
    For the modding discord. (discord.arkmodding.net) after you sign in through the steam API you will see the screen with your invite code, there is also a link to 'Contact staff' So I would hit that and give them a message, they should be able to generate an invite for you manually.

    What tutorials are you following?

    Comment


      #3
      Before you load into a map, look at the scene editor, and delete the 'light direction' or whatever its called that deals with lighting. That might help with crashing if it is crashing during trying to load a map/create a new map.
      As for the mi_newisland thing, I actually use the universal one from arkmodding.net, never have issues with it.

      Comment


        #4
        Hello FedTonyHD,

        first of all try to open TheIsland Map and try to look how WildCard have done there stuff and what Material they Used for the Landscale.
        Normal you have a base Material for Landscapes "MI_NewIsland" the Second material is for Making Holes in the landscape (For caveantrance) -> "MI_NewIsland_Hole"

        Did you make your Landscape in your Mainmap File ? If yes make an own Sublevel for it.
        Here is a Link for the Sublevel structure of WildCard https://wiki.arkmodding.net/index.php?title=Sublevel

        Comment


          #5
          Wow 6 days nothing and then 3 replys!

          ZenRowe - may it be that one needs to have the arkdevkit on steam? i have the devkit from the epic launcher. I messaged, but there was no reaction.
          The Tutorials i watched so far are mainly Brick Whut, Whookie and some others...

          Nightshift - Indeed, that fixed it! I stumbled upon that solution in another thread here on the forums (answer might be by you too), i have a buddy that is already in the arkmodding discord, he was so kind to upload that universal material for me. I really enjoy the new paintlayers.

          Exilog - Yes i started out with the MI_NewIsland Materials, and now switched to the universal ones.
          I started mapping out the continent in the persistent level. I then started to create sublevels for foliage and other statics, but i ain't sure how to manage the level streaming part.

          I activated world composition, but it let me drop through the mesh, so i deactivated it. I saw in a tutorial, that a camera actor is needed. But i don't know if one is enough and if it matters where i place it. Also i am not sure what i should do else to increase performance.

          I mapped out entire Westeros + a part of Essos. I want to recreate the Map as good as i can. I split the map in Zones for the sublevels, i ended up with 12. For each of the 12 Zones i wanted to make 2 sublevels (foliage and other statics). So i would end up with the Landscape Mesh Persistent Level and those 24 Sublevels.

          thank you for all the answers and i hope you can help me here, so i can continue in my journey

          Edit: the discord auto invite has worked this time, i just tried again (to get the message box) lol
          Last edited by FedTonyHD; 04-17-2018, 09:58 PM.

          Comment


            #6
            Glad you figured out that crashing part. I did read somewhere, where someone isolated the issue directly in the settings of the directional lighting, but I cant recall what it was exactly.

            With world composition make sure you unchecked 'world biased' or something, (Sorry i'm currently saving my map and it takes forever so I am not exactly sure of the name).

            And I would definitely check out Exilogs tutorials, they were great for learning, and I still keep going back to them to figure stuff out. (https://www.youtube.com/watch?v=GFxC...i4cIneG5wGC3tY)

            If you are anything like me, I like to keep things organized and easily found with my map. I broke my map into many sub-levels.
            My main level is only my main ocean processing stuff, weather, and day/night cycle information.
            Then I have separate sub-levels for my obelisks, landscape, persistent play zone, Dino spawns and biome stuff.
            Persistant play zone is stuff like spawn points or various small other additions that can spread out on the map.
            Obviously then i have my map broken into many many sub-levels broken into sections. Each section contains separate sub-levels for Foliage, Mesh's, and Water Mesh's with their individual post processing volumes.

            I like to keep things as organized as possible so having everything in separate levels definitely helps move and find stuff quickly.

            As far as performance, I am still kinda messing around with the whole streaming level thing so I cant give much advice on that. But I can say, when you add foliage, make sure you check the cull distances...a lot of them have like 215000 for the cull range, The lower you can get that number, the better. What it does, just incase you dont know, is as a player, thats the point where the client will start to render in whatever it is. So you really gotta find the sweet spot, where you are not rendering in miles of tree's but they are not just appearing out of no where as you move. Oh, and yeah, that goes for the static meshes you add too, lots of them have very high numbers and there is no point for them to be rendered in a mile away...well unless you only want super computers to run your map!

            Comment

            Working...
            X