Announcement

Collapse
No announcement yet.

Went and made a child of a currently existing wall but can't place it ingame.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Went and made a child of a currently existing wall but can't place it ingame.

    Building the wall with mats, and otherwise get it into the inventory works just fine - after placing the wall on the hotbar and then pressing the key to place it, nothing happens, it doesnt show the green outline of the wall that it otherwise normally would - the original version of this wall works however - and I can't for the life of me figure out why it doesnt work for me - the only thing I have changed on everything is the references and health on the walls.

    Help D: ?

    #2
    You need to add the new structure to the "Additional structures to place" array in your PrimalGameData


    My Mods | P0k3r's Workshop

    Comment


      #3
      Well I went and replaced the original one with the one I made, as I don't want to make a new one, but rather just modify the existing one - to hopefully avoid people not losing their engrams - or isnt that possible ?

      Comment


        #4
        Use Remap Engrams and Remap Items of PrimalGameData.
        I will finish this mod.

        Alchemy (A Full Blown Skill)

        Comment


          #5
          You can remap them as Huston850 said however, since it is in fact a new structure, it still needs to get added to the additional structures to place.
          The only way you would NOT have to add them to that array is if you just straight up modified the original which is NOT a good thing unless you are making a TC.


          My Mods | P0k3r's Workshop

          Comment


            #6
            Was sure I replied here - anyway I went to put them into additional structures and remapped all of them as well - however as before I can still craft them, and drag them around in my inventory, but I still can't place them afterwards, when pressing the hotkey they have been placed on, nothing simply happens - I honostly can't figure out why.

            Comment


              #7
              Okay so - I went and tried to redo it all, and it seems like I got it working now.
              - Thanks !

              Comment


                #8
                - New issue though - I went and tried to use the mod ingame, it is however not actually putting the changes I made into effect.

                Anyone who could tell me what I might be missing ?

                Comment


                  #9
                  Recook it. If you're only testing this mod and it's first, make sure you have a description in PrimalGameData. If you press escape and don't see your description, your mod didn't load properly.
                  I will finish this mod.

                  Alchemy (A Full Blown Skill)

                  Comment


                    #10
                    I take it that the mods listed should be above the config file settings in the game ?
                    - Cos it certainly doesnt show up, even though I do have a description :/

                    Edit: Okay so, I went to recook it, diddent help at all, I obviously must be missing something.
                    Odd thing is though when I load the map, it does loads the primalgamedata that comes with the mod, yet it apparently does nothing to change anything at all ?
                    Last edited by Zoin; 11-04-2016, 01:10 PM.

                    Comment


                      #11
                      Originally posted by Zoin View Post
                      I take it that the mods listed should be above the config file settings in the game ?
                      - Cos it certainly doesnt show up, even though I do have a description :/

                      Edit: Okay so, I went to recook it, diddent help at all, I obviously must be missing something.
                      Odd thing is though when I load the map, it does loads the primalgamedata that comes with the mod, yet it apparently does nothing to change anything at all ?
                      I'm not familiar with that method. I do singleplayer and dedicated from a .bat, so I use ?GameModIds=

                      Is your PrimalGameData a child of the original?
                      I will finish this mod.

                      Alchemy (A Full Blown Skill)

                      Comment


                        #12
                        Originally posted by Huston850 View Post
                        I'm not familiar with that method. I do singleplayer and dedicated from a .bat, so I use ?GameModIds=

                        Is your PrimalGameData a child of the original?
                        Everything is a child of the original, except for the level file as that apparently cant be a child.

                        I just got it downloaded from the workshop really.
                        I just noticed that its loading the mod-primal data file when I load the map is all, it does however also load the original one first, not sure if its supposed to do that or not.

                        I could send you the files to the mod for you to look at if thats a possibility ? :/
                        Its frustrating to no end atleast.

                        Comment


                          #13
                          It'll load the base PrimalGameData then all children thereafter. Does it at least work in the dev kit?
                          I will finish this mod.

                          Alchemy (A Full Blown Skill)

                          Comment


                            #14
                            Yes, it works in the devkit, no problems there at all, works exactly as it should - just not ingame :s

                            Comment


                              #15
                              So here's what I've done:

                              Made a child of the generic mod files - I set the primal game data and GameTest mode to the default override in the level file, ive made a child of every single engram, every single, blueprint, and item - I changed the different attributes to what I wanted them to be - remapped the items, and engrams as well as adding them under additional - I then went to cook the mod as a Game Mod - uploaded it to steam workshop - am I missing a step here somewhere that causes the game not to change anything ?

                              Comment

                              Working...
                              X