Announcement

Collapse
No announcement yet.

BluePrint In-App purchases IOS not working UE 4.7.5 Win

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    BluePrint In-App purchases IOS not working UE 4.7.5 Win

    Hello,

    I have an issue with In app Purchase on UE 4.7.5 for windows.

    In-app purchase was working fine on UE 4.5.1 after a modification in the IOSEngine.ini (my last thread : here)

    Since I have migrate to 4.7.5 the problem re-appear :

    then I have added to the DefaultEngine.ini :
    Code:
    [OnlineSubsystem]
    DefaultPlatformService=IOS
    
    [OnlineSubsystemIOS.Store]
    bSupportInAppPurchasing=True
    But still the same...
    here is the logs at UE Startup :
    Code:
    [2015.04.18-09.17.19:100][  0]LogModuleManager:Warning: ModuleManager: Unable to load module 'OnlineSubsystemIOS' because the file 'C:/Program Files/Unreal Engine/4.7/Engine/Binaries/Win64/' was not found.
    [2015.04.18-09.17.19:100][  0]LogOnline:Warning: Unable to load default OnlineSubsystem module IOS, using NULL interface
    [2015.04.18-09.17.19:127][  0]LogOnline:Verbose: NULL: Created thread (ID:3968).
    ...
    ...
    ...
    [2015.04.18-09.18.55:475][175]LogOnline:Display: NULL: FOnlineSubsystemNull::Shutdown()
    [2015.04.18-09.18.55:475][175]LogOnline:Display: Unloading online subsystem: Null
    ...
    ...
    Is there a solution ?
    Thanks for your help

    St├ęphane
    Last edited by tefica; 04-18-2015, 06:32 AM.

    #2
    Same problem here with Android/iOS.
    Look my post: https://answers.unrealengine.com/que...ase-issue.html

    Comment


      #3
      Hi Helghast,
      by your side, have you found a way to solve the problem ?

      Comment


        #4
        No. I hope that we should not touch code to fix it.
        I think everything is properly configured in the project and GoogePlay but still returns "Failed".

        Maybe we should wait for the next update.

        Comment


          #5
          I have just installed the new upgrade : 4.7.6 but the issue persist... I did create a new blank BluePrint Project and launch it with no ini modification and it return :
          Code:
          [2015.04.21-14.10.00:902][  0]LogOnline:Warning: No default platform service specified for OnlineSubsystem

          Comment


            #6
            Hi all,

            Terence Burns has been able to assist Helghast in this AnswerHub thread. Please have a look and see if it assists in your individual issues.

            Thanks!

            Comment


              #7
              Hi wittlief,

              I had a look at this Thread, thanks,
              but In-app Purchase still not work for me on IOS (Not tested on Android), all seems to be well configured but all in-app functions return failed :

              Click image for larger version

Name:	read.JPG
Views:	1
Size:	53.3 KB
ID:	1075564
              Click image for larger version

Name:	Make.JPG
Views:	1
Size:	54.9 KB
ID:	1075565

              My defaultEngine.ini :

              Click image for larger version

Name:	ini.JPG
Views:	1
Size:	20.1 KB
ID:	1075566

              I'm currently working on UE4.7.6 on a BluePrint Only project under Windows...
              May be should I Install a github Version of UE and compile on a Mac with UnrealRemoteTool ? but I would prefer not...
              Last edited by tefica; 05-03-2015, 03:03 AM.

              Comment


                #8
                Ok, Solved for IOS on UE 4.7.6 the good syntax is :

                Code:
                [OnlineSubsystemIOS.Store]
                bSupportsInAppPurchasing=True

                (it was not the same in the UE4.5.1 version...)

                Thanks Helghast, wittlief, and thanks Terence !

                Comment


                  #9
                  Originally posted by tefica View Post
                  Ok, Solved for IOS on UE 4.7.6 the good syntax is :

                  Code:
                  [OnlineSubsystemIOS.Store]
                  bSupportsInAppPurchasing=True

                  (it was not the same in the UE4.5.1 version...)

                  Thanks Helghast, wittlief, and thanks Terence !
                  Added this line but the error still persist in 4.14.2

                  Code:
                  LogModuleManager:Warning: No filename provided for module OnlineSubsystemIOS
                  LogModuleManager:Warning: ModuleManager: Unable to load module 'OnlineSubsystemIOS' because the file 'C:/Program Files (x86)/Epic Games/4.14/Engine/Binaries/Win64/' was not found.

                  Comment

                  Working...
                  X