Announcement

Collapse
No announcement yet.

Workaround for 4.7.1 iOS "Launch On" and "Package" issue.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Workaround for 4.7.1 iOS "Launch On" and "Package" issue.

    Hello,

    There is a known issue in 4.7.1 for iOS that is making packaging no longer work properly. We have found a work-around and wanted to get it up ASAP while we work to fix the problem. We have a hotfix on the way and expect it to be ready by the end of the week.

    UE-11207 iOS launch fail after upgrading to 4.7.1, provision not found, signing key not found

    Symptom: When attempting to utilize Launch On or File|Package, the editor doesn't allow their use because it doesn't find a valid provision or certificate even though the Provision List in the IOS Project Settings shows a valid provision.

    Problem: In 4.7 we introduced automatic generation of the Info.plist file so users wouldn't have to keep updating the plist and instead could remain in the editor to set their iOS settings. The generation of this file is not happening before we do the validation check and so the validation utilizes an incorrect Bundle Identifier when attempting to determine if the provision and certificate are valid.

    Work Around: The simplest way to get around this issue is to utilize a Wild Card provision.

    1) To do this, on the Apple Developer site (developer.apple.com) log in to the Member Center.

    2) Select Manage your certificates and create a new App ID (something like MyTeam).

    3) Select Wildcard App ID and specify the Bundle ID as * (asterisk). This will make an App ID that will match any Bundle Identifier you may set in the Unreal Editor.

    Click image for larger version

Name:	Wildcard Step1.png
Views:	2
Size:	56.6 KB
ID:	1145054

    4) Finish the App ID process (as shown in the IOS Quick Start developer documentation).

    5) Then, select All under the Provisioning Profiles section on the developer site.

    6) Create a new iOS App Development Provisioning Profile utilizing the MyTeam App ID you created previously.

    Click image for larger version

Name:	Wildcard Step2.png
Views:	2
Size:	22.5 KB
ID:	1145055

    7) Download and import this new provision via the IOS Project Settings in the Unreal Editor.

    You will now be able to utilize Launch On and File|Package again. Further, this will then properly generate the plist with the Bundle Identifier you have specified in the settings, and so it will then utilize your specific provision for the game in the future.
    Twitch /unrealalexander| Twitter @UnrealAlexander
    How to report a bug? | Installation & Setup issues?
    Call me to a thread by posting this: [MENTION]Alexander Paschall[/MENTION]

    #2
    I followed your instruction. Importing provisioning file was not problem. But while importing Certificate it gives me this message: Failed to load or install certificate due to an error: 'Object reference not set to an instance of an object'

    After I failed to package for ios, I needed to repackage for android, now the process that was previously complete fails. The message log points in red something about provisioning, that shouldn't relate to android packaging. Just to let you know.

    I trust you guys fix the packaging problems and give a clear instruction to us! good luck!

    Comment


      #3
      I followed your instruction. Importing provisioning file was not problem. But while importing Certificate it gives me this message: Failed to load or install certificate due to an error: 'Object reference not set to an instance of an object'
      Click image for larger version

Name:	Screenshot1.png
Views:	1
Size:	42.2 KB
ID:	1071287

      After I failed to package for ios, I needed to repackage for android, now the process that was previously complete fails. The message log points in red something about provisioning, that shouldn't relate to android packaging. Just to let you know.

      I trust you guys fix the packaging problems and give a clear instruction to us! good luck!

      Comment


        #4
        I forgot to mention, this was on UE4.7.3

        Comment


          #5
          Hi aabun,

          This is the AnswerHub thread from a user who had a similar problem recently. Can you have a look and see if this helps your issue? Further, if it does not help, can you start another forum thread or AnswerHub thread? This thread that you are replying to was for an issue that was fixed in 4.7.2. and it will be easier to track your particular problem if it is not piggybacking a fixed issue. Thanks very much!

          Comment

          Working...
          X