Announcement

Collapse
No announcement yet.

Desktop Forward And Deferred Renderers For iOS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Desktop Forward And Deferred Renderers For iOS

    In the 4.26 Release Highlights video (here: https://youtu.be/OchRhhRaE5s) there was a section on mobile improvements and they mentioned that you could enable the desktop deferred renderer, they showed a video of their infiltrator demo running on an ipad pro.

    They didn't give any clues on how to actually enable these modes but from what I was able to deduce here is how you enable the various modes:
    • Mobile Deferred Renderer
      • r.Mobile.ShadingPath=1 in ConsoleVariables.ini
      • "Metal Mobile Renderer" checkbox checked in iOS project settings
    • Mobile Forward Renderer (default)
      • Default project and ini settings
      • r.Mobile.ShadingPath=0
      • "Metal Mobile Renderer" checkbox checked
    • Desktop Deferred Renderer
      • r.Mobile.ShadingPath=1 in ConsoleVariables.ini
      • "Metal Desktop Renderer" checked in iOS project settings
      • "Metal Mobile Renderer" unchecked in iOS project settings
    • Desktop Forward Renderer
      • r.Mobile.ShadingPath=0
      • "Metal Desktop Renderer" checked in iOS project settings
      • "Metal Mobile Renderer" unchecked in iOS project settings
    However I haven't been able to get any of the modes except for the default Mobile Forward Renderer to actually render something without graphical glitches or crashing the engine.

    See attached screenshots for images of the third person template on an iphone xs with the desktop forward and deferred renderers. The mobile deferred renderer doesn't even work - the editor crashes every time when trying to compile shaders.

    Has anybody successfully got either the desktop deferred or forward renderers working on iOS? If so how did you do it?

    I really wish epic would just spend the 15 minutes writing documentation about this stuff, and if they aren't willing to write docs on it they shouldn't put it in release notes/highlights.

    Attached Files

    #2
    Try to disable fog and light shafts
    Making games with Unreal Engine https://ufna.dev
    My plugins official channel: https://discord.gg/N92pzqJ

    Comment


      #3
      Originally posted by ufna View Post
      Try to disable fog and light shafts
      Sadly this didn't work for me. Here is what I did based on your suggestion:

      - Disabled everything Fog related in Project Settings (SupportAtmosphericFog = false, VertexFoggingForOpaque = false)
      - Added console commands which disable Fog (r.Fog 0)
      - Made sure Light Shafts are disabled on the Directional Light

      So if there is any step I was missing please feel free to elaborate in more detail ufna.

      Comment


        #4
        Originally posted by freaknbigpanda View Post
        In the 4.26 Release Highlights video (here: https://youtu.be/OchRhhRaE5s) there was a section on mobile improvements and they mentioned that you could enable the desktop deferred renderer, they showed a video of their infiltrator demo running on an ipad pro.

        They didn't give any clues on how to actually enable these modes but from what I was able to deduce here is how you enable the various modes:
        • Mobile Deferred Renderer
          • r.Mobile.ShadingPath=1 in ConsoleVariables.ini
          • "Metal Mobile Renderer" checkbox checked in iOS project settings
        • Mobile Forward Renderer (default)
          • Default project and ini settings
          • r.Mobile.ShadingPath=0
          • "Metal Mobile Renderer" checkbox checked
        • Desktop Deferred Renderer
          • r.Mobile.ShadingPath=1 in ConsoleVariables.ini
          • "Metal Desktop Renderer" checked in iOS project settings
          • "Metal Mobile Renderer" unchecked in iOS project settings
        • Desktop Forward Renderer
          • r.Mobile.ShadingPath=0
          • "Metal Desktop Renderer" checked in iOS project settings
          • "Metal Mobile Renderer" unchecked in iOS project settings
        However I haven't been able to get any of the modes except for the default Mobile Forward Renderer to actually render something without graphical glitches or crashing the engine.

        See attached screenshots for images of the third person template on an iphone xs with the desktop forward and deferred renderers. The mobile deferred renderer doesn't even work - the editor crashes every time when trying to compile shaders.

        Has anybody successfully got either the desktop deferred or forward renderers working on iOS? If so how did you do it?

        I really wish epic would just spend the 15 minutes writing documentation about this stuff, and if they aren't willing to write docs on it they shouldn't put it in release notes/highlights.
        I tend to believe that this is kind of a "regression", have you ever tried to build and run your project with UE 4.25.4, which fixed the desktop rendering issues on iOS for my project.

        Comment


          #5
          I recently received a suggestion to set the Sky Light to Movable which should make it magically work. Haven't had the chance to try that one out yet, but still wanted to let you guys know. Maybe it helps.

          Comment


            #6
            Originally posted by R1804 View Post

            I tend to believe that this is kind of a "regression", have you ever tried to build and run your project with UE 4.25.4, which fixed the desktop rendering issues on iOS for my project.
            Personally I never had this issue with UE 4.25.4. But we had to update to 4.26 for Android because they fixed some exposure issues which we've experienced with 4.25.
            But since we are not able to build for older Apple devices with 4.26 anymore we now need to have two separate branches one with 4.25 and one with 4.26. So the problem is "kind of" solved on our end for the moment.

            Comment


              #7
              Originally posted by Thoeme View Post
              I recently received a suggestion to set the Sky Light to Movable which should make it magically work. Haven't had the chance to try that one out yet, but still wanted to let you guys know. Maybe it helps.
              It seems like this does work! The graphical glitches are gone. What I did was set both the directional light and skylight to moveable and I also disabled static lighting completely in the project for good measure.

              Where did you find that information? I really wish epic would document this stuff so we don't spend hours trying to get stuff to work :/

              Comment


                #8
                Originally posted by freaknbigpanda View Post

                It seems like this does work! The graphical glitches are gone. What I did was set both the directional light and skylight to moveable and I also disabled static lighting completely in the project for good measure.

                Where did you find that information? I really wish epic would document this stuff so we don't spend hours trying to get stuff to work :/
                Hi. Really cool that it worked. Also thank you for letting me know
                I've received that suggestion through Unreal Slackers Discord.
                But you are absolutely right about the lack of documentation, especially in the AR space.

                Comment


                  #9
                  Originally posted by freaknbigpanda View Post
                  In the 4.26 Release Highlights video (here: https://youtu.be/OchRhhRaE5s) there was a section on mobile improvements and they mentioned that you could enable the desktop deferred renderer, they showed a video of their infiltrator demo running on an ipad pro.

                  They didn't give any clues on how to actually enable these modes but from what I was able to deduce here is how you enable the various modes:
                  • Mobile Deferred Renderer
                    • r.Mobile.ShadingPath=1 in ConsoleVariables.ini
                    • "Metal Mobile Renderer" checkbox checked in iOS project settings
                  • Mobile Forward Renderer (default)
                    • Default project and ini settings
                    • r.Mobile.ShadingPath=0
                    • "Metal Mobile Renderer" checkbox checked
                  • Desktop Deferred Renderer
                    • r.Mobile.ShadingPath=1 in ConsoleVariables.ini
                    • "Metal Desktop Renderer" checked in iOS project settings
                    • "Metal Mobile Renderer" unchecked in iOS project settings
                  • Desktop Forward Renderer
                    • r.Mobile.ShadingPath=0
                    • "Metal Desktop Renderer" checked in iOS project settings
                    • "Metal Mobile Renderer" unchecked in iOS project settings
                  However I haven't been able to get any of the modes except for the default Mobile Forward Renderer to actually render something without graphical glitches or crashing the engine.

                  See attached screenshots for images of the third person template on an iphone xs with the desktop forward and deferred renderers. The mobile deferred renderer doesn't even work - the editor crashes every time when trying to compile shaders.

                  Has anybody successfully got either the desktop deferred or forward renderers working on iOS? If so how did you do it?

                  I really wish epic would just spend the 15 minutes writing documentation about this stuff, and if they aren't willing to write docs on it they shouldn't put it in release notes/highlights.
                  Hi guys. Just to let you know, I've created a bug report for the issue describe here. You can track changes on that issue here: https://issues.unrealengine.com/issue/UE-107774

                  Please also consider voting on the issue to increase priority.

                  Comment

                  Working...
                  X