Announcement

Collapse
No announcement yet.

iOS Launch Failed (Failed to connect to bundle)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    iOS Launch Failed (Failed to connect to bundle)

    I'm trying to push an empty level in a blank project to iOS, and I get the following errors:

    LogPlayLevel: Error: [DD] ... Error: Failed to connect to bundle 'com.myCompany.myAppName'
    LogPlayLevel: Error: [DD] ... Error: Failed to connect to bundle 'com.myCompany.myAppName'
    LogPlayLevel: Error: Instruments Usage Error: Specified target process is invalid: 'com.myCompany.myAppName'
    LogPlayLevel: Error: ERROR: Launch Failure
    LogPlayLevel: Error: RunUAT ERROR: AutomationTool was unable to run successfully.
    PackagingResults: Error: Launch failed! Failed to launch on device. Make sure your install of Xcode matches or is newer than the OS on your device.

    I'm pretty sure my XCode and iOS are both up-to-date (see Dev Environment Details below).

    The selected Mobile Provision was created at developer.apple.com specifically for this project, and is listed as 'Valid' in Project Settings > Platform > iOS
    The selected Certificate is also listed as 'Valid' in Project Settings > Platform > iOS

    I'm especially curious to learn what the first error ("Failed to connect to bundle") means.

    Dev Environment Details
    Unreal Engine 4.25 (also tried 4.24.3 and 4.23.1)
    XCode 11.5
    iOS 13.5.1
    Mac OS Catalina 10.15.6

    #2
    Well... I found what was wrong with my setup! I hadn't assigned the correct Device to my Profile on the Apple Developer dashboard (developer.apple.com). My profile was accidentally registered to an old device. Once I registered to my current device, I re-downloaded my profiles and certificates via Xcode and the project launched on my iPhone!

    Comment

    Working...
    X