Announcement

Collapse
No announcement yet.

Submitting an App built wit UE4.17 to the App Store

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Submitting an App built wit UE4.17 to the App Store

    Hello, I am using UE4.17.2. I have managed to successfully package and test my game on my iPhone 7 Plus.
    I now want to upload it to the AppStore, using the Transporter App, but I get:
    "SDK Version Issue: This app was built with the iOS 10.3 SDK. All iOS apps submitted to the App Store must be built with the iOS 11 SDK"
    I've tried setting the "Minimum iOS Version" to "11 Beta" in Project Settings, but nothing changed.
    Is it true that with UE4.17.2 you simply cannot develop for iOS?
    Is there a way around that issue?

    #2
    It's as written in the log: "All iOS apps submitted to the App Store must be built with the iOS 11 SDK"
    This is a new restriction by Apple. Google it to get the exact reasons for this decision.

    1. You could try packaging with XCode9, which came with iOS11 sdk (but it might fail...).
    2. or in XCode 9, right-click, choose "show package content" and navigate to the folder /XCode/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/
    and copy and paste the iOS11 sdk to your XCode version that works with your ue4 build. (Not sure where to adjust settings in UE4, if needed)

    If both methods fail, you will have to update you UE4 project to Unreal Engine 4.18, the first release to support iOS11 and XCode9 and see if it causes any problems to be fixed.

    Side node:
    Most people miss the fact, that the XCode version minor-numbers and iOS version minor-number match
    and they also release around the same time, revealing their connection.
    examples:
    XCode 11.0 for iOS 13.0 sdk
    XCode 11.1 for iOS 13.1 sdk
    XCode 11.2 for iOS 13.2 sdk

    Comment


      #3
      Thank you very much for the response! I am using Windows for everything except uploading to the AppStore (meaning I only use the Transporter App), because I don't own a Mac and I am only using my friends Mac for a while. It seems that it is time to move to UE4.24

      Comment

      Working...
      X