No announcement yet.

iOS - Packaged project has black levels

  • Filter
  • Time
  • Show
Clear All
new posts

    iOS - Packaged project has black levels

    I've decided to upgrade my project from 4.22 to 4.24 (because I couldn't package project to iOS 13.3 - xCode 11 is needed and it works only with newer versions of UE). So, I backed up the project and upgraded it. Everything works perfectly in the editor, no errors, nothing (asset validation is ok). Game works as intended. I've been trought almost every asset I have and I tried to compile every asset again, every time it worked = 0 errors.
    So I tried to make a build. Build Successful (that's what It said). So I launched game on my iPhone (iPhone 7 Pplus, iOS 13.3) and there come the problem. Everything I saw was UI and black map (or maybe blank map, I don't know, everything was black), now I know that the map must be there, or at least the map settings were packaged, because in my main menu I use different game mode than in my levels, so I only wonder why is it black? I tried changing it to every other level (map) I had, I even created new one and put a direct light etc. so it won't be black, nothing worked.
    So I tried creating new project on 4.24.1 and launching it on my iPhone (3rd person game) and it worked. So I wonder where is the problem, because the problem is not in the old maps, whenever I create new one, set is as default map and launched I saw only black screen and UI. So there must be some sort of problem in project itself, however I was not able to find where, but I guess it has something to do with switching to newer version of Unreal Engine.

    I'd appreciate any help.



    Other info:
    OS: MacOS 10.15 Catalina
    xCode: 11.3
    UE: 4.24.1
    Last edited by LordSagy; 01-08-2020, 08:34 AM.

    Same issue.


      We've seen the same simply building from a template file with nothing added. Building natively on a Mac, no remote build etc
      David Gillespie
      Foster + Partners


        The project settings show a list of map files "Level1", "Level2" and so on.
        But the content browser shows map files named "Level1_2", "Level2_2" and so on.
        So there is a mismatch between level name and filename of level-file.

        Notice that in the editor the level name is "MenuLevel" (top left in your screenshot and also in the world outliner).
        The list of maps to cook in the project name does not take level names, but file names, like shown in the content browser.

        Try fixing the file naming.
        It should be "MenuLevel_02" in the project settings or rename the level in the content browser to a proper "MenuLevel". If map name and map file name are the same, that's probably better.