Announcement

Collapse
No announcement yet.

Screen tearing / Jelly Effect on 4.23 ARKit Camera

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by CosmicLobster View Post


    Thank you for your effort and sharing this.
    However i'm afraid there has been a misunderstanding.

    So your app is VR, it does not use camera footage, that is an unusual case. Naturally everyone means the "real world" camera feed from the ios-device when talking about an Augmented Reality framework, not the virtual camera in the UE4 world that renders actors in a scene.
    Oh, I'm sorry if I misunderstood. My app uses camera footage in the background for its tracking like Oculus Quest.
    Can you check this video whether there's any problem you mentioned above?
    I built and recorded it just before.

    Comment


      #17
      Thank you for the video.
      Yes the problem is visible in the video aswell. For example at playtime 17-20 seconds. (See image attached, this is at 19sec)
      In the video (using iPhone) there is sometimes one tearing in the picture, but on iPads and iPadPros the camera image looks all the time more fractured like a broken chess-board. Endusers would send many complains and give bad reviews, so it is not usable for production.


      Mobile hardware renders not in full frames, but in small tiles. The small rendered tiles then get composed to one full images. It seems the engine has a problem at that process.

      By now the issue got 19 votes, target fix updated to 4.24.2, but as we learned last time, this is no reliable information and epic remains silent like always.
      We are holding back production for an AR-project because of this.

      Even if this issue gets fixed, AR Environment Capture Probes are broken too.

      AR - Environment Capture Probe Type: Automatic crash
      https://issues.unrealengine.com/issue/UE-85533

      Screen Renders Black in a Packaged AREnvProbe Project
      https://issues.unrealengine.com/issue/UE-81660

      AREnvProbe - App crash on iPad if automatic environment capture is enabled
      https://issues.unrealengine.com/issue/UE-86540


      I will not trust release notes anymore before testing if they are actually usable for production in the future. This is very sad, so disappointed.

      https://issues.unrealengine.com/issue/UE-81611
      Last edited by CosmicLobster; 01-17-2020, 06:51 PM.

      Comment


        #18
        Originally posted by CosmicLobster View Post
        Thank you for the video.
        Yes the problem is visible in the video aswell. For example at playtime 17-20 seconds. (See image attached, this is at 19sec)
        In the video (using iPhone) there is sometimes one tearing in the picture, but on iPads and iPadPros the camera image looks all the time more fractured like a broken chess-board. Endusers would send many complains and give bad reviews, so it is not usable for production.......[/ATTACH]
        Wow.... I can see what you mean now, exactly. It's a shame that I can't find it before!

        Comment


          #19
          Is it fixed in the newest Update? Dont have a Iphone to try...

          Comment


            #20
            Originally posted by AntonZero100 View Post
            Is it fixed in the newest Update? Dont have a Iphone to try...
            No, of course not.
            Target Fix means nothing and gets delayed all the time. https://issues.unrealengine.com/issue/UE-81611

            Here is a video with comparison. On an iPadPro11 the problem can be seen better.
            Besides the blocky tearing, the frame rate also does not seem as smooth it should be.
            The video compression makes it a bit blurry (effect is stronger on an actual retina device) but it still can be seen.

            Video: Unreal Engine 4 Bug in ARKit

            Comment


              #21
              Ooohhh man hilarious xD It's a Staff Pick !!!
              Isn't this Nick Penwarden Director of Engineering who say this in a live stream?

              Comment


                #22
                Originally posted by AntonZero100 View Post
                Ooohhh man hilarious xD It's a Staff Pick !!!
                Isn't this Nick Penwarden Director of Engineering who say this in a live stream?
                I simply could not resist...

                It's from GDC 2019 - State of Unreal

                Comment


                  #23
                  My fellow AR devs, now it get's weird.

                  Yesterday (12.feb) the bug was marked as fixed on the bug report site.
                  GitHub source shows a fix commit in the dev-vr branch
                  https://github.com/EpicGames/UnrealE...ntime/AR/Apple (github access required to reach link)

                  (by Wang Hao, seems to be from Epic China, who by the way, i want to mention this, do amazing work in communication with the community and creating great learning content, i am lucky my Chinese friend/coworker can share some of this with me)

                  So I put the new ARKit plugin source in a fresh 4.24.2 branch (the current release branch on github), packaged and at first glance the issue seems fixed!

                  But today the issue is set back to "Unresolved"!? https://issues.unrealengine.com/issue/UE-81611

                  So mixed feelings, let's see after more testing.

                  Comment


                    #24
                    Awesome CosmicLobster! I will take a look at it!

                    At least I've been working with version 4.22.3 without issue for a while.

                    Cheers

                    Comment

                    Working...
                    X