No announcement yet.

Is packaging to iphone easier from a mac then pc?

  • Filter
  • Time
  • Show
Clear All
new posts

    Is packaging to iphone easier from a mac then pc?

    Long story short I am having one hell of a difficult time getting the puzzle game template packaged to iphone from my pc. Instead of asking a specific question I have a couple of more general questions I am hoping some of you could help me out with.

    1.How much easier is the process in general if done on a mac laptop instead of a windows pc? Could I email my project from my windows pc to a macbook air, open the project on the mac and then do the packaging, certificates, keys, provisions, xcode from there? Or does it make much a difference?

    2.If I continue down the rabbit hole on windows, how necessary is a remote build and xcode from a mac in the cloud? Does anybody do this without a remote build? The one time I actually got an iOS package out of unreal it was without a remote build and xcode (however getting that build onto the phone via iphonepackager fails and I haven't been able to duplicate the successful package, it just randomly packaged successfully from the editor one time and one time only).

    3.Is packaging to android easier then iphone? Should I just pick up an android for beta purposes and go into troubleshooting abyss with apple only when I am completely ready to distribute?

    Any help/opinions are appreciated.

    you are referring to this method, right?

    It never worked for me. Simple things like an empty space in the windows user name and nothing works. Quite tedious pseudo-solution, even if it works for some people.
    When even in an UE4 live stream on youtube, one of epic's staffs says they switched to mac, because packaging iOS from windows is too much of a pain, that says a lot...
    Yes it is easier. The UE4 editor can distinguish between different ios devices, package and deploy to the device over Wifi and Xcode can show an output log, while the game is being played.

    I'm relatively fine on a 15" MacBookPro, but a Macbook Air would be crawling and slow you down.
    Working on your PC and only packaging on a Macbook Air might be a solution to get startet.

    Forget about emailing your project, that's too much data and easy to loose track.
    Transfer the project by using a version control Cloud like bitbucket (should be done anyway ) or have a shared folder in the local network.

    Important: don't copy the whole project folder. some folders are locally compiled for windows and not usable for mac. Leave /Binaries /Build /Saves and /Intermediate. The Mac should create these by itself when the project opens. You can cut down compile times with a shared folder in your local network set as an Derived Data Cache ( All files compiled for iOS will then be shared by PC and Mac, no need to compile these again.


      You can only build/package for iOS on a Mac.

      1. If you are developing on a PC, you can copy your project to your mac and build/package it there. Either by using source control, SSH secure copy or any other ways you can think of to have a copy of your project on the Mac. The best way to do it is to use the remote build feature from UE4 which makes use of SSH connection to transfer your project to the Mac and request the Unreal Engine installed on your Mac to build/package for iOS which will then return the packaged game via SSH back to your PC.

      2. It's 100% optional, it only makes the process faster once it is setup but you can literally just move your project using an USB key to the Mac and it would work just the same.

      3. Easier is subjective. You can deploy Android from a PC making it less of a hassle since you don't have all the back and forth between PC and Mac but it can also be harder depending on what you know already about iOS and Android.


        Originally posted by ANameTooLongToFi View Post
        You can only build/package for iOS on a Mac.

        2. It's 100% optional, it only makes the process faster once it is setup but you can literally just move your project using an USB key to the Mac and it would work just the same.

        This is what I am doing atm and although it is a little bit of a hassle the ease of building on a Mac makes it all worth while...


          It's worth noting that while using the Mac for building blueprint projects is optional, you need it for code, you need it to release and you need it to debug. Having an honest to god mac sitting there is a lifesaver.


            If you're shopping around for a cheap Mac, get one with an SSD. That will be more of a bottleneck than the CPU speed or even memory, when it comes to the UE4 build process. There's a ton of IO bound operations going on, and that SSD will really help.


              Desktop Macs all come with hybrid drives that have both platters and an SSD in them. They pre-cache data you use on the SSD. I wouldn't specifically look for one with an SSD because it'll be a loss in drive space with no gain in speed.


                Just checking in my 2 cents worth.

                I’m a remote building from my Windows UE4 machine on a MacBook Pro 2012 with a 500 fb SSD hard drive. It took some stuffing around to get working but now I have it rolling it is seamless.

                I’m a newbie getting ready to launch my first iOS app. I’m only doing iOS work right now and use the PC for UE4 and let the remote build tools do all the Xcode stuff. UE4 on my existing macs ran like a dog. PC horsepower per $$ was a factor in this decision too. All my PCs and macs are second hand and not too spec.

                I work on PC, deliver to App Store from Mac using ITMSTransporter. That’s my flow.


                  I have been trying to get launching to an iphone working for a week now. Keep hitting a wall, have tried everything, this is the error I'm getting:

                  After following several guides on launching to ios I still cannot get it working. I have tried an empty project, the ar kit sample and the face ar sample to no avail. This is the error I'm getting:

                  LogPlayLevel: ********** BUILD COMMAND STARTED **********
                  LogPlayLevel: Completed Launch On Stage: Build Task, Time: 5.581737
                  LogPlayLevel: Running: mono "/Users/Shared/Epic Games/UE_4.23/Engine/Binaries/DotNET/UnrealBuildTool.exe" AR IOS Development -Project=/Users/dondoo/Desktop/AR/AR.uproject /Users/dondoo/Desktop/AR/AR.uproject -NoUBTMakefiles -remoteini="/Users/dondoo/Desktop/AR" -skipdeploy -ini:Game:[/Script/UnrealEd.ProjectPackagingSettings]:BlueprintNativizationMethod=Di
                  sabled -Manifest=/Users/dondoo/Desktop/AR/Intermediate/Build/Manifest.xml -NoHotReload -log="/Users/dondoo/Library/Logs/Unreal Engine/LocalBuildLogs/UBT-AR-IOS-Development.txt"
                  LogPlayLevel: Compiling against OS Version 12.0 [minimum allowed at runtime]
                  LogPlayLevel: Error: ERROR: Unhandled exception: System.FormatException: Input string was not in a correct format.
                  LogPlayLevel: at System.Number.ThrowOverflowOrFormatException (System.Boolean overflow, System.String overflowResourceKey) [0x0001a] in <a104f9cbbafd4348bcc580acb0a3f8a8>:0
                  LogPlayLevel: at System.Number.ParseSingle (System.ReadOnlySpan`1[T] value, System.Globalization.NumberStyles styles, System.Globalization.NumberFormatInfo info) [0x00071] in <a104f9cbbafd4348bcc580acb0a3f8a8>:0
                  LogPlayLevel: at System.Single.Parse (System.String s) [0x0001a] in <a104f9cbbafd4348bcc580acb0a3f8a8>:0
                  LogPlayLevel: at UnrealBuildTool.ReadOnlyIOSTargetRules.get_RuntimeVersion () [0x00010] in <55005cea58344f71ab61265be43fc684>:0
                  LogPlayLevel: at UnrealBuildTool.IOSPlatform.SetUpEnvironment (UnrealBuildTool.ReadOnlyTargetRules Target, UnrealBuildTool.CppCompileEnvironment CompileEnvironment, UnrealBuildTool.LinkEnvironment LinkEnvironment) [0x00226] in <55005cea58344f71ab61265be43fc684>:0
                  LogPlayLevel: at UnrealBuildTool.UEBuildTarget.SetupGlobalEnvironment (UnrealBuildTool.UEToolChain ToolChain, UnrealBuildTool.CppCompileEnvironment GlobalCompileEnvironment, UnrealBuildTool.LinkEnvironment GlobalLinkEnvironment) [0x00bc8] in <55005cea58344f71ab61265be43fc684>:0
                  LogPlayLevel: at UnrealBuildTool.UEBuildTarget.Build (UnrealBuildTool.BuildConfiguration BuildConfiguration, UnrealBuildTool.ISourceFileWorkingSet WorkingSet, System.Boolean bIsAssemblingBuild, Tools.DotNETCommon.FileReference SingleFileToCompile) [0x00061] in <55005cea58344f71ab61265be43fc684>:0
                  LogPlayLevel: at UnrealBuildTool.BuildMode.CreateMakefile (UnrealBuildTool.BuildConfiguration BuildConfiguration, UnrealBuildTool.TargetDescriptor TargetDescriptor, UnrealBuildTool.ISourceFileWorkingSet WorkingSet) [0x00141] in <55005cea58344f71ab61265be43fc684>:0
                  LogPlayLevel: at UnrealBuildTool.BuildMode.Build (System.Collections.Generic.List`1[T] TargetDescriptors, UnrealBuildTool.BuildConfiguration BuildConfiguration, UnrealBuildTool.ISourceFileWorkingSet WorkingSet, UnrealBuildTool.BuildOptions Options, Tools.DotNETCommon.FileReference WriteOutdatedActionsFile) [0x0001a] in <55005cea58344f71ab61265be43
                  LogPlayLevel: at UnrealBuildTool.BuildMode.Execute (Tools.DotNETCommon.CommandLineArguments Arguments) [0x002cc] in <55005cea58344f71ab61265be43fc684>:0
                  LogPlayLevel: at UnrealBuildTool.UnrealBuildTool.Main (System.String[] ArgumentsArray) [0x00291] in <55005cea58344f71ab61265be43fc684>:0
                  LogPlayLevel: Took 30,190432s to run mono, ExitCode=5
                  LogPlayLevel: UnrealBuildTool failed. See log for more details. (/Users/dondoo/Library/Logs/Unreal Engine/LocalBuildLogs/UBT-AR-IOS-Development.txt)
                  LogPlayLevel: AutomationTool exiting with ExitCode=5 (5)
                  LogPlayLevel: Completed Launch On Stage: Build Task, Time: 29.662970
                  LogPlayLevel: Error: RunUAT ERROR: AutomationTool was unable to run successfully.
                  PackagingResults: Error: Launch failed! Unknown Error

                  I have a valid provisioning profile and certificate and apple developer account, working on a macbook pro trying to launch to an iphone x.


                    I use remote building and it works fine