Announcement

Collapse
No announcement yet.

App Rejected due to TrueDepth API in a Non-Arkit project

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    App Rejected due to TrueDepth API in a Non-Arkit project

    Hi,
    Like many that used 4.19 to package for Mobile iOS, we are getting a TrueDepth Reference in our app that Apple refuse during Review.
    All the steps that people have done in the other threads to resolve the issue failed on our side. It has been 2 months now.


    Apple Messages:
    Guideline 2.5.1 - Performance - Software Requirements
    During review, we found that your app includes TrueDepth APIs. However, we were not able to locate any features in your app that use TrueDepth APIs.
    Next Steps
    If your app does not include any features that use TrueDepth APIs, please remove them from your app.

    As your app uses the Unity ARKit plugin, it would be appropriate to update to the latest version, which includes a setting that allows you to exclude TrueDepth APIs.
    If your app does include features that use TrueDepth APIs, please reply to this message in Resolution Center to provide information on how to locate them.

    And later after 5 "fixes".
    This app makes use of `ARFaceTrackingConfiguration` and `ARFaceAnchor` which are considered to be TrueDepth APIs. It would be appropriate to remove all TrueDepth features from this app before resubmission for review.


    Steps Done: Note that ARKit was enabled back in 4.18 but was disabled for all other packagings since 4.19. All Packagings are done deleting Intermediates\Binaries and Full Rebuild to assure a clean Package.
    We Updated to 4.21.2 which should have resolved the TrueDepth bug, It did not.
    We tried Cleaning up the Apple ARkit and ARFace cpp but we are no experts (blueprint projects). One of the Epic Staff suggested we delete both ARKit and ARFace Support Plugins and recompile the source. However there still seem to be traces in the packaging.
    Searching for "ARFace" in our last ipas with a Find and Replace program (GREP and FAR) returns nothing, maybe because it's compiled. but our previous one did find "ARFace" traces.
    We pretty much tried all in there https://answers.unrealengine.com/que...8388/view.html and some small other things found in other forums.
    We have no idea what to do next, we might call Apple directly. Thanks, good day.
    Last edited by SimonParadis; 02-06-2019, 02:07 AM.
Working...
X