Announcement

Collapse
No announcement yet.

ARKit 4.18 preview 1 - official IOS 11 and XCode 9 - camera feed red?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    nicksava do you still have this issue? I would double check permissions (e.g. additional plist data) and other settings in project settings involving AR and mobile.

    Leave a comment:


  • replied
    Shaisa thanks! I got closer but now I can't see any game objects once the ARKitMaterial is applied to the camera as a post process. Without the post process I still get a black screen in 4.18.3

    Leave a comment:


  • replied
    I don't know if it's because of the 4.18.3 hotfix, or not - but if you remove all video feed backgrounds cube that you've created (based on Epic/Apple's documentation for implementing ARKit, this is what you were supposed to do) - it actually works for portrait and landscape. So actually - you don't need anything but a player with a camera that does hit tests. No need for fixes for color and stuff, too. Tested on iPhone 8 with iOS 11.2.2 and UE4.18.3

    Leave a comment:


  • replied
    Why am I getting a green feed after using the material function? Did I do something wrong here?

    Leave a comment:


  • replied
    Hey guys. You need to change material type to post process. just easy as that.

    Leave a comment:


  • replied
    Hi! Thanks for this tutorial. Do you know how to add shadows on objects using 4.18 preview4?

    Leave a comment:


  • replied
    I saw a check in for FOV fix for upcoming portrait/landscape so hopefully that will be fixed in p4 or final (whatever is next) it did mention an upcoming hot fix so may even be 4.18.1

    Leave a comment:


  • replied
    4.18p3 here. Turned on Mobile HDR based on a friends test and camera image looks brighter.

    Looks like the AR plug-in is disabled by default in p3. Had to remote build to get it on phone on win10.

    Any clues on why Portrait mode is weird?

    Leave a comment:


  • replied
    Originally posted by BGuerreiro View Post

    Hi Omigamedev, any luck fixing the dark camera feed?
    I am having the same issue
    Nope sorry, I gave up at the moment. I'll wait for the implementation to be complete, because it's clearly in preview.

    Leave a comment:


  • replied
    Originally posted by omigamedev View Post
    I keep testing and I just found out that there's no need for the material, if you remove all the backgrounds (sky and box) and you leave the black it will be filled with the video feed automatically, but to me it looks quite dark, not sure why.
    Hi Omigamedev, any luck fixing the dark camera feed?
    I am having the same issue

    Leave a comment:


  • replied
    I accidentally left the ARKit material off of the camera and off of the world background, and everything works much better. Just black nothingness in the level seems to do the camera passthrough just fine if you "Launch in AR". I don't notice any tint issues at the moment. Using 4.18p2

    Leave a comment:


  • replied
    Originally posted by Shin_ji View Post
    Would appreciate any insight from Epic Staff, since most likely we're not dealing with engine issues but wrong setup.
    Hi Shin_ji,

    It would be best to keep this thread on the topic of the red tint rendering issue, which we are still looking into and will likely be entering a bug for soon. I see that you have made an Answerhub post for your particular issue here so we'll have someone look into that issue and respond there.

    Leave a comment:


  • replied
    So in regards to AR. I've deployed test project following simple setup with cube placing.

    Material function done by skyphyr works, no red screen
    Placing cubes following simple OnTouchEvent setup from within level blueprint seems to spawn actors in the world but transform is all messed up, to me it doesn't seem like AR is working here.



    App seems to run only in landscape, swapping to portrait breaks aspect ratio.





    Would appreciate any insight from Epic Staff, since most likely we're not dealing with engine issues but wrong setup.

    Leave a comment:


  • replied
    Originally posted by ND_Dwight View Post

    Sure.
    There is a handy video on YouTube. (https://www.youtube.com/watch?v=Z6FAl6v0ax0) It shows, how to spawn actors at around 12:19. Even though it was made with 4.17, it's still usable. I attached how I did it in 4.18 preview1.
    after further investigation,I have found that if i disable the post process material and leave the camera red, the spawn works but with strange location, if i enable the post process material ,i cannot see the spawned actors anymore...

    Leave a comment:


  • replied
    Originally posted by hls333555 View Post

    thanks for the reply.actually i have tried this, almost the same blueprint, but after i install the project on my iphone7p,if i touch on the screen nothing spawns actually.but i'm sure the nodes get called because the print string works after the trace success...i really don't know what i'm missing...
    Hmm... I have tried to spawn 6 different Actor blueprints with each having a pre set static mesh component. The different meshes have the same material and are created inside Unreal (cubes that vary in size). Now that I try to spawn them, some spawn and some don't.

    I tried to spawn them in the same way in a non AR environment, and it works perfectly.

    I now also don't know what's missing or wrong. Could it be a bug?

    Leave a comment:

Working...
X