Announcement

Collapse
No announcement yet.

ARKit 4.18 preview 1 - official IOS 11 and XCode 9 - camera feed red?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by darinsmyth View Post

    This gets ARKit working with ios 11 and xcode 9 official versions. But the camera display will be RED.
    It works, just as you said. Thank you! And you may be "happy" to hear, that my camera display is also red.

    Leave a comment:


  • replied
    Originally posted by ND_Dwight View Post

    Do you mind telling me how you got it to work?
    I deleted the ARKitCamera and the texture, from 4.17.
    In 4.18 I now export to iphone and run the app, but I see a white background instead of camera feed and can not move the camera...
    -EDIT UPDATE This has now been updated after fixes below so the camera should now work fine!! Thanks to Skyphyr and Omigamedev
    This gets ARKit camera working with ios 11 and xcode 9 official versions.

    Install 4.18 Preview 1.
    Create new project -> blank -> set it to mobile, no starter content, scaleable 2d/3d
    Apple ARKit plugin should be enabled as default but just double check under plugins.
    Setup IOS so your provision/certificate are present. Setup bundle display/name/identifier
    Change minimum ios version to IOS 11, I've kept Metal v1.2, Frame rate lock to 60fps
    Under Project settings enable 'Start in AR'
    Under Additional Plist data add this: <key>NSCameraUsageDescription</key> <string>This application will use the camera for AR</string>
    Restart if prompted

    Enable Show Engine Content and Show Plugin Content from the view options in Content browser
    In your game world you should have a Directional Light (mine set to static)
    Create a new Blueprint of type pawn and add a camera component to it. Go to the Camera component details->Rendering Features -> Post Processing Material, where it says Array click on the +, from the dropdown Choose ->Asset Reference, click on none, now in Browse type in ARKitCameraMaterial, select this.
    Click compile
    Now add this Pawn to your world at position 0,0,0
    Build lighting if necessary.
    Connect your iphone/ipad and Launch
    Game should start with camera now functioning.
    Last edited by darinsmyth; 09-23-2017, 05:19 PM.

    Leave a comment:


  • replied
    Originally posted by darinsmyth View Post
    Hi, I've managed to get ARKit working on official ios11 and xcode 9 using 4.18 P1 on iphone 6s however the camera feed now has a red tint to it, could any of the devs give any pointers in getting the camera to show as 'normal'? Steps were: Creating an unlit 2-sided material using the ARKit Passthrough Camera node (Texture Y and const coord 0), using a regular camera component in my pawn and have enabled 'Start in ar' option from project settings. Thx.
    Do you mind telling me how you got it to work?
    I deleted the ARKitCamera and the texture, from 4.17.
    In 4.18 I now export to iphone and run the app, but I see a white background instead of camera feed and can not move the camera...

    Leave a comment:


  • replied
    Originally posted by Matthew J View Post
    Hello darinsmyth,

    Thank you for reporting this issue. We'll be investigating this issue and respond here if we need anymore information, which will likely lead to wanting you to create an Answerhub post for further correspondence.
    No problem

    Leave a comment:


  • replied
    Hello darinsmyth,

    Thank you for reporting this issue. We'll be investigating this issue and respond here if we need anymore information, which will likely lead to wanting you to create an Answerhub post for further correspondence.

    Leave a comment:


  • ARKit 4.18 preview 1 - official IOS 11 and XCode 9 - camera feed red?

    Hi, I've managed to get ARKit working on official ios11 and xcode 9 using 4.18 P1 on iphone 6s however the camera feed now has a red tint to it, could any of the devs give any pointers in getting the camera to show as 'normal'? Steps were: Creating an unlit 2-sided material using the ARKit Passthrough Camera node (Texture Y and const coord 0), using a regular camera component in my pawn and have enabled 'Start in ar' option from project settings. Thx.
Working...
X