Announcement

Collapse
No announcement yet.

HTML5 always fails in UE 4.12

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    HTML5 always fails in UE 4.12

    No matter what project I try to package it will always fail at:

    MainFrameActions: Packaging (HTML5): UnrealBuildTool: error: Linking globals named '_Z14UELinkerFixupsv': symbol multiply defined!

    Even if I try to package blank one. Is this a know bug? Or am I missing something since there seems to be no info on this anywhere and one would expect that if this was the case with HTML5 packaging it would be all over these forums.

    Thanks.

    #2
    try disabling plugins that you are not using. if you have marketplace plugins enabled, they also might be the cause on multiple symbol definition error.
    if you have c++ code, be sure that you are using macros correctly. if you have any IMPLEMENT_MODULE calls, be sure that variables are all ok.

    Comment


      #3
      Thanks and sorry for late reply finally had time for some HTML5 testing, disabling Plugins (Substance, VaRest) did help something but now there is an entirely new error:

      Could not find file c:\Program Files (x86)\Epic Games\4.12\Engine\Intermediate\Build\HTML5\.emscripten

      I do have full UE4 installed with HTML5 option as well.

      Comment


        #4
        open control panel (if you are on windows 10, open the older one that looks like win7 version.)
        right top, there is a drop down, select large icons from the list.
        click the system icon, and select "advanced system settings" from the list on the left.
        (also on windows 10, you can search "system environment variables" and click "edit system env. vars." from the search result)

        now, click the Advanced tab, click Environment Variables button.

        is there an EM_CONFIG variable set in the bottom list? if so, remove it or rename it something like EM_CONFIG_TMP
        check both PATH variables (double click on them, one in top and the other is in the bottom list) and make sure that they do not have any .emscripten, if there is, remove that file link.

        oooh and restart then... that is the most important part
        Last edited by emrahgunduz; 07-18-2016, 03:25 AM.

        Comment


          #5
          I'm using Windows 10 and UE 4.14.1, and I'm getting the .emscripten file not found error.

          I don't have the EM_CONFIG system variable and verified that by running "set EM_CONFIG".

          Comment


            #6
            I followed the installation instruction months ago and I have emscripten, python, and Firefox nightly build installed.

            I found out that this was causing the problem. I uninstalled .emscipten and firefox nightly build. I removed the python entries in the Path and a PYTHONHOME environment variable.

            And finally HTML5 Package build was successful.

            Comment


              #7
              As for .emscripten file not found error, there is a known issue on Windows. When there is HOME environment variable, packaging fails with the error.
              The issue is UE-36717 and the fix will be in 4.16.
              https://issues.unrealengine.com/issue/UE-36717

              Comment


                #8
                I do have full UE4 installed with HTML5 option as we
                1onlineapotheke.de Cialis bestellen levitra kaufen

                Comment


                  #9
                  Originally posted by Rumiko Hoshino View Post
                  As for .emscripten file not found error, there is a known issue on Windows. When there is HOME environment variable, packaging fails with the error.
                  The issue is UE-36717 and the fix will be in 4.16.
                  https://issues.unrealengine.com/issue/UE-36717
                  has this been fixed? because I'm getting the missing .emscripten file error too (using 4.16.3), I do not have a home or em_config var either.

                  EDIT NVM (of course), I reinstalled UE4 and started new project, packaging was successful. Not sure what the cause was but I have a feeling that even though I disabled the houdini engine plugin that something was still lingering maybe? (that was the only external pluging running on my UE4)

                  so if anyone is having similar problem a full reinstall helped me.
                  Last edited by elgordostudio; 07-31-2017, 06:25 PM.

                  Comment

                  Working...
                  X