Announcement

Collapse
No announcement yet.

Character disappears in game after packaging for html5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Character disappears in game after packaging for html5

    Hey everyone,

    I just build a completely sidescroller game , everything works like a charm in the preview, but if I am packaging the whole game for html5, my character is not showing up in the game. Everything else is showing.

    I already read through some other topics and tried out all the suggested thinks, but it is not working at all.

    Here are all the things I already eliminated:
    • Reduced the amount of bones to 68
    • Each vertices is influenced by max. 4 bones
    • The character has only 6900 vertices
    • I only imported the mesh, without the skeletal, then the character is showing up in the scene, so there must be something wrong with the skeletal. But I am just not sure, what it is.
    In my Output log I am getting the following yellow lines, but I am not sure, what exactly I can do to get rid of them or if they are the reason, why my character is not showing up. It is my first game:
    • Warning: Getting valid bind pose failed. Try to recreate bind pose.
    • Warning: Recreating bind pose succeeded.
    • Warning: Material needed to have new flag set bUsedWithSkeletalMesh !
    • Wrang: Bones digested - 68 Depth of hierarchy -17

    I also packaged the sidescroller from unreal. The character in there is showing up, so there must be something wrong, with my skeletal, I just cannot find the answer to it.

    It would be great, If anyone of you has an idea and would eb so kind to help me.

    Have a lovely Sunday and thanks a lot
    Anna

Working...
X