Announcement

Collapse
No announcement yet.

Packaging for HTML5 - either development or shipping there are problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Packaging for HTML5 - either development or shipping there are problems

    Hello, I am really struggling here. And tried this with 2-3 projects even with an empty project and i cant get it to work in a browser with local host or on a server.
    Everytime i package the project for SHIPPING it says 404 not found and in the command window of the html5 helper it says not serving<project name>

    If i package for development at least the launcher starts and then crashes with an error i dont understand.(see screenshot)

    So here are all the different ways i tried packaging.

    1. Just packaged(development) a new empty project without adding c++ code and without generating visual studio files from the windows exploer project file. The result was a correclty exported HTML5 project which opened up but got a black screen only. Tried packaging(shipping) and got the error 404 directly and nothing happened.

    2. Added c++ code - same outcome. Added visual studio project files - same outcome. Deleted some folders and rebuilt the project - same outcome.

    Tried with compress and dont comrpess, tried with PAK and wihout PAK file.

    Tried installing emscripten SDK and python and adding environment shortcuts but that totally broke the packaging project so i uninstalled emscripten SDK but didnt uninstal python yet as it makes no difference .. with or without.

    Tried with my real project all those things and got the error from the screenshot when packaging for development. I really REALLY have no idea what to try anymore. PLS HELP

    edit: at one time when i was launching html5 from the engine itself it was starting .. with some broken geometry BUT was working. Now it spits out the same error i get when i package it. I am doing it "by the book" from the launch ..
    Last edited by IvayloEGT; 12-13-2018, 10:26 AM.

    #2
    so i installed visual studio 2017 (was using 2015) tried again with a blank project - still black screen, blank project with starter content AND it works, blueprint first person sample scene - it works

    my project still DOESNT WORK though. Tried deleting every object and blueprint and it still doesnt work. Could the fact that it was all imported from datasmith be problematic? in the error ubject..globals .. what could this mean?

    Comment

    Working...
    X