Announcement

Collapse
No announcement yet.

Unreal Engine 4 is available for Win10 UWP app dev now

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Bluemak View Post

    polkovnika3

    Try the following in the project settings:
    1- Change the build configuration to shipping in the packaging.
    2- Check create compressed cooked package to true.
    Thanks this works.

    Leave a comment:


  • replied
    Originally posted by polkovnika3 View Post
    Can anyone confirm that it works on the console Xbox One ?
    I tested the simplest template but the console does not load it displays an error.
    " For some reason UE4Game took too long to start. (0x8027025a) "
    polkovnika3

    Try the following in the project settings:
    1- Change the build configuration to shipping in the packaging.
    2- Check create compressed cooked package to true.

    Leave a comment:


  • replied
    Can anyone confirm that it works on the console Xbox One ?
    I tested the simplest template but the console does not load it displays an error.
    " For some reason UE4Game took too long to start. (0x8027025a) "

    Leave a comment:


  • replied
    Originally posted by Sparkash View Post
    I can build and run from within Visual Studio 2015, but when I try to create a package from within UE, I get the following error -

    Code:
    UATHelper: Packaging (UWP (x86-32bit)): MSBuild: UWPPlatform.Automation.cs(214,63): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [...\engine\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
    Any thoughts?
    And for everyone having that issue:
    Open Project in visual studio, select UWP.Automation from the right, then Project > Manage NugetPackages and install WindowsDevicePortalWrapper

    Leave a comment:


  • replied
    Hi anyone know how to update UE4 Fork so he can see the newer versions of Windows SDK 10.0.17134.0,..
    Now with SDK version 10.0.16299.0, there is not one project running.

    I apologize for my bad English.

    Leave a comment:


  • replied
    Originally posted by ZeJudge View Post
    I have now successfully compiled & packaged my game, although I am unable to launch it. It seems that when I attempt a launch it will look as though it tries to open, then it closes with no error. If I try to open the application directly from the installed folder then I get a number of errors stating that the following DLL files cannot be found:


    vccorlib140_app.DLL
    MSVCP140_APP.dll
    CONCRT140_APP.dll
    VCRUNTIME140_APP.dll
    We are running into this same issue, when running our game from Visual Studio 2015.
    Windows SDK: 10.0.14393.0
    Visual Studio 2015
    Solution Configuration: Development
    Solution Platform: UWP64
    Startup Project: GameTitle (Universal Windows)
    Debugger: Local Windows Debugger

    Leave a comment:


  • replied
    Hi anyone know where I can download this version of the SDK.
    PS: I fixed my problem.
    Last edited by polkovnika3; 05-19-2018, 02:58 PM.

    Leave a comment:


  • replied
    Originally posted by jsyarrow View Post


    When you're seeing the immediate close on launch, is that under the debugger? If not, I'd suggest trying with the debugger attached to see whether you get better info. Use Debug->Other debug targets->Debug Installed App Package in Visual Studio. Depending on how early in startup the failure occurs you may need to check the 'Do not launch, but debug my code when it starts' box, in which case you should wait for the debugger to fully attach and then launch your app normally to observe the results.

    A couple of things that I know offhand can cause failures early in the startup process:
    - Incorrectly setting the 'Use Retail Windows Store Environment' flag in UWP project settings. If you check this on, then you must have a catalog entry for your product in the retail environment of the store (hidden is fine); if you check it off (default), your OS must be in development mode to run the app. You must check it on when building a final package for submission.
    - Long stalls on the game thread during startup. UWP apps are required to get their message pump up and running within a few seconds of launch. If they don't the OS will summarily kill them. If you have long-running work that occurs early in the launch flow you could be getting caught by this.

    Failure to launch when double-clicking the exe in the folder is to be expected. There's extra work the OS does to set up the UWP environment before passing control to your code. A part of that is setting up paths so that those dlls can be found.



    This fork hasn't been updated to specifically understand SDKs past 16299. Looks like 17134 includes some schema additions that need to be accounted for. As you've discovered you can explicitly lock to an earlier SDK. That should fix the first complaint in your log.

    As the text notes, however, that first message should be non-fatal. I think it's the stuff that comes after that is causing the real trouble:



    You should check UWP project settings for this value. If you're not using Xbox Live you should leave the field empty.



    I suspect this is ultimately what kills the build. It looks like we have a bug in Engine\Plugins\Runtime\ApexDestruction\Source\ThirdParty\PhysX\ApexDestructionLib.Build.cs - it's still looking in the old pre-4.19 locations for the APEX dll . In the latest version everything should be in Binaries\ThirdParty\PhysX3\UWP64. If you adjust the values of ApexBinariesDir for UWP64/32 it might get you up and running .



    jsyarrow Thank you very much!

    Leave a comment:


  • replied
    Originally posted by jsyarrow View Post


    When you're seeing the immediate close on launch, is that under the debugger? If not, I'd suggest trying with the debugger attached to see whether you get better info. Use Debug->Other debug targets->Debug Installed App Package in Visual Studio. Depending on how early in startup the failure occurs you may need to check the 'Do not launch, but debug my code when it starts' box, in which case you should wait for the debugger to fully attach and then launch your app normally to observe the results.

    A couple of things that I know offhand can cause failures early in the startup process:
    - Incorrectly setting the 'Use Retail Windows Store Environment' flag in UWP project settings. If you check this on, then you must have a catalog entry for your product in the retail environment of the store (hidden is fine); if you check it off (default), your OS must be in development mode to run the app. You must check it on when building a final package for submission.
    - Long stalls on the game thread during startup. UWP apps are required to get their message pump up and running within a few seconds of launch. If they don't the OS will summarily kill them. If you have long-running work that occurs early in the launch flow you could be getting caught by this.



    Thanks jsyarrow! Your debugging method helped track down the issue. It looks like the packager didn't copy over the following file and so was falling over: \Engine\Binaries\ThirdParty\PhysX3\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll

    Everything is now working great, thanks!

    Leave a comment:


  • replied

    Originally posted by ZeJudge View Post

    I have now successfully compiled & packaged my game, although I am unable to launch it. It seems that when I attempt a launch it will look as though it tries to open, then it closes with no error. If I try to open the application directly from the installed folder then I get a number of errors stating that the following DLL files cannot be found:


    vccorlib140_app.DLL
    MSVCP140_APP.dll
    CONCRT140_APP.dll
    VCRUNTIME140_APP.dll
    When you're seeing the immediate close on launch, is that under the debugger? If not, I'd suggest trying with the debugger attached to see whether you get better info. Use Debug->Other debug targets->Debug Installed App Package in Visual Studio. Depending on how early in startup the failure occurs you may need to check the 'Do not launch, but debug my code when it starts' box, in which case you should wait for the debugger to fully attach and then launch your app normally to observe the results.

    A couple of things that I know offhand can cause failures early in the startup process:
    - Incorrectly setting the 'Use Retail Windows Store Environment' flag in UWP project settings. If you check this on, then you must have a catalog entry for your product in the retail environment of the store (hidden is fine); if you check it off (default), your OS must be in development mode to run the app. You must check it on when building a final package for submission.
    - Long stalls on the game thread during startup. UWP apps are required to get their message pump up and running within a few seconds of launch. If they don't the OS will summarily kill them. If you have long-running work that occurs early in the launch flow you could be getting caught by this.

    Failure to launch when double-clicking the exe in the folder is to be expected. There's extra work the OS does to set up the UWP environment before passing control to your code. A part of that is setting up paths so that those dlls can be found.

    Originally posted by Peterson Oliveira View Post
    ...
    But I saw my last version for the windows sdk in my pc is 10.0.17134.0 but in UE4 no is 10.0.16299.0
    ...
    This fork hasn't been updated to specifically understand SDKs past 16299. Looks like 17134 includes some schema additions that need to be accounted for. As you've discovered you can explicitly lock to an earlier SDK. That should fix the first complaint in your log.

    As the text notes, however, that first message should be non-fatal. I think it's the stuff that comes after that is causing the real trouble:

    Originally posted by Peterson Oliveira View Post
    [2018.05.14-07.33.44:077][611]UATHelper: Packaging (UWP (x64-64bit)): ERROR: Xbox Live Title Id was not in a recognized format. Specify a 32 bit hex number (without leading 0x)
    You should check UWP project settings for this value. If you're not using Xbox Live you should leave the field empty.

    Originally posted by Peterson Oliveira View Post
    [2018.05.14-07.37.52:813][357]UATHelper: Packaging (UWP (x64-64bit)): WARNING: SafeCopyFile Exception was Exception in mscorlib: Could not find a part of the path 'C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll'.
    I suspect this is ultimately what kills the build. It looks like we have a bug in Engine\Plugins\Runtime\ApexDestruction\Source\ThirdParty\PhysX\ApexDestructionLib.Build.cs - it's still looking in the old pre-4.19 locations for the APEX dll. In the latest version everything should be in Binaries\ThirdParty\PhysX3\UWP64. If you adjust the values of ApexBinariesDir for UWP64/32 it might get you up and running.




    Leave a comment:


  • replied
    Originally posted by fpoulin View Post
    At the beginning of your log I see:

    The 'http://schemas.microsoft.com/appx/manifest/uap/windows10/6:CodecMimeType' attribute is not declared.
    XML schema failed to compile; validation of the final AppxManifest.xml will be skipped.
    If your AppxManifest.xml is valid then this is harmless, but if it contains invalid content you may encounter packaging or deployment errors.
    Updating your Windows SDK and/or Visual Studio installation may correct the schema problems and simplify diagnosis of invalid content.
    ERROR: Xbox Live Title Id was not in a recognized format. Specify a 32 bit hex number

    1. Are you using Visual Studio 2017, if yes make sure to add -2017 to the GenerateProjectFiles to setup the UE4.sln project correctly
    GenerateProjectFiles.bat -2017
    2. In Unreal Editor make sure the project Settings are also set correctly:
    - Platforms --> UWP --> Toolchain --> Compiler Version: Visual Studio 2017
    - Platforms --> UWP --> Toolchain --> Windows 10 SDK: 10.0.16299.0 (the most recent SDK installed on my PC)

    Apart from that I'm not sure what the problem could be.

    Good Luck!

    Hi fpoulin
    Already done all this.
    But I saw my last version for the windows sdk in my pc is 10.0.17134.0 but in UE4 no is 10.0.16299.0
    Maybe is this.

    Thanks for try help me.

    Click image for larger version  Name:	 Views:	1 Size:	13.7 KB ID:	1475751
    Click image for larger version  Name:	 Views:	1 Size:	19.2 KB ID:	1475752
    Click image for larger version  Name:	 Views:	1 Size:	62.0 KB ID:	1475753
    Last edited by Star Game Studio; 05-14-2018, 05:08 PM.

    Leave a comment:


  • replied
    Originally posted by jsyarrow View Post
    In case you haven't already tracked this down: ICMP is not a module we've ever specifically ported to UWP as it's not typically used by games that do multiplayer over Live. It appears to contain some platform-specific code. The missing definitions (along with a few others) are (for Windows) in a Windows/IcmpWindows.cpp file which would be omitted when compiling for UWP. You'll need to provide an equivalent UWP/IcmpUWP.cpp file, which may well be able to just reuse all the Windows Desktop code (e.g. much of the D3D12 RHI works this way).
    Thanks jsyarrow - I disabled the OnlineFramework plugin and this has now compiled correctly. Sorry, I didn't realise you mentioned this in a previous post, sometimes these solutions get lost in the noise.

    I have now successfully compiled & packaged my game, although I am unable to launch it. It seems that when I attempt a launch it will look as though it tries to open, then it closes with no error. If I try to open the application directly from the installed folder then I get a number of errors stating that the following DLL files cannot be found:


    vccorlib140_app.DLL
    MSVCP140_APP.dll
    CONCRT140_APP.dll
    VCRUNTIME140_APP.dll


    Even though these files do exist in the following directory and the report.wer of my game states it attempts to load these files: C:\Program Files\WindowsApps\Microsoft.VCLibs.140.00_14.0.25426.0_x64__8wekyb3d8bbwe

    Compiler Version Used: VS 2017
    Windows SDK: 10.0.16299.0
    Build Configuration: Development

    I have both VS 2015 & VS 2017 C++ Redistributables Runtimes installed.

    Leave a comment:


  • replied
    At the beginning of your log I see:

    The 'http://schemas.microsoft.com/appx/manifest/uap/windows10/6:CodecMimeType' attribute is not declared.
    XML schema failed to compile; validation of the final AppxManifest.xml will be skipped.
    If your AppxManifest.xml is valid then this is harmless, but if it contains invalid content you may encounter packaging or deployment errors.
    Updating your Windows SDK and/or Visual Studio installation may correct the schema problems and simplify diagnosis of invalid content.
    ERROR: Xbox Live Title Id was not in a recognized format. Specify a 32 bit hex number

    1. Are you using Visual Studio 2017, if yes make sure to add -2017 to the GenerateProjectFiles to setup the UE4.sln project correctly
    GenerateProjectFiles.bat -2017
    2. In Unreal Editor make sure the project Settings are also set correctly:
    - Platforms --> UWP --> Toolchain --> Compiler Version: Visual Studio 2017
    - Platforms --> UWP --> Toolchain --> Windows 10 SDK: 10.0.16299.0 (the most recent SDK installed on my PC)

    Apart from that I'm not sure what the problem could be.

    Good Luck!


    Leave a comment:


  • replied
    Originally posted by MackeyK24 View Post
    OMG... I cant believe that Microsoft (the most power software company on the planet) and Epic... With out a doubt one of the best and complete game engines in world.

    And with both of those POWER houses... We still have this CRAZY LONG UWP external build process...

    IF YOU CAN GET IT TO BUILD AT ALL... I sure the XXX cant

    After TWO HOURS of building, I get a failure towards the end:
    UBT Error: Failed to build UE4Editor-UWPDeviceDetector

    Anybody got any clues about that one ?

    UPDATE: If you have problems with UWP-DeviceDetector or WindowsDevicePortal. After you generate the Project files (using -2017). Manually add the windows device portal nugget package to the UWP.Automation project and build that first. Then build the whole UE4 solution.

    That FINALLY worked for me... After many hours...

    I know everyone says this... But man UWP need to be binary marketplace plugin already
    Hi.
    Look that tutorial.
    This tutorial are the steps it takes to port a UE4 game to a retail XboxOne in Developer Mode. Note: Currently this process only works for 2...

    Leave a comment:


  • replied
    Hello guys.

    If I build for windows 64bits work fine!
    But if I build to UWP 64bits the build fails!
    And if I create a new project third person and build in uwp 64 work fine too.

    Anyone help me, please!
    Thanks

    That the final error!

    [2018.05.14-07.33.39:156][596]UATHelper: Packaging (UWP (x64-64bit)): Execution of commandlet took: 226.94 seconds
    [2018.05.14-07.33.43:402][609]UATHelper: Packaging (UWP (x64-64bit)): LogOnline: Display: OSS: FOnlineSubsystemNull::Shutdown()
    [2018.05.14-07.33.43:403][609]UATHelper: Packaging (UWP (x64-64bit)): LogOnline: Display: OSS: FOnlineAsyncTaskManager::Stop() ActiveTask:0000000000000000 Tasks[0/0]
    [2018.05.14-07.33.43:403][609]UATHelper: Packaging (UWP (x64-64bit)): LogOnline: Display: OSS: FOnlineAsyncTaskManager::Exit() started
    [2018.05.14-07.33.43:403][609]UATHelper: Packaging (UWP (x64-64bit)): LogOnline: Display: OSS: FOnlineAsyncTaskManager::Exit() finished
    [2018.05.14-07.33.44:073][611]UATHelper: Packaging (UWP (x64-64bit)): Took 250.8304621s to run UE4Editor-Cmd.exe, ExitCode=0
    [2018.05.14-07.33.44:074][611]UATHelper: Packaging (UWP (x64-64bit)): ********** COOK COMMAND COMPLETED **********
    [2018.05.14-07.33.44:074][611]UATHelper: Packaging (UWP (x64-64bit)): ********** STAGE COMMAND STARTED **********
    [2018.05.14-07.33.44:074][611]UATHelper: Packaging (UWP (x64-64bit)): Creating UE4CommandLine.txt
    [2018.05.14-07.33.44:074][611]UATHelper: Packaging (UWP (x64-64bit)): Creating Staging Manifest...
    [2018.05.14-07.33.44:075][611]UATHelper: Packaging (UWP (x64-64bit)): WARNING:
    [2018.05.14-07.33.44:075][611]UATHelper: Packaging (UWP (x64-64bit)):
    [2018.05.14-07.33.44:075][611]UATHelper: Packaging (UWP (x64-64bit)): file:///C:/Program Files (x86)/Microsoft Visual Studio/2017/Community/Xml/Schemas/UapManifestSchema_v4.xsd(164): The 'http://schemas.microsoft.com/appx/manifest/uap/windows10/6:CodecMimeType' attribute is not declared.
    [2018.05.14-07.33.44:076][611]UATHelper: Packaging (UWP (x64-64bit)):
    [2018.05.14-07.33.44:076][611]UATHelper: Packaging (UWP (x64-64bit)): XML schema failed to compile; validation of the final AppxManifest.xml will be skipped.
    [2018.05.14-07.33.44:076][611]UATHelper: Packaging (UWP (x64-64bit)):
    [2018.05.14-07.33.44:076][611]UATHelper: Packaging (UWP (x64-64bit)): If your AppxManifest.xml is valid then this is harmless, but if it contains invalid content you may encounter packaging or deployment errors.
    [2018.05.14-07.33.44:076][611]UATHelper: Packaging (UWP (x64-64bit)):
    [2018.05.14-07.33.44:077][611]UATHelper: Packaging (UWP (x64-64bit)): Updating your Windows SDK and/or Visual Studio installation may correct the schema problems and simplify diagnosis of invalid content.
    [2018.05.14-07.33.44:077][611]UATHelper: Packaging (UWP (x64-64bit)): ERROR: Xbox Live Title Id was not in a recognized format. Specify a 32 bit hex number (without leading 0x)
    [2018.05.14-07.33.45:070][614]UATHelper: Packaging (UWP (x64-64bit)): Cleaning Stage Directory: C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64
    [2018.05.14-07.33.45:070][614]UATHelper: Packaging (UWP (x64-64bit)): Creating pak using staging manifest.
    [2018.05.14-07.33.45:405][615]UATHelper: Packaging (UWP (x64-64bit)): Running UnrealPak *******
    [2018.05.14-07.33.45:405][615]UATHelper: Packaging (UWP (x64-64bit)): Running: C:\UNREALENGINE\UE_UWP\Engine\Binaries\Win64\UnrealPak.exe C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64\CatchTheThief\Content\Paks\CatchTheThief-UWP64.pak -create=C:\UNREALENGINE\UE_UWP\Engine\Programs\AutomationTool\Saved\Logs\PakList_CatchTheThief-UWP64.txt -encryptionini -enginedir="C:\UNREALENGINE\UE_UWP\Engine" -projectdir="C:\UNREALENGINE\CatchTheThief" -platform=UWP -abslog="C:\UNREALENGINE\UE_UWP\Engine\Programs\AutomationTool\Saved\Logs\PakLog_CatchTheThief-UWP64.log" -order=C:\UNREALENGINE\CatchTheThief\Build\UWP64\FileOpenOrder\CookerOpenOrder.log -UTF8Output -multiprocess
    [2018.05.14-07.33.46:072][617]UATHelper: Packaging (UWP (x64-64bit)): LogPakFile: Display: Loading response file C:\UNREALENGINE\UE_UWP\Engine\Programs\AutomationTool\Saved\Logs\PakList_CatchTheThief-UWP64.txt
    [2018.05.14-07.33.46:403][618]UATHelper: Packaging (UWP (x64-64bit)): LogPakFile: Display: Added 12808 entries to add to pak file.
    [2018.05.14-07.33.46:404][618]UATHelper: Packaging (UWP (x64-64bit)): LogPakFile: Display: Loading pak order file C:\UNREALENGINE\CatchTheThief\Build\UWP64\FileOpenOrder\CookerOpenOrder.log...
    [2018.05.14-07.33.46:739][619]UATHelper: Packaging (UWP (x64-64bit)): LogPakFile: Display: Finished loading pak order file C:\UNREALENGINE\CatchTheThief\Build\UWP64\FileOpenOrder\CookerOpenOrder.log.
    [2018.05.14-07.33.46:739][619]UATHelper: Packaging (UWP (x64-64bit)): LogPakFile: Display: Collecting files to add to pak file...
    [2018.05.14-07.33.46:740][619]UATHelper: Packaging (UWP (x64-64bit)): LogPakFile: Display: Collected 12808 files in 0.16s.
    [2018.05.14-07.37.52:154][355]UATHelper: Packaging (UWP (x64-64bit)): LogPakFile: Display: Added 12808 files, 2047794194 bytes total, time 245.33s.
    [2018.05.14-07.37.52:154][355]UATHelper: Packaging (UWP (x64-64bit)): LogPakFile: Display: Compression summary: 41.21% of original size. Compressed Size 1927229411 bytes, Original Size 4676787999 bytes.
    [2018.05.14-07.37.52:155][355]UATHelper: Packaging (UWP (x64-64bit)): LogPakFile: Display: Unreal pak executed in 246.003016 seconds
    [2018.05.14-07.37.52:481][356]UATHelper: Packaging (UWP (x64-64bit)): Took 247.105272s to run UnrealPak.exe, ExitCode=0
    [2018.05.14-07.37.52:481][356]UATHelper: Packaging (UWP (x64-64bit)): UnrealPak Done *******
    [2018.05.14-07.37.52:482][356]UATHelper: Packaging (UWP (x64-64bit)): Copying NonUFSFiles to staging directory: C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64
    [2018.05.14-07.37.52:813][357]UATHelper: Packaging (UWP (x64-64bit)): WARNING: SafeCopyFile Exception was Exception in mscorlib: Could not find a part of the path 'C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll'.
    [2018.05.14-07.37.52:814][357]UATHelper: Packaging (UWP (x64-64bit)): Stacktrace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    [2018.05.14-07.37.52:814][357]UATHelper: Packaging (UWP (x64-64bit)): at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
    [2018.05.14-07.37.52:814][357]UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.InternalUtils.SafeCopyFile(String SourceName, String TargetName, Boolean bQuiet, Boolean bFilterSpecialLinesFromIniFiles) in C:\UNREALENGINE\UE_UWP\Engine\Source\Programs\AutomationTool\AutomationUtils\Utils.cs:line 364
    [2018.05.14-07.37.52:815][357]UATHelper: Packaging (UWP (x64-64bit)): WARNING: Failed to copy C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll to C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll, deleting, waiting 10s and retrying.
    [2018.05.14-07.38.02:812][387]UATHelper: Packaging (UWP (x64-64bit)): WARNING: SafeCopyFile Exception was Exception in mscorlib: Could not find a part of the path 'C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll'.
    [2018.05.14-07.38.02:813][387]UATHelper: Packaging (UWP (x64-64bit)): Stacktrace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    [2018.05.14-07.38.02:813][387]UATHelper: Packaging (UWP (x64-64bit)): at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
    [2018.05.14-07.38.02:814][387]UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.InternalUtils.SafeCopyFile(String SourceName, String TargetName, Boolean bQuiet, Boolean bFilterSpecialLinesFromIniFiles) in C:\UNREALENGINE\UE_UWP\Engine\Source\Programs\AutomationTool\AutomationUtils\Utils.cs:line 364
    [2018.05.14-07.38.02:815][387]UATHelper: Packaging (UWP (x64-64bit)): WARNING: Failed to copy C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll to C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll, deleting, waiting 10s and retrying.
    [2018.05.14-07.38.12:812][417]UATHelper: Packaging (UWP (x64-64bit)): WARNING: SafeCopyFile Exception was Exception in mscorlib: Could not find a part of the path 'C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll'.
    [2018.05.14-07.38.12:813][417]UATHelper: Packaging (UWP (x64-64bit)): Stacktrace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    [2018.05.14-07.38.12:814][417]UATHelper: Packaging (UWP (x64-64bit)): at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
    [2018.05.14-07.38.12:814][417]UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.InternalUtils.SafeCopyFile(String SourceName, String TargetName, Boolean bQuiet, Boolean bFilterSpecialLinesFromIniFiles) in C:\UNREALENGINE\UE_UWP\Engine\Source\Programs\AutomationTool\AutomationUtils\Utils.cs:line 364
    [2018.05.14-07.38.12:815][417]UATHelper: Packaging (UWP (x64-64bit)): WARNING: Failed to copy C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll to C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll, deleting, waiting 10s and retrying.
    [2018.05.14-07.38.22:814][447]UATHelper: Packaging (UWP (x64-64bit)): WARNING: SafeCopyFile Exception was Exception in mscorlib: Could not find a part of the path 'C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll'.
    [2018.05.14-07.38.22:815][447]UATHelper: Packaging (UWP (x64-64bit)): Stacktrace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    [2018.05.14-07.38.22:816][447]UATHelper: Packaging (UWP (x64-64bit)): at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
    [2018.05.14-07.38.22:817][447]UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.InternalUtils.SafeCopyFile(String SourceName, String TargetName, Boolean bQuiet, Boolean bFilterSpecialLinesFromIniFiles) in C:\UNREALENGINE\UE_UWP\Engine\Source\Programs\AutomationTool\AutomationUtils\Utils.cs:line 364
    [2018.05.14-07.38.22:818][447]UATHelper: Packaging (UWP (x64-64bit)): WARNING: Failed to copy C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll to C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll, deleting, waiting 10s and retrying.
    [2018.05.14-07.38.32:815][477]UATHelper: Packaging (UWP (x64-64bit)): WARNING: SafeCopyFile Exception was Exception in mscorlib: Could not find a part of the path 'C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll'.
    [2018.05.14-07.38.32:816][477]UATHelper: Packaging (UWP (x64-64bit)): Stacktrace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    [2018.05.14-07.38.32:816][477]UATHelper: Packaging (UWP (x64-64bit)): at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
    [2018.05.14-07.38.32:817][477]UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.InternalUtils.SafeCopyFile(String SourceName, String TargetName, Boolean bQuiet, Boolean bFilterSpecialLinesFromIniFiles) in C:\UNREALENGINE\UE_UWP\Engine\Source\Programs\AutomationTool\AutomationUtils\Utils.cs:line 364
    [2018.05.14-07.38.32:818][477]UATHelper: Packaging (UWP (x64-64bit)): WARNING: Failed to copy C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll to C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll, deleting, waiting 10s and retrying.
    [2018.05.14-07.38.42:814][507]UATHelper: Packaging (UWP (x64-64bit)): WARNING: SafeCopyFile Exception was Exception in mscorlib: Could not find a part of the path 'C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll'.
    [2018.05.14-07.38.42:815][507]UATHelper: Packaging (UWP (x64-64bit)): Stacktrace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    [2018.05.14-07.38.42:816][507]UATHelper: Packaging (UWP (x64-64bit)): at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
    [2018.05.14-07.38.42:817][507]UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.InternalUtils.SafeCopyFile(String SourceName, String TargetName, Boolean bQuiet, Boolean bFilterSpecialLinesFromIniFiles) in C:\UNREALENGINE\UE_UWP\Engine\Source\Programs\AutomationTool\AutomationUtils\Utils.cs:line 364
    [2018.05.14-07.38.42:818][507]UATHelper: Packaging (UWP (x64-64bit)): WARNING: Failed to copy C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll to C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll, deleting, waiting 10s and retrying.
    [2018.05.14-07.38.52:813][537]UATHelper: Packaging (UWP (x64-64bit)): WARNING: SafeCopyFile Exception was Exception in mscorlib: Could not find a part of the path 'C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll'.
    [2018.05.14-07.38.52:813][537]UATHelper: Packaging (UWP (x64-64bit)): Stacktrace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    [2018.05.14-07.38.52:814][537]UATHelper: Packaging (UWP (x64-64bit)): at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
    [2018.05.14-07.38.52:814][537]UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.InternalUtils.SafeCopyFile(String SourceName, String TargetName, Boolean bQuiet, Boolean bFilterSpecialLinesFromIniFiles) in C:\UNREALENGINE\UE_UWP\Engine\Source\Programs\AutomationTool\AutomationUtils\Utils.cs:line 364
    [2018.05.14-07.38.52:815][537]UATHelper: Packaging (UWP (x64-64bit)): WARNING: Failed to copy C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll to C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll, deleting, waiting 10s and retrying.
    [2018.05.14-07.39.02:812][567]UATHelper: Packaging (UWP (x64-64bit)): WARNING: SafeCopyFile Exception was Exception in mscorlib: Could not find a part of the path 'C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll'.
    [2018.05.14-07.39.02:813][567]UATHelper: Packaging (UWP (x64-64bit)): Stacktrace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    [2018.05.14-07.39.02:814][567]UATHelper: Packaging (UWP (x64-64bit)): at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
    [2018.05.14-07.39.02:814][567]UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.InternalUtils.SafeCopyFile(String SourceName, String TargetName, Boolean bQuiet, Boolean bFilterSpecialLinesFromIniFiles) in C:\UNREALENGINE\UE_UWP\Engine\Source\Programs\AutomationTool\AutomationUtils\Utils.cs:line 364
    [2018.05.14-07.39.02:815][567]UATHelper: Packaging (UWP (x64-64bit)): WARNING: Failed to copy C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll to C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll, deleting, waiting 10s and retrying.
    [2018.05.14-07.39.12:812][597]UATHelper: Packaging (UWP (x64-64bit)): WARNING: SafeCopyFile Exception was Exception in mscorlib: Could not find a part of the path 'C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll'.
    [2018.05.14-07.39.12:813][597]UATHelper: Packaging (UWP (x64-64bit)): Stacktrace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    [2018.05.14-07.39.12:814][597]UATHelper: Packaging (UWP (x64-64bit)): at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
    [2018.05.14-07.39.12:814][597]UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.InternalUtils.SafeCopyFile(String SourceName, String TargetName, Boolean bQuiet, Boolean bFilterSpecialLinesFromIniFiles) in C:\UNREALENGINE\UE_UWP\Engine\Source\Programs\AutomationTool\AutomationUtils\Utils.cs:line 364
    [2018.05.14-07.39.12:815][597]UATHelper: Packaging (UWP (x64-64bit)): WARNING: Failed to copy C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll to C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll, deleting, waiting 10s and retrying.
    [2018.05.14-07.39.22:815][627]UATHelper: Packaging (UWP (x64-64bit)): WARNING: SafeCopyFile Exception was Exception in mscorlib: Could not find a part of the path 'C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll'.
    [2018.05.14-07.39.22:815][627]UATHelper: Packaging (UWP (x64-64bit)): Stacktrace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    [2018.05.14-07.39.22:816][627]UATHelper: Packaging (UWP (x64-64bit)): at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
    [2018.05.14-07.39.22:817][627]UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.InternalUtils.SafeCopyFile(String SourceName, String TargetName, Boolean bQuiet, Boolean bFilterSpecialLinesFromIniFiles) in C:\UNREALENGINE\UE_UWP\Engine\Source\Programs\AutomationTool\AutomationUtils\Utils.cs:line 364
    [2018.05.14-07.39.22:818][627]UATHelper: Packaging (UWP (x64-64bit)): WARNING: Failed to copy C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll to C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll
    [2018.05.14-07.39.22:818][627]UATHelper: Packaging (UWP (x64-64bit)): ERROR: Failed to copy C:\UNREALENGINE\UE_UWP\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll to C:\UNREALENGINE\CatchTheThief\Saved\StagedBuilds\UWP64\Engine\Binaries\ThirdParty\PhysX\UWP64\VS2015\APEX_DestructiblePROFILE_x64.dll
    [2018.05.14-07.39.22:820][627]UATHelper: Packaging (UWP (x64-64bit)): (see C:\UNREALENGINE\UE_UWP\Engine\Programs\AutomationTool\Saved\Logs\UAT_Log.txt for full exception trace)
    [2018.05.14-07.39.22:820][627]UATHelper: Packaging (UWP (x64-64bit)): AutomationTool exiting with ExitCode=1 (Error_Unknown)
    [2018.05.14-07.39.23:161][628]UATHelper: Packaging (UWP (x64-64bit)): BUILD FAILED
    [2018.05.14-07.39.23:161][628]PackagingResults: Error: Unknown Error
    Last edited by Star Game Studio; 05-14-2018, 06:14 AM.

    Leave a comment:

Working...
X