Announcement

Collapse
No announcement yet.

Unreal Engine 4 is available for Win10 UWP app dev now

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by jsyarrow View Post
    Evenios - the original error you posted looks rather like UE can't locate the Windows 10 SDK. The build system is not finding Windows.winmd, which typically is in [Program files(x86)]\Windows Kits\10\UnionMetadata (or somewhere like that). But I wonder whether the 16299 SDK has moved it exclusively to a versioned folder? Which could be a problem if that's the only SDK you have installed.

    On Xbox One you might want to make sure that your project is being categorized as a game on the Xbox. You can highlight your app in Dev Home, press the View button, and then select View details. If the App type says 'App', then you have limited access to system resources. Changing that to 'Game' will allow you to use more of the hardware. And if you end up submitting to the Windows Store, make sure your submission is marked as a game to get the same resources in a retail scenario.

    Note that to take full advantage of the GPU on an Xbox One UWP title flagged as a 'game' you must use D3D12. But the current code in the fork runs into problems when using the D3D12RHI on Xbox. I hope we'll have a fix for that in the future.


    Jerry.Richards - no plans to release the project source. It's an Xbox One XDK project which creates some restrictions and also makes it less useful to the internet at large. XDK developers in particular may see (or have already seen) selected elements of the work appear in some of our developer outreach materials.
    Looks like Windows 10 SDK has moved to an exclusive versioned folder. I had to install 14393 to get it working. Is that the correct approach? Or should the newer versions be moved up to UnionMetadata?

    Comment


      Originally posted by fkrstevski View Post

      Looks like Windows 10 SDK has moved to an exclusive versioned folder. I had to install 14393 to get it working. Is that the correct approach? Or should the newer versions be moved up to UnionMetadata?
      Turns out that we were missing a trailing .0 when looking for the file in the versioned folder. Should be fixed in latest; with any luck that should eliminate the need to install 14393.

      A few other changes related to diagnosing SDK and compiler related issues just went in too. I hope these will make getting started a bit easier. Should also 'fix' the problem with D3D12 and 14393 (I just took the easy way out and only allow D3D12 when your Windows SDK has the headers required by the current RHI).

      Comment


        I followed all steps to build the engine from source, but now I noticed that in the solution explorer I am missing the Game folder that should be Under Engine and Programs in Visual Studios 2017. Did I do something incorrect.

        Comment


          So I have redone the build from engine a 3rd time Hoping to see what I did wrong , but still same issue. I have a project that was already made that I converted like it asked me. I Hit f5 and the editor launches. This is all good so far i believe. The problem comes because my game does not show up in the solution explorer like documents say it should anyone have idea whats going on. Also sorry if this has been re-posted I have tried writing this a view times but it never shows up.

          Comment


            Is this board still going?

            Comment


              I'm getting a different error:

              Comment


                Also, can you tell me why Solution Explorer shows 2015 when I don't have 2015 installed?

                The Generate Solution Files does the same thing for the UE solution unless I use the command line along with the -2017 switch, at least that is what I think it is. Visual Studio shows normally, at least from my perspective, when viewing UE4, there is no added qualifier such as that shown in the attached image. At a minimum it is annoying but does leave me concerned, especially when I can't load my project with the UE4 Editor (UWP build), and I don't have it installed.

                Comment


                  Apex was moved to its own Plugin. Not having my UE4 project file setup correctly caused me a couple of problems. If you're using Apex too and upgrading to (I think) 4.17 or above, I would add the Apex plugin before open the project:

                  Code:
                    {
                     "Name": "ApexDestruction",
                     "Enabled": true
                    }

                  Comment


                    Just my luck. A release UWP64 build exits without any error. Using the debugger trying to track down what is occurring, it appeared that Apex_DestructibleCHECKED_x64.dll is missing.

                    Click image for larger version

Name:	FailedToLoadApexDestructible.jpg
Views:	1
Size:	188.8 KB
ID:	1404994





                    Comment


                      I've already reported this issue to the GitHub Repository but I wanted to list here too in case someone else has a solution:

                      Code:
                      XBoxOne Critical Error
                      
                      [2018.01.02-20.21.28:355][420]LogUWP: Error: === Critical error: ===
                      [2018.01.02-20.21.28:355][420]LogUWP: Error:
                      [2018.01.02-20.21.28:355][420]LogUWP: Error: Fatal error: [File:E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line: 183]
                      [2018.01.02-20.21.28:355][420]LogUWP: Error: Ran out of memory allocating 65536 bytes with alignment 0
                      [2018.01.02-20.21.28:355][420]LogUWP: Error:
                      [2018.01.02-20.21.28:355][420]LogUWP: Error:
                      [2018.01.02-20.21.28:355][420]LogUWP: Error:
                      Is there anything I can do to get around this error?
                      My UEUWP build works correctly, without error, on my PC. However, it crashes on the XBoxOne.

                      Comment


                        i got this crash when open the motion control map any idea whats going on?

                        Comment


                          Originally posted by phearbot View Post
                          I'm trying to visit the repo linked in this thread (https://github.com/MICROSOFT-XBOX-AT...OFT_UWP_UNREAL) and I'm getting a 404. It looks like people have visited in the past couple of days. Is it just me?
                          If you see a 404 page, you need to complete the enrollment process:
                          1. Create a GitHub account.
                          2. Sign up for the Epic program
                          3. Follow the instructions to associate your Epic Program account with your GitHub account.
                          4. Join the Epic GitHub Org (from the email invitation you receive after Step 3)
                          5. Done! You should be able to access the Microsoft UWP Unreal fork on GitHub and the Readme.MD with more information.

                          Comment


                            i have try to packaging to both uwp x86 and x64 and got this


                            UATHelper: Packaging (UWP (x64-64bit)): Running AutomationTool...
                            UATHelper: Packaging (UWP (x64-64bit)): Automation.ParseCommandLine: Parsing command line: -ScriptsForProject="C:/Users/INTEL/Documents/Unreal Projects/MyProject2/MyProject2.uproject" BuildCookRun -nocompileeditor -nop4 -project="C:/Users/INTEL/Documents/Unreal Projects/MyProject2/MyProject2.uproject" -cook -stage -archive -archivedirectory="D:/Unreal Projec
                            ts/Packageproj" -package -clientconfig=Development -ue4exe=UE4Editor-Cmd.exe -pak -prereqs -nodebuginfo -targetplatform=UWP64 -build -CrashReporter -utf8output -compile
                            UATHelper: Packaging (UWP (x64-64bit)): ScriptCompiler.FindAndCompileScriptModules: Compiling scripts.
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: DotNETUtilities -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\DotNETUtilities.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UnrealBuildTool -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\UnrealBuildTool.exe
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: AutomationUtils.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationUtils.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: AllDesktop.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\AllDesktop\AllDesktop.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: Localization.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\Localization.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: OneSkyLocalization.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\OneSkyLocalization.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: AutomationScripts.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\AutomationScripts.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: Android.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\Android\Android.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: BuildGraph.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\BuildGraph.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: HTML5.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\HTML5\HTML5.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: MobileDeviceInterface -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\IOS\MobileDeviceInterface.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: IOS.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\IOS\IOS.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: Linux.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\Linux\Linux.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: Mac.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\Mac\Mac.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: TVOS.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\TVOS\TVOS.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\bin\Microsoft.Common.CurrentVersion.targets(2041,5): warning MSB3245: Could not resolve this reference. Could not locate the assembly "WindowsDevicePortalWrapper". Check to make sure the assembly exists on disk. If this reference is req
                            uired by your code, you may get compilation errors. [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\bin\Microsoft.Common.CurrentVersion.targets(2041,5): warning MSB3245: Could not resolve this reference. Could not locate the assembly "Windows". Check to make sure the assembly exists on disk. If this reference is required by your code,
                            you may get compilation errors. [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UWPPlatform.Automation.cs(890,50): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UWPPlatform.Automation.cs(890,107): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UWPPlatform.Automation.cs(902,50): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UWPPlatform.Automation.cs(902,107): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UWPPlatform.Automation.cs(214,63): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UWPPlatform.Automation.cs(214,120): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UWPPlatform.Automation.cs(214,190): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UWPPlatform.Automation.cs(245,65): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UWPPlatform.Automation.cs(245,122): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UWPPlatform.Automation.cs(245,192): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UWPPlatform.Automation.cs(193,50): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: UWPPlatform.Automation.cs(186,13): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: Win.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\Win.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MSBuild: XLocLocalization.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\XLocLocalization.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): CommandUtils.Run: Run: Took 3,0184739s to run MSBuild.exe, ExitCode=1
                            UATHelper: Packaging (UWP (x64-64bit)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Failed to build "D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\Scripts\UAT.proj":
                            UATHelper: Packaging (UWP (x64-64bit)): DotNETUtilities -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\DotNETUtilities.dll
                            UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\UnrealBuildTool.exe
                            UATHelper: Packaging (UWP (x64-64bit)): AutomationUtils.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationUtils.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): AllDesktop.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\AllDesktop\AllDesktop.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): Localization.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\Localization.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): OneSkyLocalization.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\OneSkyLocalization.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): AutomationScripts.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\AutomationScripts.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): Android.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\Android\Android.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): BuildGraph.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\BuildGraph.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): HTML5.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\HTML5\HTML5.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): MobileDeviceInterface -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\IOS\MobileDeviceInterface.dll
                            UATHelper: Packaging (UWP (x64-64bit)): IOS.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\IOS\IOS.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): Linux.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\Linux\Linux.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): Mac.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\Mac\Mac.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): TVOS.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\TVOS\TVOS.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\bin\Microsoft.Common.CurrentVersion.targets(2041,5): warning MSB3245: Could not resolve this reference. Could not locate the assembly "WindowsDevicePortalWrapper". Check to make sure the assembly exists on disk. If this reference is required by
                            your code, you may get compilation errors. [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\bin\Microsoft.Common.CurrentVersion.targets(2041,5): warning MSB3245: Could not resolve this reference. Could not locate the assembly "Windows". Check to make sure the assembly exists on disk. If this reference is required by your code, you may
                            get compilation errors. [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): UWPPlatform.Automation.cs(890,50): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): UWPPlatform.Automation.cs(890,107): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): UWPPlatform.Automation.cs(902,50): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): UWPPlatform.Automation.cs(902,107): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): UWPPlatform.Automation.cs(214,63): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): UWPPlatform.Automation.cs(214,120): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): UWPPlatform.Automation.cs(214,190): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): UWPPlatform.Automation.cs(245,65): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): UWPPlatform.Automation.cs(245,122): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): UWPPlatform.Automation.cs(245,192): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): UWPPlatform.Automation.cs(193,50): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): UWPPlatform.Automation.cs(186,13): error CS0234: The type or namespace name 'Tools' does not exist in the namespace 'Microsoft' (are you missing an assembly reference?) [D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\UWP\UWP.Automation.csproj]
                            UATHelper: Packaging (UWP (x64-64bit)): Win.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\Win.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): XLocLocalization.Automation -> D:\MicrosoftUWPUnreal\New folder\Engine\Binaries\DotNET\AutomationScripts\XLocLocalization.Automation.dll
                            UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.ScriptCompiler.FindAndCompileScriptModules(String ScriptsForProjectFileName, List`1 AdditionalScriptsFolders) in D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\AutomationUtils\ScriptCompiler.cs:line 178
                            UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.ScriptCompiler.FindAndCompileAllScripts(String ScriptsForProjectFileName, List`1 AdditionalScriptsFolders) in D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\AutomationUtils\ScriptCompiler.cs:line 80
                            UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.Automation.Process(String[] Arguments) in D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\AutomationUtils\Automation.cs:line 505
                            UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.Program.MainProc(Object Param) in D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\Program.cs:line 133
                            UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param) in D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\AutomationUtils\Utils.cs:line 708
                            UATHelper: Packaging (UWP (x64-64bit)): at AutomationTool.Program.Main() in D:\MicrosoftUWPUnreal\New folder\Engine\Source\Programs\AutomationTool\Program.cs:line 57
                            UATHelper: Packaging (UWP (x64-64bit)): Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
                            UATHelper: Packaging (UWP (x64-64bit)): BUILD FAILED
                            PackagingResults:Error: Error Unknown Error




                            any idea what happen?

                            Comment


                              and also i got his when trying to run generateprojectfiles.bat


                              D:\MicrosoftUWPUnreal\tes\New folder>GenerateProjectFiles.bat -2017
                              Setting up Unreal Engine 4 project files...
                              C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\bin\
                              Microsoft.Common.CurrentVersion.targets(2041,5): warning MSB3245: Could not res
                              olve this reference. Could not locate the assembly "Windows". Check to make sur
                              e the assembly exists on disk. If this reference is required by your code, you
                              may get compilation errors. [D:\MicrosoftUWPUnreal\tes\New folder\Engine\Source
                              \Programs\UnrealBuildTool\UnrealBuildTool.csproj]
                              UWP\WinMDRegistrationInfo.cs(4,7): error CS0246: The type or namespace name 'Wi
                              ndows' could not be found (are you missing a using directive or an assembly ref
                              erence?) [D:\MicrosoftUWPUnreal\tes\New folder\Engine\Source\Programs\UnrealBui
                              ldTool\UnrealBuildTool.csproj]

                              GenerateProjectFiles ERROR: UnrealBuildTool failed to compile.

                              Press any key to continue . . .

                              Comment


                                Are there any special optimizations/settings for the xbox one?

                                I tried to compile the third person template several times and run it on my xbox one, but i get graphical issues every time..

                                If i use the standard deferred renderer, i will get strange looking shadows (especially on walls). I tried different builds with different lighting settings like prebuild stationary lights, movable lights, etc.
                                But the shadows always look strange. (the standard mannequin material also looks slightly different)

                                If i use the forward renderer, the game wont start on my xbox one..

                                All the different builds run perfectly on my desktop pc. No graphic issues.


                                Im using the current 4.18.2 version build from source. Packaging UWP x64.
                                No build errors in output log at all. Only warnings about apple and android.
                                Uwp App type is set to game.
                                Last edited by OmniMachina; 01-07-2018, 03:13 AM.

                                Comment

                                Working...
                                X