Announcement

Collapse
No announcement yet.

Unreal Engine 4 is available for Win10 UWP app dev now

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    [MENTION=494622]jsyarrow[/MENTION],

    The Trouble Shooting Guide states that "the application is either disabled or incorrectly configured".

    1. It states try deleting the PFX file.
    2. Double check that the AppXManifest is set to the same application identity as Dev Center.

    We're not using PFX, correct? So one is out.
    The manifest Identity has the correct version, the Publisher="CN=99999RvBGames", Name="99999RvBGames.LongshotHero"

    The Properties has
    <DisplayName>ms-resource : ProjectName</DisplayName>
    <PublisherDisplayName>ms-resource : CompanyName</PublisherDisplayName>
    <Description>ms-resource : Description</Description>


    What I don't see is my SCID, nor the TitleId.

    Should these be present?
    Did I miss a setting?

    [EDIT]
    I realize now that the Company Distinguished Name is from the Dev Center portal.
    Last edited by Jerry.Richards; 06-13-2017, 05:52 PM.

    Leave a comment:


  • replied
    [MENTION=494622]jsyarrow[/MENTION],

    It looks like it is working better. . .but now I'm getting error: 0x80860003

    Unfortunately pressing the error code directs me to a page that reports: Sorry! No Support articles were found for "0x80860003".

    Additionally, Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\ThirdParty\XSAPI\Microsoft.Xbox.Live.SDK.WinRT.UWP.2016.12.20170107.01\build\native\include\xsapi\errors.h doesn't have it either.

    Now I'm looking at the Trouble Shooting Guide to see if it can help: https://developer.microsoft.com/en-u...ooting-sign-in


    I noticed that in the Dev Center Portal Xbox Live Settings dialog, it listed my game name differently than the Project Name that is contained in the UE4 Project - Description page. Should these two match? Most likely yes, and therefore changed the portal name to match the UE4 name. Is this the right thing to do?

    Leave a comment:


  • replied
    No I don't think this will work if you mean like to directly copy and paste the GlobalShaderCache to that location it wont work I even tried this but the UWP just removes it when it gets launched.

    The GlobalShaderCache exists but it gets stored in another location and not on the one that its looking for, no clue whats happening here.

    Leave a comment:


  • replied
    After looking over my Project Settings (again), I noticed that the Company Distinguished Name was set to possibly a localized version. Additionally, after wiping the project clean, I inadvertently used RvBGames instead of the Store version, which has a numeric value prepended to it: <99999>RvBGames.

    I reverted back to the previous version of the XSAPI (20170107), and now I'm repacking again using UWP64. Hopefully this will work.

    Can the XSAPI calls work under the Debug build? They don't work within the Editor.

    Leave a comment:


  • replied
    [MENTION=494622]jsyarrow[/MENTION] - can you confirm the following on the Project Description page:

    - Project ID: stays (GUID) as provided by UE4?
    - Project Name: as displayed on Dev Center Portal
    - Company Name: <yourName>
    - Company Distinguished Name: CN=<yourName>

    There was a good amount of discussion regarding the above but I can't remember right off the top of my head. So I'll need to go back through my notes, and this thread.

    Can you confirm the UWP Settings:

    - Service Config Id: as provided by the Dev Center portal
    - Title Id: the decimal Title Id converted to hex, leading zeros unnecessary
    - Is Creators Program Title: checked
    - Logo's set

    Leave a comment:


  • replied
    Btw, it appears that the Title ID is the last twelve hex characters of the SCID.

    Leave a comment:


  • replied
    Yes, I've done it numerous times. I've checked and rechecked the five steps, and after pressing Test the portal reports success:

    Click image for larger version

Name:	PublishConfig.jpg
Views:	1
Size:	73.9 KB
ID:	1129475


    Also, I cannot package with the latest XSAPI SDK. Should I revert back then?

    If so, can I just reset the version, run the script, and "Build" the engine/editor?

    Leave a comment:


  • replied
    [MENTION=29977]ErnestoEFL[/MENTION] - elaborating on my cook comments: if you ran a cook for UWP it should have generated the cooked content in a folder named something like Saved/Cooked/UWP64 under your project's (not the Engine) folder. If you were running a regular Windows desktop build in a Development configuration it would be able to read directly from that path, but UWP apps have restrictions on the folders they can access without explicit user permission. So you need to move the content into a location that the UWP app can access - which means somewhere inside the application package. When running from Visual Studio a virtual application package is laid out rooted in the folder Binaries/UWP64/AppX. For a C++ project this is relative to your project path; for a blueprint project this is relative to the engine folder. So if you copy from the cooked directory to that location then your content will be accessible. Does that help?
    [MENTION=5350]Jerry.Richards[/MENTION] - I'm running low on ideas. Did you republish your configuration just in case (kind of the equivalent of turning-it-off-then-on-again, but you never know)?
    [MENTION=801248]Wxzuir[/MENTION] - you should be able to stick with VS2015, but you might need to install the 14393 SDK. Looks like the D3D12 RHI has some dependencies on newer headers, and for UWP we're pulling those headers from the Windows SDK (rather than the ThirdParty folder - makes it easier to maintain WACK compliance).

    Leave a comment:


  • replied
    [MENTION=494622]jsyarrow[/MENTION]

    I installed Windows10 SDK 10586....
    (I can see this SDK on the control panel and this is the only SDK I can see)
    My Visual Studio version is 2015 Update 1
    My commit is 713f1c0

    But I met the same problem as [MENTION=4855]Pierdek[/MENTION](#303)
    Code:
    2>------ Build started: Project: UE4, Configuration: Development_Editor x64 ------
    2>  Performing 7 actions (4 in parallel)
    2>  Module.D3D12RHI.cpp
    2>  OculusRiftRenderD3D12.cpp
    2>g:\MICROSOFT_UWP_UNREAL-release_uwp\Engine\Source\ThirdParty\Windows\DX12\include\d3dx12.h(1151): error C2504: 'D3D12_DESCRIPTOR_RANGE1': base class undefined
    2>g:\MICROSOFT_UWP_UNREAL-release_uwp\Engine\Source\ThirdParty\Windows\DX12\include\d3dx12.h(1153): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
    2>g:\MICROSOFT_UWP_UNREAL-release_uwp\Engine\Source\ThirdParty\Windows\DX12\include\d3dx12.h(1153): error C2143: syntax error: missing ',' before '&'
    2>g:\MICROSOFT_UWP_UNREAL-release_uwp\Engine\Source\ThirdParty\Windows\DX12\include\d3dx12.h(1156): error C2061: syntax error: identifier 'D3D12_DESCRIPTOR_RANGE_FLAGS'
    What should I do to build it?
    And if I get a new PC with VS2017 and the newest SDK(15063),would I be able to build it?

    Leave a comment:


  • replied
    Unfortunately I'm getting the same errors as above. The steps I took are as follows:

    1. I deleted (again) my UEUWP source.
    2. Downloaded the source from GitHub
    3. Changed the xsapiVersionUWP in GetXboxLiveSDK script
    4. Executed GetXBoxLiveSDK
    5. Setup.bat
    6. GenerateProjectFiles.bat
    7. Built in Visual Studio

    8. Deleted all build data from game folder
    9. Opened game project using UEUWP
    10. Set Project Settings - Description, and UWP
    11. Packaged project for UWP64

    Above errors encountered again.

    Leave a comment:


  • replied
    Sorry, misunderstood. Also yes, before the build . OnlineSubsystemLive has compile-time dependencies on the SDK content (via its WinMD). Dependencies that look very like the things your build output is complaining about .

    Leave a comment:


  • replied
    Yes, before the build. Correct?

    Because it wasn't done in that order.

    Leave a comment:


  • replied
    Originally posted by Jerry.Richards View Post
    Does GetXboxLiveSDK.ps1 need to be performed before the build?
    Yes, it needs to be run manually at the moment.

    Leave a comment:


  • replied
    Does GetXboxLiveSDK.ps1 need to be performed before the build?

    Leave a comment:


  • replied
    Looking back through the build log, I do see some Xbox related errors:

    Code:
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(28): error C2039: 'Xbox': is not a member of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: C:\Program Files (x86)\Windows Kits\10\Include\10.0.15063.0\winrt\wrl\event.h(1195): note: see declaration of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(28): error C2039: 'Services': is not a member of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: C:\Program Files (x86)\Windows Kits\10\Include\10.0.15063.0\winrt\wrl\event.h(1195): note: see declaration of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(28): error C2039: 'System': is not a member of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: C:\Program Files (x86)\Windows Kits\10\Include\10.0.15063.0\winrt\wrl\event.h(1195): note: see declaration of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(28): error C3083: 'Xbox': the symbol to the left of a '::' must be a type
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(28): error C3083: 'Services': the symbol to the left of a '::' must be a type
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(28): error C3083: 'System': the symbol to the left of a '::' must be a type
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(28): error C2039: 'GetTokenAndSignatureResult': is not a member of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: C:\Program Files (x86)\Windows Kits\10\Include\10.0.15063.0\winrt\wrl\event.h(1195): note: see declaration of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(28): error C2061: syntax error: identifier 'GetTokenAndSignatureResult'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(172): error C2039: 'Xbox': is not a member of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: C:\Program Files (x86)\Windows Kits\10\Include\10.0.15063.0\winrt\wrl\event.h(1195): note: see declaration of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(172): error C2039: 'Services': is not a member of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: C:\Program Files (x86)\Windows Kits\10\Include\10.0.15063.0\winrt\wrl\event.h(1195): note: see declaration of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(172): error C3083: 'Xbox': the symbol to the left of a '::' must be a type
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(172): error C3083: 'Services': the symbol to the left of a '::' must be a type
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(172): error C2039: 'XboxLiveContext': is not a member of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: C:\Program Files (x86)\Windows Kits\10\Include\10.0.15063.0\winrt\wrl\event.h(1195): note: see declaration of 'Microsoft'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(172): error C2143: syntax error: missing ';' before '^'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(172): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(172): error C2238: unexpected token(s) preceding ';'
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Plugins\Online\XboxOne\OnlineSubsystemLive\Source\Public\OnlineSubsystemLive.h(173): error C2039: 'Xbox': is not a member of 'Microsoft'

    There were more of them.

    Leave a comment:

Working...
X