Announcement

Collapse
No announcement yet.

Unreal Engine 4 is available for Win10 UWP app dev now

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Otacon
    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: Module.Engine.14_of_35.cpp.obj : fatal error LNK1143: invalid or corrupt file: no symbol for COMDAT section 0x6
    That's a new one to me. But it looks like it might be a transient problem. Have you tried deleting the obj file above (so it will be regenerated) and building again?

    Comment


      Hi,

      I want to test UWP for XBOXONE but I experience various problems.
      This test is to see if it is possible to develop some games on UWP with UE with a Cross-Buy support for XboxOne.

      -> But I am unable to make a simple 3D scene running on XB1.
      The game perfectly run to Desktop with UE launcher button.

      -> I cannot add the xboxone console (its a developer xb1) as device in the UE device manager for UWP.

      -> So I decided to make a package: it builds and deploys without problem but the game crash just after launch screen on XB1.

      -> Then I expected that it may a sign/certificate problem. So I regenerated a new one by command line but now I cannot package anymore...

      [code]
      MakeAppx : error: Error info: error C00CE169: App manifest validation error: The app manifest must be valid as per schema: Line 3, Column 55, Reason: 'MyCompany' '(CN|L|O|OU|E|C|S|STREET|T|G|I|SN|DC|SERIALNUMBER|Description|PostalCode|POBox|Phone|X21Address|dnQualifier|(OID\.(0|[1-9][0-9]*)(\.(0|[1-9][0-9]*))+))=(([^,+="<>#;])+|".*")(, ((CN|L|O|OU|E|C|S|STREET|T|G|I|SN|DC|SERIALNUMBER|Description|PostalCode|POBox|Phone|X21Address|dnQualifier|(OID\.(0|[1-9][0-9]*)(\.(0|[1-9][0-9]*))+))=(([^,+="<>#;])+|".*")))*' 'pattern'

      'MyCompany' 'Publisher'
      [code]

      Something is missing in the app manifest ... but it is generated by UE, isn't it?

      Any help very apreciated

      Comment


        Okay I managed to fix signing problem: simply forget to add "CN=" before Company Name in project description tab

        But packaged app always crash ... Cooking for the package seems done correctly or may i miss some other settings?

        Comment


          I think many of us here are hoping for Hololens.

          Comment


            Originally posted by Christophe.Paris View Post
            But packaged app always crash ... Cooking for the package seems done correctly or may i miss some other settings?
            It probably means that your app cannot access the cooked assets. The easiest way to fix that is to set up the cook-on-the-fly asset server correctly - see https://forums.unrealengine.com/show...268#post608268 for details on that.

            I believe for standalone distributions you need to copy the cooked assets in manually, but I'm not certain.

            Comment


              Build Successfully

              Hi Forum

              Ill build successfull a UWP App for Win10 x64 and a App for Xbox One(S)

              interested ?

              So i can make a Video from it

              bb

              Comment


                C'mon man! 
                @A_Sobieraj | www.HypnoticAnts.com | Artist/Developer/CoFounder

                Comment


                  I would like to learn more about building for XBox One Also, does UWP build works for both ARM and Intel?

                  Comment


                    I'm finding that Unreal Editor's Launch button never works for UWP builds - when it tries to launch the app, it gives an error that UE4Frontend doesn't support the "UWP" platform. I get this whether I build with pre-cooked assets or try to use the cook-on-the-fly support.

                    Is the Launch button working for anybody else?

                    Comment


                      I know this Thread is quite old and interest may have gone.
                      Anyway I have built Unreal Engine 4.14.3 from a clone. Using Visual Studio 2015 update 3 VC++ and the GitHub extension.

                      This clone was then used to build the clone of MICROSOFT_UWP_UNREAL as Win64.

                      The MICROSOFT_UWP_UNREAL version attempted to build UWP64 project this failed its due to an assertion about platform types saying UWP is not a valid platform.

                      The failure is in %USERNAME%\Source\Repos\MICROSOFT_UWP_UNREAL\Engine\Source\Developer\TargetPlatform\Public\Common\TargetPlatformBase.h
                      Click image for larger version

Name:	TargetPlatformBasePatch.png
Views:	1
Size:	23.0 KB
ID:	1122113

                      Basically line 246 is commented out.

                      I don't know enough about the code to apply #IF symbol #ENDIF conditional compilation

                      This however means the UWP64 package could be successfully made and can be installed with Windows 10 Anniversary/Insider build 14393
                      Click image for larger version

Name:	Install.png
Views:	1
Size:	41.2 KB
ID:	1122114

                      Unfortunately when installed the program starts with a big white box and stays there!
                      which is not the way the Win64 works.

                      Comment


                        The strange Blue box with a big white box inside the Graphics driver failure over the Remote Desktop connection the original controller was configured for a NVidia GT750 graphics the remote machine used an AMD9700 laptop driver, total incompatibility. When run using the NVidia Windows 10 UWP version it works fine.
                        Last edited by Jimbohalo10; 01-27-2017, 06:52 PM. Reason: add status

                        Comment


                          UWP multiplayer with blueprints

                          Hi,

                          Is it possible to make a UWP multiplayer game with blueprints?

                          Thanks in advance,

                          Comment


                            Originally posted by gfoot View Post
                            I'm finding that Unreal Editor's Launch button never works for UWP builds - when it tries to launch the app, it gives an error that UE4Frontend doesn't support the "UWP" platform. I get this whether I build with pre-cooked assets or try to use the cook-on-the-fly support.

                            Is the Launch button working for anybody else?
                            Lunch button does not work for me either but the game is deployed and I can run it from Start menu in Windows 10.

                            Comment


                              Hi people, I'm sorry for the late answer, but my PC had some problems. Furthermore I had again the Unreal engine editor and the games new compiling. Here is a small snippet. Demo I had installed before ever the infiltrator so that it runs faster. That would be it for now. Statement of course in the near time



                              btw: sorry for the bad english :P

                              Comment


                                There is problem when trying to check this type of Windows 10 app into Windows Store,
                                using the https://msdn.microsoft.com/en-us/win...aging-uwp-apps

                                The app built with the Xbox will ONLY be supported from the MICROSOFT_UWP_UNREAL in UWP64

                                The Unreal 4 UWP32 MICROSOFT_UWP_UNREAL needed for Holographic and HoloLens cannot be entered to Windows Store.

                                https://msdn.microsoft.com/en-us/win...d-app-packages explains the problems
                                The offline versions will install but will NOT meet the packaging requirements for the Store

                                Comment

                                Working...
                                X