Announcement

Collapse
No announcement yet.

Unreal Engine 4 is available for Win10 UWP app dev now

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by DejanSeguljev View Post
    I'm trying to build latest uwp branch and there is an error:

    EXEC : error : System.ArgumentException: An item with the same key has already been added.
    9> at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
    9> at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
    9> at UnrealBuildTool.UEBuildTarget.Build(BuildConfiguration BuildConfiguration, CPPHeaders Headers, List`1 OutputItems, List`1 UObjectModules, ActionGraph ActionGraph) in C:\Data\MICROSOFT_UWP_UNREAL\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildTarget.cs:line 2403
    9> at UnrealBuildTool.UnrealBuildTool.RunUBT(BuildConfiguration BuildConfiguration, String[] Arguments, FileReference ProjectFile) in C:\Data\MICROSOFT_UWP_UNREAL\Engine\Source\Programs\UnrealBuildTool\System\UnrealBuildTool.cs:line 1396
    9>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(41,5): error MSB3075: The command "..\..\Build\BatchFiles\Build.bat UE4Editor Win64 Development -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command.
    I think this was fixed in 4.17.1 hotfix, but that hasn't been merged over to UE4_UWP

    EDIT: I actually have no idea about the error, it looks like it might be this:

    https://answers.unrealengine.com/que...le-in-417.html

    But I tracked down the plugin that its complaining about, which made the build continue, but there were still a bunch of errors after the fact. Inside "Engine\Plugins\Media\MfMedia\MfMedia.uplugin", MfMediaFactory is listed twice.
    Last edited by fkrstevski; 09-25-2017, 11:46 PM.

    Leave a comment:


  • replied
    Originally posted by demonixis View Post
    Hi there,
    I try to compile the mixedreality branch but I'm stuck on the first step because the Setup.bat script tries to download a file with a name with more than 260 characters.
    Despite this error, I tried to run GenerateProjectFiles.bat but errors here too. The namespace Metadata doesn't exists.

    This is a screenshot of all errors
















    Is anyone was able to compile this branch? Or maybe can someone send me a link to a working build?

    Thanks!
    You need to move the UE4 UWP source to a shorter path to avoid those issues. I put mine in C:\UE4_UWP

    Leave a comment:


  • replied
    Yup I get that, but without wading through 38 pages, I wanted to know how well this UWP branch works.

    Guess I can clone it later and give it a go myself....

    Leave a comment:


  • replied
    Good news, but UE4 still doesn't support deployment to UWP out of the box.

    Leave a comment:


  • replied
    Apologies for laziness, but there are 38 pages to go through, but I have questions :

    Is the toolchain for deploying UE projects onto an XB1 via UWP reasonably straightforward/reliable now?

    Are there any remote debugging facilities?

    Leave a comment:


  • replied
    Originally posted by mid_gen View Post

    Just came here to post this! Amazing news, going to have to pick up an XB1s.
    Yep same here.

    Leave a comment:


  • replied
    Originally posted by HeadClot View Post
    Looks like microsoft is giving devs more resources for Xbox development

    https://blogs.windows.com/buildingap...JHGHpHowfVt.97
    Just came here to post this! Amazing news, going to have to pick up an XB1s.

    Leave a comment:


  • replied
    Looks like microsoft is giving devs more resources for Xbox development

    https://blogs.windows.com/buildingap...JHGHpHowfVt.97

    Leave a comment:


  • replied
    Hi there,
    I try to compile the mixedreality branch but I'm stuck on the first step because the Setup.bat script tries to download a file with a name with more than 260 characters.
    Despite this error, I tried to run GenerateProjectFiles.bat but errors here too. The namespace Metadata doesn't exists.

    This is a screenshot of all errors
















    Is anyone was able to compile this branch? Or maybe can someone send me a link to a working build?

    Thanks!

    Leave a comment:


  • replied
    I'm trying to build latest uwp branch and there is an error:

    EXEC : error : System.ArgumentException: An item with the same key has already been added.
    9> at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
    9> at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
    9> at UnrealBuildTool.UEBuildTarget.Build(BuildConfiguration BuildConfiguration, CPPHeaders Headers, List`1 OutputItems, List`1 UObjectModules, ActionGraph ActionGraph) in C:\Data\MICROSOFT_UWP_UNREAL\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildTarget.cs:line 2403
    9> at UnrealBuildTool.UnrealBuildTool.RunUBT(BuildConfiguration BuildConfiguration, String[] Arguments, FileReference ProjectFile) in C:\Data\MICROSOFT_UWP_UNREAL\Engine\Source\Programs\UnrealBuildTool\System\UnrealBuildTool.cs:line 1396
    9>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(41,5): error MSB3075: The command "..\..\Build\BatchFiles\Build.bat UE4Editor Win64 Development -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command.

    Leave a comment:


  • replied
    Hi, anyone encountered and resolved this error? Even i when copy all the required .xsd files from Windows SDK, it still fails on 'unrecognized argument'. Using Visual Studio 2017 Community (15.2).

    UATHelper: Packaging (UWP (x64-64bit)): UnrealBuildTool: ERROR: System.IO.FileNotFoundException: Could not find file 'C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Xml\Schemas\UapManifestSchema.xsd'.

    Leave a comment:


  • replied
    Hey

    Question not directly related to UWP, but since here most people MS look I have question.

    Did you guys tried to run unreal server on Windows Server Nano (preferable option) or Windows Server Core ?
    I've been trying to set it up (and then later create container based on windows nano and unreal server). But to no avail. I just couldn't get it to run or to check what dependencies I might be missing.

    Leave a comment:


  • replied
    Where are an installed game logs kept at?

    It appears that the UWP application is installed in WindowsApps; Win64 logs and crash reports are stored in AppData\Local; but I can't find the UWP game logging files.

    EDIT
    For anyone else that may be interested: Device Portal File Explorer provides fairly easy access to the files for the installed application:
    https://blogs.windows.com/buildingap...your-app-data/
    Last edited by Jerry.Richards; 08-19-2017, 11:56 AM.

    Leave a comment:


  • replied
    Thanks [MENTION=494622]jsyarrow[/MENTION], we made some modifications to EraAdapter to deal with the offline situation.

    Leave a comment:


  • replied
    [MENTION=494622]jsyarrow[/MENTION] - Thank you for those instructions. It is a much easier work flow. Do the accounts have to be added to my desktop or can I omit that step?

    Can I just set the account up and access it from the Sign-In screen?

    EDIT:
    Rather nice that I can complete the setup of a new account from the Sign-In screen. Correction. It is working now

    Click image for larger version

Name:	TestAccount.jpg
Views:	1
Size:	53.2 KB
ID:	1132500


    And I can see my Leaderboard with multiple players

    Click image for larger version

Name:	HighScores.Short.jpg
Views:	1
Size:	93.3 KB
ID:	1132501
    Attached Files
    Last edited by Jerry.Richards; 08-15-2017, 11:07 PM.

    Leave a comment:

Working...
X