Announcement

Collapse
No announcement yet.

[Plugin] Http/s REST, blueprintable JSON and Parse REST API manager at once (VaRest)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    Hi, there:
    I'm encountering a situation, and maybe someone here can help me.
    Of course I use this great plugin to response/request Http, I construct a JsonRequest as usually and send it to webserver.
    In Android Devices, it works fine both on Development and Shipping Version.
    But in iOS Devices, the web server received binary data which can't be resolved. And the header was added "Accept-Language:zh-tw" and "Accept-Encoding:gzip, deflate".
    Any Advices ?

    Comment


      #62
      Doesn't work with Unreal Engine 4.8
      Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	8.2 KB
ID:	1080193

      Comment


        #63
        @Furentes - Start a new c++ project and put the varest folder inside a plugins folder*which you will need to make* in your new project. It will ask to recompile hit yes, take the varest plugin folder after it is finished and put it in the plugin folder for your current project.

        Comment


          #64
          Howdy,
          I have fixed a version of VaRest Plugin for UE 4.8, Anyone is wellcome to download it.
          VaRest for UE4.8

          Comment


            #65
            Tip:
            When you click the link from ZenTechEntertainment click the link in the top left "Download VaRest Plugin for UE 4.8" Its near the date.
            I had trouble and was trying the link on the last post.

            Here is a Direct Link: https://drive.google.com/file/d/0B5g...A2cExaZkk/view

            The download button is at the top of the page (Down arrow with a line under it)

            This is a great Plug In Thank you.

            Comment


              #66
              I've released all new changes as 1.1-rc8 release: https://github.com/ufna/VaRest/releases/tag/1.1-rc8

              Big thanks to all guys who contributed to VaRest!

              Comment


                #67
                4.9?

                Hi,

                I was trying to use this plug-in with 4.9, on the github page it says it's compatible with 4.8-4.9, but it says it failed to load on start. Does anyone got it working with 4.9? I'm using a blueprint project, don't know if that's the problem?

                Thank you, this looks to be a really useful plugin, looking forward to try it!

                Comment


                  #68
                  Works in 4.9.
                  Last edited by mxnko; 09-05-2015, 12:33 AM.

                  Comment


                    #69
                    Originally posted by Esteves View Post
                    I was trying to use this plug-in with 4.9, on the github page it says it's compatible with 4.8-4.9, but it says it failed to load on start. Does anyone got it working with 4.9? I'm using a blueprint project, don't know if that's the problem?
                    Yes, it's because you're using a blueprint project - plugins are not fully compatible with this kind of projects (for example, you also can't package blueprint-only project if you're using plugins). Btw I can make pre-compiled version if you want.

                    Comment


                      #70
                      I've released a new version: 1.1 R 9

                      Comment


                        #71
                        EDIT 1: Ok I've just realized my problem is because I'm using a Blueprint Project? How can I convert it to a C++ project? I've tried adding an empty C++ class but I still have the same issue. How do I check if my project is a Blueprint project and how do I convert it to a C++ one?

                        EDIT 2: Alright I finally got it to work. For others' reference here's what I did:

                        I removed the plugin from my project, added an empty C++ class and let UE4 do the generate the visual studio project (it will do this automatically in 4.9). If you go to the File menu, you should see "Refresh Visual Studio Project" instead of "Generate Visual Studio Project" now. Now you have to open up Visual Studio and build the solution before trying to "launch" (in the editor) or package the game. Make sure you have the right build settings (Shipping / Debug / Development etc.) or just build for all of them. Also, if you put the plugin in your Game Engine folder instead of Project folder, you will have problems compiling it because the plugin is missing some .lib file that needs to be compiled (and that will only happen if you added it as a plugin in your project rather than your engine).

                        I didn't know that you need it to be a C++ project for this to work properly (be packageable), I think you should state that somewhere on your first post for people who have been programming exclusively in Blueprint (like me).

                        ORIGINAL POST:
                        Hey, my project can't launch/package when I enable your plugin (disabling it and then attempting to package again works). I can still run the game in the editor just fine, even with the plugin enabled and with the blueprint functions being used (and the functions work).

                        Here what I think is the relevant part of the huge output log...

                        LogPlayLevel: Project.CopyBuildToStagingDirectory: ********** STAGE COMMAND STARTED **********
                        LogPlayLevel: BuildCommand.Execute: ERROR: BUILD FAILED
                        LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception:
                        LogPlayLevel: Program.Main: ERROR: Exception in AutomationScripts.Automation: Stage Failed. Missing receipt 'FNMG-Win64-Development.target.xml'. Check that this target has been built.
                        LogPlayLevel: Stacktrace: at Project.CreateDeploymentContext(ProjectParams Params, Boolean InDedicatedServer, Boolean DoCleanStage)
                        LogPlayLevel: at Project.CopyBuildToStagingDirectory(ProjectParams Params)
                        LogPlayLevel: at BuildCookRun.DoBuildCookRun(ProjectParams Params)
                        LogPlayLevel: at BuildCommand.Execute()
                        LogPlayLevel: at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
                        LogPlayLevel: at AutomationTool.Automation.Process(String[] CommandLine)
                        LogPlayLevel: at AutomationTool.Program.MainProc(Object Param)
                        LogPlayLevel: at AutomationTool.InternalUtils.RunSingleInstance(Action`1 Main, Object Param)
                        LogPlayLevel: at AutomationTool.Program.Main()
                        LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes.
                        LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=Error_MissingExecutable
                        LogPlayLevel: Domain_ProcessExit
                        LogPlayLevel: copying UAT log files...
                        LogPlayLevel: RunUAT.bat ERROR: AutomationTool was unable to run successfully.
                        LogPlayLevel: Completed Launch On Stage: Build Task, Time: 2.756917
                        LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_15c6c_0///####STATCAT_Advanced#### old //STATGROUP_Threads//FLauncherTask///Thread_14ac4_0///####STATCAT_Advanced####
                        LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 0.000120
                        LogPlayLevel: BUILD FAILED
                        PackagingResults:Error: Error Launch failed! Missing UE4Game binary.
                        You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:
                        UE4Game <Platform> <Configuration>
                        I attempted to build the project with Visual Studio (like the error message suggested) but when I try generating Visual Studio project files, I get this error.

                        Running E:/Epic Games/Epic Games/4.9/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="E:/Projects/Unreal Engine/FNMG/FNMG.uproject" -game -rocket -progress
                        Discovering modules, targets and source code for game...
                        ERROR: Module "VaRestPlugin" linked into both E:\Epic Games\Epic Games\4.9\Engine\Plugins\VaRestPlugin\Binaries\Win64\UE4Editor-VaRestPlugin.dll and E:\Epic Games\Epic Games\4.9\Engine\Plugins\VaRestPlugin\Binaries\Win64\UE4Editor-VaRestPlugin.dll, which creates ambiguous linkage for dependents.
                        I should note that I haven't touched the C++ portion of Unreal yet (I'm not experienced with compiling it in the IDE etc.)
                        Last edited by Dois; 10-06-2015, 03:42 PM.

                        Comment


                          #72
                          Hello, I'm new to using VaParse and Parse Rest API. I have created a APP on parse.com but my problem is how do I use it in blueprints. I followed your tutorial but Its not working All I want to know how to do is how to make it so I can use parse.com Rest API to register players and to allow them to login from ingame using blueprints ONLY. I would show you what I got but my UE4 Crashed again. I really need to get that fix any ways, I can use anyone help I tried to do this my self for 3 weeks now No luck yet. Here is a list of what I am wanting to do

                          What I want to using parse.com with VaParsePlugin BLUEPRINTS ONLY

                          Make 1 blueprint that will allow my to call from it That will have the listed stuff in it blow
                          You might want to check this out https://parse.com/docs/rest/guide#quick-reference
                          Funcation for PlayerRegister https://parse.com/docs/rest/guide#users-signing-up
                          Function for PlayerLogin https://parse.com/docs/rest/guide#users-logging-in
                          Function for Custom Objects Like Integers,Strings,Floats https://parse.com/docs/rest/guide#objects
                          Fuction for Adding,Updating,Removing Custom Objects https://parse.com/docs/rest/guide/#o...eating-objects
                          Thats all I'm needing it to do if you can get me started on a example of one of them Above I will hum well Say Thank You in return

                          Comment


                            #73
                            Hi! Is there support for Parse Files? I'm current looking for a way to implement it myself but the unreal api docs ain't that friendly

                            Comment


                              #74
                              Romelio I am currently working on a API function using only Blueprints It supports Everything listied on this site https://www.parse.com/docs/rest/guide Including File uploading and downloading. I'll upload some screenshots soon I get that part implemented in the blueprint. Keep checking back here every day soon I get it done I'll upload it to here and I will make a forum page for it and YES it has describtion on how to use each Parse Path Prefix.

                              * EDITED Added image Main of my EasyParse Blueprint *
                              More Images Coming soon, EasyParse is a blueprint NO C++ Only blueprints this content makes your live easyer when using VaRest Plugin.
                              Remember this is a week old image sorry about that I will upload a new image some time next week or once I get the blueprint done.
                              You will be able to found this on market thats if it gets approved if not then I'll just make it free. I have put lot of work in to this to make and help everyone who is using VaRest Plugin live easyer.

                              new image:
                              Click image for larger version

Name:	6e0a088c4b47e411f9a248ee0db6e257.png
Views:	1
Size:	169.1 KB
ID:	1091420

                              Image Main. - OLD IMAGE
                              Click image for larger version

Name:	56f53d7b025825b117a7ffd13c50b230.png
Views:	1
Size:	364.3 KB
ID:	1091419
                              Last edited by xxmobkiller-ZacheryRussell; 10-17-2015, 10:53 PM. Reason: Added image Main of my EasyParse Blueprint

                              Comment


                                #75
                                https://www.parse.com/docs/rest/guide

                                Comment

                                Working...
                                X