Announcement

Collapse
No announcement yet.

[Plugin] Http/s REST, blueprintable JSON and Parse REST API manager at once (VaRest)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by martoof View Post
    Hi,
    Thank for 4.25 update !!! you're the best !

    "Get Response Object" seem to not work on 4.24 & 4.25?
    Can you confirm ufna ?

    I have same problem "By HevoYTB-FR on April 20, 2020 9:08 PM on marketplace"


    For the moment my only solution is to "get response content as string + construct my json object and decode json.
    I think I have the same problem. Using 4.25 from store.

    Comment


      Just tested, all works as it should. Please provide example that fails.
      Making games with Unreal Engine https://alyamkin.com

      Comment


        Hi ufna, I have what's hopefully a quick question.

        How do I loop through a Object Array that came in as a response?

        {"ship_values":[{"total_water":"0"},{"total_material":"0"},{"total_score":"0"}]}

        Basically i'm trying to have the key and value come into UE4.

        Example:

        Click image for larger version

Name:	ObjArray.PNG
Views:	152
Size:	113.5 KB
ID:	1774287

        Thanks!

        -T

        Comment


          Hi, ufna I am facing some problem about top-level arrays reading.

          I have tried to do this: https://www.notion.so/HowTo-Read-top...de0c9e65d512f5 but it still does not work.

          Error Log is: LogVaRest: Error: UVaRestJsonObject::SetRootObject(43): Trying to set invalid json object as root one. Reset now.

          Thanks you in advance for your attention.

          P.S. UE4.21

          Edited (1): I've just found actually it did not callback after run Call URL node. Maybe it cause my issue ?
          Last edited by タナポン.TEC; 06-11-2020, 02:31 AM.

          Comment


            ok so I Downloaded 4.25plus from github and compiled source. How do i re compile your plugin for source build engines? your wiki is gone. your site links to dead links etc.
            I need to recompile the plugin so i can use it with a project requiring chaos but it says this error when trying to compile it:

            editor modules can't be compiled while the engine is running.
            Matt Walton: Programmer and owner for WireLiteSoft Games.

            Comment


              With 4.25.2 I'm having issues getting my project to package. So I did a fresh pull on the repo and tried to load the the project and can't. I have make sure that the plugin is installed in the engine, but am getting this error when I try to load or build the project:

              ERROR: Expecting to find a type to be declared in a module rules named 'VaRest' in UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null. This type must derive from the 'ModuleRules' type defined by Unreal Build Tool.
              Any Ideas?

              Comment


                Copying the plugin into the project seems to have fixed the issue for now, but I am curious as to why I'm having to do that...

                Comment


                  It's a bug of UE 4.25.2 release. Please check https://forums.unrealengine.com/unre...37#post1792437
                  Making games with Unreal Engine https://alyamkin.com

                  Comment


                    Anyone have any examples on how to get a Map field from the JSON string?

                    Comment

                    Working...
                    X