Announcement

Collapse
No announcement yet.

[Plugin] Http/s REST, blueprintable JSON and Parse REST API manager at once (VaRest)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Nightasy View Post
    I noticed the Plugin has a "Set Number Array" node. I couldn't find any documentation about it. What "Type" should I use in the MySQL database for this node?
    It sets array of float numbers.

    Leave a comment:


  • replied
    Greetings,

    I noticed the Plugin has a "Set Number Array" node. I couldn't find any documentation about it. What "Type" should I use in the MySQL database for this node?


    Edit: Is this node even working correctly? If it's passing an array then it's definitely not working.
    Last edited by Nightasy; 06-11-2016, 01:45 AM.

    Leave a comment:


  • replied
    Originally posted by OSIAS View Post
    Is this plugin going to get updated to 4.12 and if so ETA maybe? Thanks
    I've sent request to Epic team for plugin update, but you can use the Github plugin version any time (it's fully compatible with UE 4.12)

    Leave a comment:


  • replied
    Is this plugin going to get updated to 4.12 and if so ETA maybe? Thanks

    Leave a comment:


  • replied
    Originally posted by mayaping View Post
    Can this plugin be used to parse xml instead of JSON.
    I hava a webservice in a server and set a url request.The return value of this request is a xml instead of JSON format.
    Currently xml is not supported, but I think I'll add it soon

    Originally posted by mfaced View Post
    I still can't figure out why I can't build my project since I installed the plugin. I tried an empty project and built it fine and then once I install the plugin via epic launcher it fails with an unknown error.
    What's in the log files?

    Originally posted by Chance View Post
    I get the same unknown error when packaging for HTML 5 with the plugin enabled. Packaging for Win64 works fine with the plugin enabled and disabling the plugin allows packaging for HTML 5.

    I am using the plugin, installed from the marketplace, with UE 4.11.2 provided by the launcher.
    I'll check it this week.

    Leave a comment:


  • replied
    I get the same unknown error when packaging for HTML 5 with the plugin enabled. Packaging for Win64 works fine with the plugin enabled and disabling the plugin allows packaging for HTML 5.

    I am using the plugin, installed from the marketplace, with UE 4.11.2 provided by the launcher.
    Last edited by Chance; 05-29-2016, 01:15 PM.

    Leave a comment:


  • replied
    I still can't figure out why I can't build my project since I installed the plugin. I tried an empty project and built it fine and then once I install the plugin via epic launcher it fails with an unknown error.

    Leave a comment:


  • replied
    Can this plugin be used to parse xml instead of JSON.
    I hava a webservice in a server and set a url request.The return value of this request is a xml instead of JSON format.
    Click image for larger version

Name:	1CIES)Q_Q1U_WQNH`[3MM3B.png
Views:	1
Size:	29.6 KB
ID:	1106602

    Leave a comment:


  • replied
    ufna,

    Great plugin, and good to see it as an engine plugin now. However, I ran into a small snag. I am working off the latest engine source code (unrealengine-master on Github). I added your plugin because it simplifies using REST calls, but when I go to compile I get the following:

    Epic
    Games/4.10/Engine/Plugins/VaRest/Source/VaRestEditorPlugin/Classes/VaRest_BreakJson.h(27)
    : Property is exposed to the editor or blueprints but has no Category
    specified.

    I made a temp fix by just adding the category property to the affected code and it compiled fine. I've noticed this problem with another plugin and fixed it the same way. I realize that I am not working with a supported engine version; but, I would imagine that if I compiled 4.11 from source with your plugin it would do the same. (currently I use 4.11.2 from the launcher install, not source, so it's not an issue as yet).

    Leave a comment:


  • replied
    Hey guys,

    Now you can get the plugin via Launcher (https://www.unrealengine.com/marketplace/varest-plugin), so there will be no binary releases on Github.

    Leave a comment:


  • replied
    It seems as though this got updated for 4.11 yesterday:
    https://github.com/ufna/VaRest/releases

    I downloaded and tried it and it still threw up an error; then I realised I was trying to use a source copy . Seems like a pre-built version hasn't been uploaded yet so I guess I'll keep checking in to see when that drops.


    Thanks for the update, ufna.

    Leave a comment:


  • replied
    Those having trouble building plugins, I've done a tutorial - it's about the UE4-OSC plugin but the first 10 minutes tells you how to (very easily) compile a plugin - no c++ required (you still need a c++ project though) - search for the osc thread.

    Leave a comment:


  • replied
    Originally posted by TheFoyer View Post
    > If you're using plugins and want to package them you must switch you project to "C++ game".

    So this is a pretty vital piece of information I was not aware of since this is the one and only plugin I've used. I couldn't get this working for a week You should mention it on the github page.
    Is there any way to use this plugin (possibly through custom compiling), without the usage of a C++ project?

    Leave a comment:


  • replied
    Originally posted by AthlonJedi View Post
    I cant get it to build on ANY version of the engine, 4.9-4.11 both source and just the regular engines will NOT build it....donno what im doing wrong
    How are you trying to build it? Where did you place VaRestPlugin folder? (into Engine? or into your project?) What are the errors? What platform are you building for? What platform are you building on? Are you using VaRest source code from GitHub or VaRest precompiled binaries?

    I've been using VaRestPlugin since 4.7 and with each minor/major revision of engine, VaRest never caused any problems..

    Leave a comment:


  • replied
    I cant get it to build on ANY version of the engine, 4.9-4.11 both source and just the regular engines will NOT build it....donno what im doing wrong

    Leave a comment:

Working...
X