Announcement

Collapse
No announcement yet.

Hi, how to get source for GitHub

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Hi, how to get source for GitHub

    Hi, I am new to unreal.
    I am downloading it because I am told that it i possible to add CPP third party plugin or modules to the engine.
    I do not see a way to get the code, or the SDK necessary to that.

    what I try to clone the reposotroy I get thsi error

    git.exe clone --progress -v "https://github.com/EpicGames/UnrealEngine" "D:\unrealSource\UnrealEngine"

    Cloning into 'D:\unrealSource\UnrealEngine'...
    remote: Repository not found.
    fatal: repository 'https://github.com/EpicGames/UnrealEngine/' not found


    git did not exit cleanly (exit code 128) (47593 ms @ 1/19/2015 6:08:25 AM)

    an when I try to the site as it is explained in the various page here or on the website I get this message
    Click image for larger version

Name:	Untitled1.png
Views:	1
Size:	199.9 KB
ID:	1143156

    can some one please tell me what I am doing wrong?
    Julio

    #2
    You have to login to github with the account you set in the unreal engine website.

    Since you're using Windows, you can use Github for Windows (https://windows.github.com/) since it's easier to use your github account (and download the code) from there.

    Comment


      #3
      I have Github on Mac, Window and Linux
      When I follow the instructions on this place https://www.unrealengine.com/ue4-on-github

      the first step take me to this page. but form there nothing else works

      Comment


        #4
        Hi Julio,

        First you need to go to http://www.unrealengine.com and sign in using the button up top. Once signed in you need to enter your GitHub user name into your account settings and then press save, this will turn on access to the repositories. You should now be able to access the files on GitHub.

        EDIT: This will only work if you have an active subscription to UE4. You can find the settings right here (user name IS case sensitive, make sure it is the exact same):

        Click image for larger version

Name:	GitHubAcct1.PNG
Views:	1
Size:	88.3 KB
ID:	1065332
        Last edited by DotCam; 01-19-2015, 12:41 PM.
        Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

        Comment


          #5
          I already have an unreal account form that link, I already download teh MSi file and test some demos.

          the problem is that I can no get the code for GitHub, I contacted Git Hub and the say the problem is that appears that JulioJerez is nor a member of Epic,
          But I register last night, and pad the deed. here is the Email from GitHub.
          GitHub <support@github.com>
          7:48 AM (2 hours ago)

          to me
          Hi NewtonDynamics,

          EpicTeamAdmin has invited you to join the Epic Games organization on GitHub. Head over to https://github.com/EpicGames to check out Epic Games's profile.

          To join Epic Games, follow this link:

          https://github.com/orgs/EpicGames/in...on?via_email=1

          Some helpful tips:

          - If you get a 404 page, make sure you're signed in as JulioJerez.
          - You can also accept the invitation by visiting the organization page directly at https://github.com/EpicGames

          If you were not expecting this invitation, you can ignore this email.

          Thanks,
          The GitHub Team

          Julio Jerez Attachments8:24 AM (1 hour ago)
          Hi, thank for the reply. when I click on any of the three links, I get the ei...

          Jamie Murai (GitHub Staff)
          8:26 AM (1 hour ago)

          to me
          Hi Julio,

          Sorry for the trouble. It looks like your JulioJerez account is not a member of the Epic Games organization. You will need to contact them directly for help.

          Cheers,
          Jamie
          I also contacted Unreal support but I am getting the same kind of respond, basically the link that takes me to a 404 error page.
          I also try the same from a different compute that is not in my house, so this is no a internet connection problem

          Comment


            #6
            Can you confirm your user name is entered in the field I circled in the above image? You will not be able to access the EpicGames GitHub until you enter your user name into that field.

            This is separate from registration, it needs to be done after setting up your account for the first time. Please double check this has been done.
            Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

            Comment


              #7
              the name I typed lat time was NewtonDynamics and that did not work. That was the name I got what I open the the GitHub Setting, but the people at GitHub
              tell me that My user name is JulioJerez so I tryoed that and it did no work either. I also tried JerezJulio, JulioJerez, my Email and nothing worked.

              I will try tonight JulioJerez maybe I was wrong the first time.
              Thank you

              Comment


                #8
                Hopefully that fixes it for you, make sure you use the same case capitalization though, it won't work if you use all lowercase letters.

                If that still doesn't work then be sure to send an email to accounts@unrealengine.com explaining your situation and providing your account info, they be able to make sure there are no other issues preventing you from getting access.

                Hope that helps!
                Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

                Comment


                  #9
                  Ha it worked, I was able to clone it

                  you can close this thread.
                  Thank you

                  Comment


                    #10
                    Hey guys this really helped they sent an invite after message 4 im sooooo happy ive been trying to get this for 3 days now thank you very much

                    Comment

                    Working...
                    X