Announcement

Collapse
No announcement yet.

GitHub dependency zips and latest-preview snapshots

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Originally posted by Ben Marsh View Post
    It scans for any files matching the pattern */Build/*.gitdeps.xml, so you could certainly add another to your fork. As a solution, it's really best suited to the situation where you're pushing binaries 1:many - it works well because it's a contained to the repository (you don't need to install any git extensions or anything like that), but it would make for pretty nasty merges if two people modify the binaries list at the same time. Something like git-media or git-annex would be better suited to that kind of thing.

    That said, if you really want to try it, you might be interested to have a look at this pull request, where bozaro submitted a standalone tool to generate those files - https://github.com/EpicGames/UnrealEngine/pull/884.
    What about GitHub's LFS extension? It's in early access at the moment but it's fully supported by the GitHub app.

    Comment


      #47
      I can't seem to find the answer anywhere. I've been afflicted with a rather frustrating problem that Nuclearfossil had as well, but he didn't detail how he solved it. The Setup.bat seems to want some file called UE4Prereqsetup_x64.exe, but I didn't get such a file when I cloned the repository. What do I do?

      Comment


        #48
        Setup.bat should download that file when it runs Engine\Binaries\DotNET\GitDependencies.exe. It would be downloaded to Engine\Extras\Redist\en-us\UE4PrereqSetup_x64.exe.

        What output do you get when you run Setup.bat? Can you check your virus scanner hasn't quarantined either of the above files?

        Comment


          #49
          Originally posted by Ben Marsh View Post
          Setup.bat should download that file when it runs Engine\Binaries\DotNET\GitDependencies.exe. It would be downloaded to Engine\Extras\Redist\en-us\UE4PrereqSetup_x64.exe.

          What output do you get when you run Setup.bat? Can you check your virus scanner hasn't quarantined either of the above files?
          I get the same, and it throws up that message as soon as the cmd window shows 'Installing prerequisites...' right at the start of the download.

          If it helps, this is my shortcut's target;

          D:\UE4_Clean\UnrealEngine-release-4.8.0\Setup.bat Setup.bat -exclude=WinRT -exclude=Linux -exclude=Linux32 -exclude=osx64 -exclude=osx32 -exclude=IOS -exclude=HTML5 -exclude=Android
          It doesn't seem to happen with the normal Setup.bat (at least not straight away).

          Screenshot:
          Click image for larger version

Name:	6544941427613bd517dab6de7a248442.png
Views:	1
Size:	17.9 KB
ID:	1080046

          Comment


            #50
            I think you have setup.bat repeated twice in that shortcut. It's treating the second one as an argument, but can't parse it, which is giving you an error (but it's scrolled off the top of the screen).

            Comment


              #51
              When I clicked on all the links above I got the same result:

              Click image for larger version

Name:	404.png
Views:	1
Size:	173.6 KB
ID:	1080920

              Anyone help me to download engine source code?

              Comment


                #52
                It sounds like you haven't associated your GitHub account with your UE account, or you're not logged in to GitHub. You can find instructions on how to set it up here.

                Comment


                  #53
                  Grabbed the latest .zip of source onto a new machine, unpacked it and ran setup.bat. Watched the "Updating dependencies" counter spend a while building up to 99%, then fail with this:

                  Checking dependencies (excluding Mac, Android, Linux)...
                  Updating dependencies: 99% (22123/22124), 3130.3/3131.0 MiB | 4.78 MiB/s...
                  Failed to download 'http://cdn.unrealengine.com/dependencies/2636785-bb59fe7a4b5f4abc9305901e79ac10da/e70061ffc85b6027a648cac0b1c8c6ef7d4e3106': Can't read from pack stream (CorruptPackFileException)

                  Initially thought maybe I had a network problem near the end since it had gotten that far. Tried again with the same result.

                  Comment


                    #54
                    Originally posted by jmp0 View Post
                    Grabbed the latest .zip of source onto a new machine, unpacked it and ran setup.bat. Watched the "Updating dependencies" counter spend a while building up to 99%, then fail with this:

                    Checking dependencies (excluding Mac, Android, Linux)...
                    Updating dependencies: 99% (22123/22124), 3130.3/3131.0 MiB | 4.78 MiB/s...
                    Failed to download 'http://cdn.unrealengine.com/dependencies/2636785-bb59fe7a4b5f4abc9305901e79ac10da/e70061ffc85b6027a648cac0b1c8c6ef7d4e3106': Can't read from pack stream (CorruptPackFileException)

                    Initially thought maybe I had a network problem near the end since it had gotten that far. Tried again with the same result.
                    Tried this again on another machine, and it works. The main difference between the two machines is Windows 10 (didn't work) and Windows 8.1 (did work). So now I'm not sure if this is a problem specific to Windows 10 or something else with that machine.

                    Comment


                      #55
                      Originally posted by jmp0 View Post
                      Tried this again on another machine, and it works. The main difference between the two machines is Windows 10 (didn't work) and Windows 8.1 (did work). So now I'm not sure if this is a problem specific to Windows 10 or something else with that machine.
                      Hi jmp0,

                      Would you be able to create a new post in the Bug Reports section of the AnswerHub for this?

                      Thanks,
                      Tim
                      Engine Support Technician

                      Comment


                        #56
                        Originally posted by Tim Lincoln View Post
                        Hi jmp0,

                        Would you be able to create a new post in the Bug Reports section of the AnswerHub for this?

                        Thanks,
                        Tim
                        Sure.

                        https://answers.unrealengine.com/que...indows-10.html

                        Comment


                          #57
                          Hello everyone.

                          I am trying to compile Unreal 4.6.1 ,but when I executed Setup.bat I found the next error:

                          E:\UnrealEngineSource>Setup.bat Checking dependencies (excluding Mac, HTML5, Android)...
                          Received 17642/17657 files (2607,2/2608,7mb; 0,01mb/s; 99%)...
                          Failed to download 'http://cdn.unrealengine.com/dependencies/2369409-8e3ef78261c144639cff509a0b6b4805/8b9dc269d72f7357a9ff4be501cd5836b33d2a3c' to 'C:\Users\Venus\AppData\Local\Temp\tmp8F7A.tmp': The magic number in GZip header is not correct. Make sure you are passing in a GZip stream. (InvalidDataException)
                          Press any key to continue . . .

                          I tried to run Setup.bat again, but I always have the same issue:

                          E:\UnrealEngineSource>Setup.bat Checking dependencies (excluding Mac, HTML5, Android)...
                          Received 0/15 files (0,1/1,6mb; 0,01mb/s; 0%)...
                          Failed to download 'http://cdn.unrealengine.com/dependencies/2369409-8e3ef78261c144639cff509a0b6b4805/8b9dc269d72f7357a9ff4be501cd5836b33d2a3c' to 'C:\Users\Venus\AppData\Local\Temp\tmpA943.tmp': The magic number in GZip header is not correct. Make sure you are passing in a GZip stream. (InvalidDataException)
                          Press any key to continue . . .

                          As you can see only lack to download less than 2 mb, but I always have the same error.

                          How I can solve it?
                          What is the problem?

                          Thanks before hand!

                          Comment


                            #58
                            Why Make Them As a Zip?Stupid!!

                            Comment


                              #59
                              Originally posted by Ben Marsh View Post
                              Of course, this being Epic - the source code for all this is available for you to pore over, and we'll eagerly take feedback (or pull requests) to improve on it! Some quick pointers - the tool used for downloading is in the repository under Engine/Source/Programs/GitDependencies, and the manifests of files to download are Engine/Build/Commit.gitdeps.xml and Engine/Build/Promoted.gitdeps.xml.
                              Hi,

                              I just puled the latest git version and I don't have any oof the files bolded. How can I know which files it is downloading, and where are they saved?

                              I also tried to interrupt the download and resume it (something I should be able to do according to the original post), but it restart from 0%. Why?

                              Comment


                                #60
                                Is there a particular font, type of font, or font system that is needed for Linux versions of the Unreal Engine SDK? On Linux Mint 17.3 I was able to compile everything (supposedly successfully, no errors) and run UE4Editor I get this:

                                Click image for larger version

Name:	UE4_notworking.jpg
Views:	1
Size:	114.8 KB
ID:	1122034

                                I tried updating some libraries, to newer versions (when possible, considering availability and compatibility) and recompiling, several times, but always the same thing. But since the writing is all messed up, it occurred to me that maybe I just needed a new font. Unfortunately, I can't read the apparent error message in the bottom right of the screen. Does anyone have any ideas what I'm missing or what's going on here?

                                Comment

                                Working...
                                X