Announcement

Collapse
No announcement yet.

Current state for Linux development

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Current state for Linux development

    Hiya,

    first of all i'm sorry if i'm posting in the wrong section, i couldn't find one that would fit better to this topic.
    I'm a programmer, for work I stick to Windows because, at the moment, we only care about Linux for the server side bits and that's alright, working as you would expect.
    Outside of my job I enjoy developing stuff for and on Linux. Now UE4 is making this extremely hard and painful.
    I appreciate the effort you guys put in the setup process, that is very smooth and reducing the wiki from what it was to "run Setup.sh and GenerateProjectFiles.sh" was just awesome.
    However using the engine itself is horrible, especially compared to Windows, I had a lot of hassle to set everything up and yet it's not working as it should.
    In first place there is a massive struggle to pick the right IDE but i suppose this is not completely Epic's fault. There are a few choices that one could pick from like QtCreator, KDevelop, VSCode, Clion etc etc, all good if only any of these would just work.
    I'm quite in love with CLion so that was my first pick. Well it turns out that after it eats 7-9Gb or so to read debug symbols (hey, java...) and building the project like normal it just hangs to building (I think? No idea) that "Fake Target" executable that will never run. Alright, scratch that and let's stick to vs code. I used it before and it worked, UE4 would generate a list of tasks that the editor can run and you are golden.
    I remember, again, it used to work, now it hangs while reading symbols (i'm just guessing, the only thing i can read is "Module loaded: /home/jury/Documents/dev/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-ActorPickerMode.so. Symbols loaded").
    Alright, i thought, maybe it's because of Arch, i've read ubuntu is the targeted platform so I erased my arch installation (sigh) and installed KDE Neon (ubuntu 18.04 methinks). Nein. Same error.
    Eventually i found out that if i use gdb instead of lldb it would start and even be slightly faster (I'd say normal editor speed) than lldb (yes, because starting lldb UE4Editor from the terminal would just work but that'd be slow AF).
    So at this point i can place breakpoints around and expect them to work, but it only took a day of hassle (and more considering I already tried qtcreator and Kdevelop in the past with no results - and anyway i'm not sure i would like to use those IDEs...)
    Another big issue i'm facing is the general slowness of the editor.
    The viewport and interaction with it is just fine, but using the editor, opening windows such as an actor blueprint or an animation blueprint is just painful and feel like you get the shittiest machine ever because is so sloppy and slooooow.
    Finally when I'm debugging the editor with gdb I got no option to hot recompile which is annoying because it takes ages to reopen the editor every change (at least 10 times slower compared to windows), but the button is there and working when not debugging so ¯\_(ツ)_/¯.

    Probably this is just a blamey topic, I don't expect this stuff to get automagically solved within the next week or at all, but I don't know, it feels really bad that I have to stick to Windows because the editor works so poorly in Linux. Unity has a "beta" linux version that works just well and it seems unreal (...) that we can't have the same.

    I wish someone would reply to this topic telling me i've been doing something wrong or that using distro xx with de yy works just fine.
    Am i the only one who's having those issues? What are your experiences with UE4 on Linux?

    Sorry for the wall of text and thanks for wasting your time reading and (maybe) replying to this :-)

    Jury

    #2
    Hi Jury,

    I am also having mixed experiences with UE4 on Linux.. Started a few days ago, actually, and I am at a point where things are almost nice to work with. On a sidenote, your post helped me
    I run a Debian and use UE4.21.1 with -opengl switch (I have limited/no vulkan support) and vscode with gdb with a debug setting for attach.
    Speed of Editor and Blueprint Windows is okay for me - it is kinda slow but then my machine is not particularly made for this. (I am away from my usual dev system (windows) and use my laptop)

    Connecting the process for debugging takes a long time, but then again, it's for serious debugging purposes which I hope I won't need too often.

    Best,
    DM

    Comment

    Working...
    X