Announcement

Collapse
No announcement yet.

Invalid lightmap settings

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Invalid lightmap settings

    I want to make a prototype map for testing but when I convert my brush to a Static Mesh i get "Invalid lightmap settings" error.
    When i turn on "Overridden light map res" it shows the texture how it should but when I build lightning it turns black.
    It's not the texture like you can see on the image it's the same texture on the floor.
    But the floor is an imported mesh and not from an brush.

    Tech artist at CrozzRoads.
    My Linkedin Stefan Poppe.
    Personal Portfolio StefanCG.

    #2
    Change the lightmap resolution (you can find that in the static mesh editor) to a higher value -> not 0

    Comment


      #3
      It's on 64 allready i even turned it up to 6400 but still black.

      Tech artist at CrozzRoads.
      My Linkedin Stefan Poppe.
      Personal Portfolio StefanCG.

      Comment


        #4
        Then you have to create a 2nd uv channel -> Window - Generate Unique UVs - and then create a 2nd one

        Comment


          #5
          Thank you it's not black anymore when I create a new UV and then use "Layout using 0 channel" but it ***** up my texture?

          Tech artist at CrozzRoads.
          My Linkedin Stefan Poppe.
          Personal Portfolio StefanCG.

          Comment


            #6
            Omg i didn't change the light map coordinate index xD
            It's solved thank you ^^
            Tech artist at CrozzRoads.
            My Linkedin Stefan Poppe.
            Personal Portfolio StefanCG.

            Comment


              #7
              I had to open the static mesh and change the lightmap resolution from 0 to 64. In the level editor it was showing as using the default of 64.

              Comment


                #8
                I went to windows> generate unique UV's - then I have the tab open and the settings are -
                create new
                UV channel to save results to - If I touch this I get an error "generateUV's failed, incorrect number of texcoords"
                Limit maximum stretching - 0.5
                (grayed out) limit maximum number of charts - 100
                limit spacing between charts - 1

                I can successfully generate a UV map but my model is still black after I rebuild the lighting.
                Current Projects -Cat Interstellar
                Lead Developer - Ionized Games

                Comment


                  #9
                  I am getting is error when I try to generate unique Uvs. 'GenerateUV's failed, couldn't convert to a D3DXMesh' Please help, this seems to be a common issue that is not address from my research.

                  Comment


                    #10
                    Originally posted by Trugb31 View Post
                    I am getting is error when I try to generate unique Uvs. 'GenerateUV's failed, couldn't convert to a D3DXMesh' Please help, this seems to be a common issue that is not address from my research.
                    It mostly happens when your mesh has too many polygons.
                    FREE VR Drum Kit Project
                    FREE Color LUT Collection
                    FREE Physics Driven Spacecraft Project
                    FREE GTA Style Vehicle Interaction
                    Dynamic DoF(Depth of Field)
                    Camera Crossfade

                    Comment


                      #11
                      Ok, But how do I fix this.

                      Comment


                        #12
                        Just create your lightmap in a 3d program like blender, that's the easiest way to solve your problem

                        https://www.youtube.com/watch?v=z5yc-bKbHyc

                        Comment


                          #13
                          Remember Lightmap UVs CANNOT OVERLAP. The editor can be a bit of a **** as well with spacing so make sure there's plenty of space between the uv spaces, or you will get blackened models and errors.

                          Comment


                            #14
                            Without Maya or blender :

                            - Create brush
                            - Transform with "Create Static Mesh" button
                            - Rename your mesh, then double-click on the new mesh thumbnail (Enter in the Mesh editor)

                            - Below Static Mesh Settings, change "Light Map resolution" to 128
                            - Click on the top menu "Window", then click on "Generate Unique UVs)
                            - Click on Apply
                            - Below Static Mesh Settings, open bottom panel and change "Light Map Coordinate Index" to 1
                            - Save your Mesh and Build

                            Comment


                              #15
                              Originally posted by Achitakayoh View Post
                              Without Maya or blender :

                              - Create brush
                              - Transform with "Create Static Mesh" button
                              - Rename your mesh, then double-click on the new mesh thumbnail (Enter in the Mesh editor)


                              - Below Static Mesh Settings, change "Light Map resolution" to 128
                              - Click on the top menu "Window", then click on "Generate Unique UVs)
                              - Click on Apply
                              - Below Static Mesh Settings, open bottom panel and change "Light Map Coordinate Index" to 1
                              - Save your Mesh and Build

                              My mesh is still black after that
                              Work on what you love!
                              You can see things I've worked on
                              It's not great, but I'm learning!

                              Comment

                              Working...
                              X