Announcement

Collapse
No announcement yet.

Texture streaming pool over

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Texture streaming pool over

    When I uploaded a lot of texture to the engine, I have a problem "Texture streaming pool over" As far as I understand it is due to memory overload. But i have question: is the due quantity textures or because of the quality?

    And I entered the command "stat streaming" and appear on the screen, these stats. I do not quite understand how to apply the texture on these parameters. Who could explain?
    Click image for larger version

Name:	TSPO.jpg
Views:	1
Size:	122.4 KB
ID:	1193007

    I have about 400 textures. And almost all textures are resolution of 2048x2048. Can I reduce the resolution textures, or reduce their number?

    #2
    The first thing you want to do is reduce the amount of textures you're using- you are using more than you should, so you should do a pass on that and reduce the sheer amount of textures you're using in your level. Why are you using 400 textures for what looks like a super simple game?

    Next thing to look at is your texture sizes. If most of 400 textures are 2k; you have a pretty big problem. I guarantee you don't need that many 2k textures. There's no single button solution I can give you on this; this is more technique and game dev experience (knowing and planning on how many textures and sizes you need).

    Optimization is vital in game development. What you need to have done is a (heavy) optimization pass on your project.

    Do a search online for texture packing and tiling textures. These are topics you need to get familiar with.
    Lighting Technical Director | Co-Founder
    Game School Online

    Want to learn Unreal Engine 4 and game development from professionals that have worked on games at studios like Call of Duty, Battlefield, Last of Us, Riot Games, Blizzard, and more? Checkout Game School Online, the first ever fully featured, structured online game development training platform that is completely free, no strings attached: https://beta.gameschoolonline.com/

    Comment


      #3
      Thanks for the answer! Yes, I knew that a lot of texture processor overload. I think to reduce them. Just the greater the variety of textures, the more colorful the scene. But I understand you, of course, my project is not really a game. So I think the better to reduce the resolution of the textures for small objects.

      Comment


        #4
        Im expieriencing the exact same thing with the automotive material set.

        Click image for larger version

Name:	poolsize.JPG
Views:	1
Size:	89.5 KB
ID:	1114876

        Does tht mean the automotive materials are too good for UE4?

        Comment


          #5
          UPDATE

          I just found out what happened.
          The scalability adjustment clipped the pool (without me realizing it).

          Code:
          Cmd: r.Streaming.PoolSize
          r.Streaming.PoolSize = "800"      LastSetBy: Scalability
          Cmd: r.Streaming.PoolSize 2000
          r.Streaming.PoolSize = "2000"
          LogContentStreaming: Texture pool size now 2000 MB
          So just resetting the poolsize will fix things back to normal

          Comment


            #6
            I have the same issue, even if that's an older post.
            So what's the exact command to reset the pool?

            what line do you have to enter?

            Comment


              #7
              Hey Bernhard,
              I would suggest just overwriting the default scalability settings.
              the docs on scalability will give you the exact text to use and file location.

              keep in mind the lowest target GFX you want for your project to work on when published to set the lowest possible pool size accordingly. (2gb of pool max?).

              Comment

              Working...
              X