Announcement

Collapse
No announcement yet.

Get rid of motion blur due to camera movement

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Get rid of motion blur due to camera movement

    Hey all, I'm having a couple problems with motion blur.

    1. When the camera rotates, the entire screen is blurred, which actually makes me feel kinda dizzy. Is it possible to disable this, but keep motion blur for basic object movement?

    2. The first person weapons are also blurred when the camera moves. Is it possible to disable motion blur on individual objects?



    Thanks in advance
    Fully dynamic Time of Day System blueprint: https://forums.unrealengine.com/show...e-of-Day-Setup Download it for free now!

    #2
    Find the 'Global PostProcess' actor in the Scene Outliner and select it. Then go to the Details tab and find the Motion Blur panel and set the amount to 0.0 and it should now be turned off. If you are using a Post Process Volume(s) then do the same to those.

    Comment


      #3
      That disables motion blur completely, I would like to keep it for fast-moving objects if possible

      Also, I believe you could fix #2 in UDK by setting the gun's base to be the player or camera, but I don't see anywhere to do that here.
      Fully dynamic Time of Day System blueprint: https://forums.unrealengine.com/show...e-of-Day-Setup Download it for free now!

      Comment


        #4
        Oh I'm sorry, I misunderstood.

        I do not know of a way to do that.

        Comment


          #5
          That's fine, thanks for trying

          I guess it's not possible yet, there are a lot of basic features like this missing. I'll just do without any motion blur for now
          Fully dynamic Time of Day System blueprint: https://forums.unrealengine.com/show...e-of-Day-Setup Download it for free now!

          Comment


            #6
            I haven't looked into it myself, but would it be something that you could combine with Depth of Field to achieve the effect you want? Check out the Example Content; And mess around it with, it might help you do what you're trying to do.

            If not, eh. I tried.
            KITATUS
            "Information shouldn't be behind a paywall, It should be free for all!"

            Comment


              #7
              We also need to disable moblur on an single object, anyone found how to achieve this?
              David Hanson
              You can follow our FPS development here: https://www.facebook.com/storm.united.mmofps

              Comment


                #8
                Hey, I know this advice might be a lit late but I imagine you would achieve this with render layers. I'm not even sure if Unreal 4 supports customizing render layers. I have not looked into that yet but it is how you would do it in other engines.

                As an example you may render a motion blur layer that only has your blurring objects, it would do another render pass with non-blurred objects then layer the two. Usually the same principle used for things that glow, the glow effect is usually just another render layer.

                Just keep in mind that with each render layer you take a performance hit. Hope this points you in the right direction, even though it is several months late.

                On a similar note you can override the default global motion blur settings on each individual camera. This can be adjusted and controlled via blueprints but it is a camera option not object based. Object based things would still be a new render layer.

                Comment


                  #9
                  This can be done with post process volumes. I applied it to bullets.

                  Comment

                  Working...
                  X