Announcement

Collapse
No announcement yet.

Problems on UVs and After Importing Architecture Model

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Problems on UVs and After Importing Architecture Model

    Hello guys,

    I'm new on Unreal Engine system and I've tried many times to learn and find a solution about importing Architecture model from Archicad 18 (Software I'm using to make 3D architecture model). So from Archicad, I save the 3D model into .skp (SketchUp) format and then I export it from SketchUp into .fbx format. After that I import the .fbx to UE4, and some error message comes out, it says:

    "No smoothing group information was found in this FBX scene. Please make sure to enable the "Export Smoothing Groups" option in the FBX Exporter plug-in before exporting the file. Even for tools that do not support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing."

    And then I close the message log. And another prob is this .fbx file that I imported comes into one big mesh (when I click the floor, all thing selected). The next thing is, I build the light and another message pop out, it says:

    "Lightmap UV overlapping by 1.5%. Please adjust content-Enable Error Coloring to visualize"
    "Object has overlapping UVs"

    And all the shadows and lighting screwed up. I've tried to fix those UVs problems by searching from the internet and some says try to Generate Unique UVs, and I've tried it but still the same error.

    So, I hope somebody could help me. Thanks before and sorry for the long post !

    Mos.
    Attached Files

    #2
    U have to redo the entire UV map with an 3D Programm and before that you have to delete the old ones complete.

    Comment


      #3
      the current workflow method is to use a 3rd party program to model stuff, or at least build the UV maps in that

      Comment


        #4
        1. you have to enable "export smoothing groups" in your 3d program -> I dont know if you can do that in Archicad or SketchUp
        2. disable "combine meshes" in the import window
        3. you have to create a proper lightmap: http://www.worldofleveldesign.com/ca...el-in-maya.php

        Comment


          #5
          Hi guys, sorry for late reply, been busy lately at uni

          Btw, thanks so much guys for the help and replies!
          I'll try once again to rebuild the UV map. Hope it'll solve the errors.

          Mos.

          Comment


            #6
            Originally posted by fighter5347 View Post
            1. you have to enable "export smoothing groups" in your 3d program -> I dont know if you can do that in Archicad or SketchUp
            2. disable "combine meshes" in the import window
            3. you have to create a proper lightmap: http://www.worldofleveldesign.com/ca...el-in-maya.php
            Hi, thanks for the help

            It seems there's no smoothing group option in Archicad, but I've seen it in 3dsmax. I guess I'll export it to 3dsmax first to get the smoothing group opt
            And also thank you for the link. I'll try to learn more to rebuild this UV maps.

            Comment


              #7
              Hi! year 2018 and I still have the same problem :c
              Im using cad 21! And I have the overlapping issue.
              Got any ideas?!
              I have 0 knoledge in autodesk software but i can learn if necesary

              Thanks c:

              Comment

              Working...
              X