Announcement

Collapse
No announcement yet.

Landscape editor not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    its finally working. a low tech solution copy and pasted all actors including lights and atmospheric fog into a new project then added a new landscape.
    still no idea what caused i, if it was lighting it would follow into the new project so ill just call it a glitch. thanks fighter 5347

    Leave a comment:


  • replied
    Originally posted by ahuss View Post
    is there any way i can just copy and paste this into a new project, would selecting all the actors in the scene outliner and copy and pasting them into a new project keep everything the same, with all positions in the same place, although that could replicate the issue.
    Select everything in the scene outliner - ctrl + c - open the new level - ctrl + v -> now everything is still at the same place
    What happens when you add a skylight to your level?

    Leave a comment:


  • replied
    anybody? answerhub hasnt had any hits yet

    Leave a comment:


  • replied
    Click image for larger version

Name:	ue4_1.jpg
Views:	1
Size:	559.2 KB
ID:	1086757Click image for larger version

Name:	ue4_4.jpg
Views:	1
Size:	547.4 KB
ID:	1086756
    Originally posted by fighter5347 View Post
    -post a pic that shows the scene + the scene outliner
    -report it on answerhub -> https://answers.unrealengine.com/
    okay ill do that and ill post them here too.
    The thing is if I start a new project with a starter content it works but if i create a new level in the old project it wont.
    is there any way i can just copy and paste this into a new project, would selecting all the actors in the scene outliner and copy and pasting them into a new project keep everything the same, with all positions in the same place, although that could replicate the issue.

    the first image is a new project and the second the existing one
    Last edited by ahuss; 08-31-2015, 01:55 PM. Reason: added images

    Leave a comment:


  • replied
    -post a pic that shows the scene + the scene outliner
    -report it on answerhub -> https://answers.unrealengine.com/

    Leave a comment:


  • replied
    anybody. any suggestions

    Leave a comment:


  • replied
    apologies for the delay
    Ive been thinking about what could be wrong. I checked the scene outliner the eye is open on everything.
    What happened is that I clicked create new on landscape manage and the atmosphere disappeared. The landscape wont show up. I checked my lights and readded my lightmass importance volume. Nothing is here, even if i add a new atmosphere or light nothing changes. Only lights can be manipulated

    Leave a comment:


  • replied
    That's really strange -> check if the "eye" in the outliner is closed or open + post your detailed steps so that we can try to reproduce your problem + send a picture

    Leave a comment:


  • replied
    Thanks for the warm welcome everyone.
    Sorry I took so long to reply.
    So I've been working on your suggestions and trying to fix this. Now when I say "Black" what I mean is that it becomes like when you make a new level without the starter content.
    Now I've just realised that when I started adding in landscapes my atmospheric fog also disappeared. As in it is there in the scene outliner but not the viewport. I set it up, didnt touch it after that because I had difficulties with the lighting system so left it as the best i could get it. But I've noticed it doesnt appear anymore in the viewport. Same with the landscape yet tehy show up in the outline. I tried rebuilding everything and changed from lit to unlit, checked details but I can't figure it out

    Leave a comment:


  • replied
    -use one of the template levels and try it again
    -so you see a "landscape" actor in the scene outliner?
    -make sure that you havent selected a material in your content browser when you create a landscape -> when it's not a landscape material/you havent painted on it, the landscape will turn black

    Leave a comment:


  • replied
    Hey, welcome to the forums. What do you mean by "it stays black"? Did you remove all the lighting in the level? If so, try throwing in a directional light (found in the top left panel under lights), then the viewport should be light with a blue sky. Try creating the landscape again.

    Leave a comment:


  • replied
    It isnt a lighting problem. tried lit and unlit, nothing showed up. If I press F on it I get zoomed out to about 5000cm in the z scale. I've moved the coordinates to the origin manually but nothing shows up.

    Leave a comment:


  • replied
    Hi Thejamsh,
    Yes I realised that my posts had to be approved when I submitted the second one, Sorry.
    I'll try your suggestion and put in extra light. It could have been something to do with lights because I changed my Lightmap calculation parameter(cant remember whats its called, something potential.)
    my environment had a room in it and im not sure, i may have been it lit mode
    Thanks

    Leave a comment:


  • replied
    Hey Ahuss, welcome to the forums Don't worry about posts going missing, I think it's the first 5-10 posts we moderators have to 'approve' so they'll be around somewhere. I just did this one to get you started.

    Can't help that much with the landscape side of things I'm afraid.. did you start in a completely blank environment with nothing in the Scene Outliner? If so, try adding a directional light to the level. You might have the viewport in 'lit' mode and therefore all you'll see if you have no lights is the void... you could also change the viewport settings to 'unlit' mode (top left of the viewport)

    Leave a comment:


  • started a topic Landscape editor not working

    Landscape editor not working

    Hi,
    I'm new here and to Game development. I posted here about 30 mins ago and somehow its gone missing. Can't find it on my profile too.

    Anyway to the issue. I'm learning UE4 from digital tutors introduction to unreal engine 4. I've followed it to the landscape editor, pretty much to the letter. Now with this I click on the landscape editor and get a green grid I can place around. I click on create and it should bring up a grey plane, that I can sculpt. This does not happen, it remains black and I can not use any of the landscape tools, yet it shows two actors in the Scene Outliner.

    Side note: it felt great finally starting to learn how to make games, my first map is just a room copied from the tutorials and isnt very impressive, but theres just something about your own work. It feels great. Feels EPIC.
Working...
X