Announcement

Collapse
No announcement yet.

Rolling ball jumps on flat surface

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Also having this issue, will try the suggested solutions and report back.

    Comment


      #32
      I had some success with placing a constraint in the BP with the root declared and nothing in the second component (this then seems to default to world.
      all constraints are set as free and I then put an linear motor speed zero on the z axis I set strength to 500
      This effectively dampens the vertical motion.. shame we have to do this tough

      Paul G

      Comment


        #33
        Originally posted by Biggumzzz View Post
        4.22.0 shows a whole different BodySetup.cpp file now. It looks almost completely rewritten. Thankyou for giving out this vital information to fix this long lasting Physics Issue. I thought I'd never get an answer to this. But still working on it.. Right now I'm completely stuck on what to do and how to fix this for 4.22... I was hoping one of ya'll can help look into that. Hope you guys can get back to me on this ASAP. This is crazy news to see we found some files that we can edit back to 4.19's original state!
        Seems to have been rewritten in preparation for Chaos physics. That line of code can now be found in \Engine\Source\Runtime\Engine\Private\PhysicsEngine\PhysicsGeometryPhysX.cpp. Setting that line back to the 4.19 version in there has worked for me.

        Comment


          #34
          same issu and the contact max offset don't change this problem ! pls help ^^

          Comment


            #35
            Originally posted by Sly401 View Post
            I had some success with placing a constraint in the BP with the root declared and nothing in the second component (this then seems to default to world.
            all constraints are set as free and I then put an linear motor speed zero on the z axis I set strength to 500
            This effectively dampens the vertical motion.. shame we have to do this tough

            Paul G
            Was this succes for 4.22? If so, could you specify? I am trying to fix the issue without compiling from source. If you have a workaround I will be grateful.
            Evolvation | HyperReuts

            Comment


              #36
              Originally posted by patrickolden View Post
              Also having this issue, will try the suggested solutions and report back.
              Do you have any luck.
              Evolvation | HyperReuts

              Comment


                #37
                Originally posted by ERuts View Post

                Was this succes for 4.22? If so, could you specify? I am trying to fix the issue without compiling from source. If you have a workaround I will be grateful.
                Sorry I have not yet tried 4.22

                Paul G

                Comment


                  #38
                  Hey all,

                  I've put in a new bug for this as: https://issues.unrealengine.com/issue/UE-74451

                  Cheers!

                  Comment


                    #39
                    Thanks Alex, good news at last
                    Paul G

                    Comment


                      #40
                      Originally posted by Sly401 View Post

                      Sorry I have not yet tried 4.22

                      Paul G
                      K. That's a pity. I have filed an official bug report. (as seen in the link posted by Alex) Hope it gets solved within the official build.
                      Evolvation | HyperReuts

                      Comment


                        #41
                        Is there any update to this? Or does anybody know if you can add multiple physical materials to a single object to create "zones" of friction? For me that's why I have multiple objects lined up but if I could create a "friction map" that would work too

                        Comment


                          #42
                          Fixed in 4.22.3 seems to be best impimentation yet (for me )
                          Paul G

                          Comment


                            #43
                            As of 4.23 they do

                            HTML Code:
                                        const float RestOffset = ComputeRestOffset(Elem);
                                        const float ContactOffset = ComputeContactOffset(Geom) + RestOffset;
                                        VisitorFunc(Elem, Geom, PLocalPose, ContactOffset, RestOffset);
                            It seems like each Elem (Body Element?) has its own RestOffset but I see no way to edit that in editor but maybe it takes it from min/max contact offsets?

                            In which case this should be working as it did before but even in 4.23 my physics isn't as stable as it was in 4.19 which is why I was reading through this and commenting here.


                            Assuming an element can be a PxShape then setResetoffset has this description.

                            /**
                            \brief Sets the rest offset.

                            Two shapes will come to rest at a distance equal to the sum of their restOffset values. If the restOffset is 0, they should converge to touching
                            exactly. Having a restOffset greater than zero is useful to have objects slide smoothly, so that they do not get hung up on irregularities of
                            each others' surfaces.

                            <b>Default:</b> 0.0f

                            <b>Sleeping:</b> Does <b>NOT</b> wake the associated actor up automatically.

                            \param[in] restOffset <b>Range:</b> (-PX_MAX_F32, contactOffset)

                            see getRestOffset setContactOffset
                            */

                            And FKShapeElem has a RestOffset which says

                            /** Offset used when generating contact points. This allows you to smooth out
                            the Minkowski sum by radius R. Useful for making objects slide smoothly
                            on top of irregularities */

                            I'm just not sure if the contact settings in the editor modifies these or not. I guess I'll play with higher values and see what happens. I was on the lower .01 and .05 min/max in 4.19 working fine but in 4.23 getting bounciness again.

                            Then again there is a ComputeContactOffset which I'd think uses the settings from editor but the ComputeRestOffset uses.. IDK yet.

                            Also states its been fixed here https://issues.unrealengine.com/issue/UE-68523

                            But it isn't in the release branch yet.
                            Last edited by Nonlin; 10-25-2019, 11:39 AM.

                            Comment


                              #44
                              For those coming here in search of a solution, in 4.23.x (and probably later versions as well) you need to set the Min and Max Contact Offset inside Project Settings --> Physics to very small values (e.g. 0.0001 and 0.001 respectively). No need to activate CCD or physics sub-stepping.
                              CTO | Head of VR Development - Visit us at http://humanxr.com
                              My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

                              Comment


                                #45
                                I'm experiencing the same issue with version 4.24.3. The change in contact offset just let a bit higher rolling speed, but my wheels getting bumps around speed 12m/s (~46km/h) on flat surface.
                                Is anybody has description about how possible to modify the earlier mentioned PhysicsGeometryPhysX.cpp ? Thanks for any answer.

                                Comment

                                Working...
                                X