Announcement

Collapse
No announcement yet.

Problem with exporting models

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with exporting models

    When you export a model error:
    Head has degenerate tangent bases which will result in incorrect shading. Consider enabling Recompute Tangents in the mesh's Build Settings.
    Work in 3d max file format Fbx help solve problemmu.
    Sorry for my English using Google translator)))Click image for larger version

Name:	Без имени-1.jpg
Views:	1
Size:	114.2 KB
ID:	1134639

    #2
    Export it as FBX 2013 and dont forget to UV map the mesh before that.
    FREE VR Drum Kit Project
    FREE Color LUT Collection
    FREE Physics Driven Spacecraft Project
    FREE GTA Style Vehicle Interaction
    Dynamic DoF(Depth of Field)
    Camera Crossfade

    Comment


      #3
      I'm having the same problem with one of my meshes. Its not an issue with exporting as FBX 2013 or 2014 it's something else. still working on it.

      Comment


        #4
        Double click onto your static mesh in the UE4 -> Select the recompute tangents/normals and click save

        Click image for larger version

Name:	tangents.jpg
Views:	2
Size:	31.0 KB
ID:	1050927

        Comment


          #5
          I have this problem with one of my meshes. The UVs are completely laid out, Recompute Tangents is checked. It looks great until I bake the lighting, and then it's just a total mess. Can't figure out what's wrong.

          Comment


            #6
            Originally posted by emomobile View Post
            I have this problem with one of my meshes. The UVs are completely laid out, Recompute Tangents is checked. It looks great until I bake the lighting, and then it's just a total mess. Can't figure out what's wrong.
            The issue in the screenshot is an issue with smoothing/vertex normals. If you don't have a problem until lighting is built then it's either a problem with your lightmap UV's or your lightmap resolution is too low.

            Comment


              #7
              It's the weirdest thing, because my uvs are laid out completely, no overlapping whatsoever. But when I bake the lighting it says that UVs are overlapping by 94%. I thought of having UE4 generate it's own UVs for the lightmap on a second UV channel, but when I try it says "Generate UVs failed. Couldn't convert to a D3DXMesh" I have a screenshot, but it won't upload for some reason >_<
              Attached Files

              Comment


                #8
                Hi Enomobile,

                Are your second UV's coordinates set properly? You can check this in the Mesh Editor/Viewer and in the details panel look for Lightmap coordinate index is set to 1. If it's set to 0 it's using the texture UV map instead.

                If you're still having trouble, post a screenshot of your second UV channel here. You can view this in the toolbar by selecting the UV tab and then a few buttons to the right change the UV Channel from 0 to 1 in the drop down.

                This way we can see if you've got a good second UV layout and offer some help.

                Thank you!

                Tim
                Tim Hobson | Learning Resources | Epic Games
                UE4 Documentation
                Wiki Troubleshooting Guides: Lighting | Swarm Agent | Destructibles |
                _____________________________________________
                Follow me on Twitter @TimHobsonUE4 | My Personal Website
                Photons Be Free: Mini-Tutorials and other Curiosities

                Comment


                  #9
                  Hmmmm. It seems my second UV channel is a total mess. But I don't want it to use my second channel (I didn't even know it had a second channel). How do I tell it to use channel 0?

                  Comment


                    #10
                    Open up the static mesh and check Static Mesh Settings on the right side. Click the arrow to see advanced settings and set Light Map Coordinate Index to 0.
                    FREE VR Drum Kit Project
                    FREE Color LUT Collection
                    FREE Physics Driven Spacecraft Project
                    FREE GTA Style Vehicle Interaction
                    Dynamic DoF(Depth of Field)
                    Camera Crossfade

                    Comment


                      #11
                      You can simply change it from 1 to 0 in the Details panel in the mesh viewer. If you have overlapping UVs in your texture UV (Channel 0) you will still have overlapping UVs issue. This is because there needs to be a channel for shadow information to be baked to. If there are overlapping UVs those UV islands will share the same shadow information which will lead to your model looking strange.

                      You can always set it to be dynamic if you want to avoid lightmaps but this can cause a performance overhead whereas a good lightmap has zero performance overhead as the shadow information is baked into this texture map rather than being computed at runtime.

                      Thanks!

                      Tim
                      Tim Hobson | Learning Resources | Epic Games
                      UE4 Documentation
                      Wiki Troubleshooting Guides: Lighting | Swarm Agent | Destructibles |
                      _____________________________________________
                      Follow me on Twitter @TimHobsonUE4 | My Personal Website
                      Photons Be Free: Mini-Tutorials and other Curiosities

                      Comment


                        #12
                        Bingo. You the man, Tim. ^_^

                        Comment


                          #13
                          No Problem!

                          Glad you got it working!

                          Tim
                          Tim Hobson | Learning Resources | Epic Games
                          UE4 Documentation
                          Wiki Troubleshooting Guides: Lighting | Swarm Agent | Destructibles |
                          _____________________________________________
                          Follow me on Twitter @TimHobsonUE4 | My Personal Website
                          Photons Be Free: Mini-Tutorials and other Curiosities

                          Comment


                            #14
                            problems

                            desk has degenerate tangent bases which will result in incorrect shading. Consider enabling Recompute Tangents in the mesh's Build Settings.
                            image one is what it should look like and image two is what it looks looks like in unreal 4 plz helpClick image for larger version

Name:	desk.png
Views:	1
Size:	507.0 KB
ID:	1052447Click image for larger version

Name:	deskAfter.jpg
Views:	1
Size:	490.5 KB
ID:	1052448

                            Comment


                              #15
                              Hi Kjethrow,

                              You're looking at the mesh in the mesh viewer/editor. You may want to place this in the level, add some lighting, then build lighting to see your mesh as it will appear in game. The lighting in the mesh viewer/editor does not have built lighting so it's completely representative of an in-game look.

                              On a side note:

                              I noticed your mesh does have 5 UV channels. The top of the mesh does look like it's stretched which will likely cause you an issue as well, as there is a difference between that and the first image.

                              Also make sure that the proper UV is selected for the lightmap channel. If you're not familiar with how lightmaps work just ask and I'll give you some information.

                              Tim
                              Tim Hobson | Learning Resources | Epic Games
                              UE4 Documentation
                              Wiki Troubleshooting Guides: Lighting | Swarm Agent | Destructibles |
                              _____________________________________________
                              Follow me on Twitter @TimHobsonUE4 | My Personal Website
                              Photons Be Free: Mini-Tutorials and other Curiosities

                              Comment

                              Working...
                              X